Recent

Author Topic: Fpcupdeluxe  (Read 592012 times)

valdir.marcos

  • Hero Member
  • *****
  • Posts: 1059
Re: Fpcupdeluxe
« Reply #1875 on: July 19, 2021, 11:30:08 pm »
For the Daredevils out there ...  ;)
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/tag/1.8.2v
Can be used as installer for the new Gitlab sources.
Have now everything on fpcupdeluxe moved from SVN to GIT?
Thanks for your hard work!

lucamar

  • Hero Member
  • *****
  • Posts: 4219
Re: Fpcupdeluxe
« Reply #1876 on: July 20, 2021, 01:56:25 am »
Have now everything on fpcupdeluxe moved from SVN to GIT?

AFAIK, fpcupdeluxe (and fpcup IIRC) has always been in GitHub. Only now both FPC and Lazarus are moving to GitLab, though (it seems) it's not yet completely operational (or at least it's still in the "testing" phase); hence the "daredevilness" of getting them from there :D
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus/FPC 2.0.8/3.0.4 & 2.0.12/3.2.0 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

af0815

  • Hero Member
  • *****
  • Posts: 703
Re: Fpcupdeluxe
« Reply #1877 on: July 20, 2021, 08:08:32 am »
I see it more - for fpcupdeluxe it is not important where the source are - on svn, git or mercurial based repos - fpcupdeluxe speek all the languages/repos  :-) It is only a configuration question. And since the day where fpcup work, you can insert repos. The GUI is only 'sugar' for easier handling.

Keep in mind, fpcupdeluxe is not magic, it does the same you have to do if you build a compiler/crosscompiler. Every commando fpcupdeluxe use, is the same you use. The magic is the experinece and hard work of Alfred, to find out the secrets and hidden features, bring them in a automated way to stable work. And the longtime support of Alfred is absolutly top and should be acknowledged. I think it is the same long and hard way, like Florian and other have done with the compiler itself.   
« Last Edit: July 20, 2021, 08:13:55 am by af0815 »
regards
Andreas

El Salvador

  • Jr. Member
  • **
  • Posts: 64
Re: Fpcupdeluxe
« Reply #1878 on: July 20, 2021, 03:09:02 pm »
For the Daredevils out there ...  ;)
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/tag/1.8.2v
Can be used as installer for the new Gitlab sources.
A quick question: but the configuration of the various versions of FPC & Lazarus are hard code? If for example, Lazarus version 2.10 is released (a random value), to install it with FPCUpdeluxe, do we have to wait for a new version or can I modify a configuration file?

Gustavo 'Gus' Carreno

  • Hero Member
  • *****
  • Posts: 724
  • Professional amateur ;-P
Re: Fpcupdeluxe
« Reply #1879 on: July 27, 2021, 04:20:17 pm »
Hey Don,

Yesterday I tried to resolve the fact that my Lazarus 2.0.6/FPC 3.0.4 was not working.

All of a sudden, without me doing anything but update the system, Lazarus wasn't starting. So I started it from the command line and it gave me an immediate Segmentation Fault and that was it.

In trying to solve the issue, I started by just trying to re-compile. I thought: It's hella hot, maybe Lazarus is sitting in a bad sector of my 2nd hand HDD.

Well, that was not it cuz in the end I deleted the whole thing and started from scratch and I figured out that the first stage of the compiler bootstrapping(ppc1) was ALSO segmentation faulting.

So at this moment I've given up having a 2.0.6/3.0.4 combo.

My question is: How can I tell fpcupdeluxe to use the next compiler up on the bootstrap list, so I can assess if it's a compiler issue or an Ubuntu issue.

BTW, my system is Ubuntu 21.04 64b updated as of 2 or 3 days ago.

Many thanks in advance Don!!

Cheers,
Gus
Lazarus 2.3.0(trunk) FPC 3.3.1(trunk) Ubuntu 21.04 64b Dark Theme
Lazarus 2.0.12(stable) FPC 3.2.2(stable) Ubuntu 21.04 64b Dark Theme
http://github.com/gcarreno

BSaidus

  • Sr. Member
  • ****
  • Posts: 384
  • lazarus 1.8.4 Win8.1 / cross FreeBSD
Re: Fpcupdeluxe
« Reply #1880 on: July 27, 2021, 10:40:33 pm »
Hi all people on this forum & thank you for your efforts,
I want to compile a cross compiler, packages, RTL from Windows to ARM/FreeBSD, and I use the last version of fpcupdeluxe but a message : No valid CPU / Crosscompiler found.
PS: for ARM/LINUX it works well.
So, is there any chance to implemente it ??
if I use Fpccupdeluxe on FreeBSD, would it compile for ARM/FreeBSD.

Thanks.
lazarus 1.8.4 Win8.1 / cross FreeBSD
dhukmucmur vernadh!

PascalDragon

  • Hero Member
  • *****
  • Posts: 3328
  • Compiler Developer
Re: Fpcupdeluxe
« Reply #1881 on: July 28, 2021, 09:00:01 am »
Hi all people on this forum & thank you for your efforts,
I want to compile a cross compiler, packages, RTL from Windows to ARM/FreeBSD, and I use the last version of fpcupdeluxe but a message : No valid CPU / Crosscompiler found.
PS: for ARM/LINUX it works well.
So, is there any chance to implemente it ??
if I use Fpccupdeluxe on FreeBSD, would it compile for ARM/FreeBSD.

The target arm-freebsd is not supported. What is supported however is aarch64-freebsd, but only in the development version of FPC (3.3.1).

Snify

  • Newbie
  • Posts: 4
FPC Linker Problem for i386
« Reply #1882 on: July 28, 2021, 09:28:46 am »
Hello,

I have used fpcupdeluxe for X86_64 (Linux) and successfully installed Lazarus with FPC.
Compiling works just great on my linux machine (X64).
I would like to cross compile to i386 (X86 Linux), so I used fpcupdeluxe again.
Everything went well so far. However the linking process doesn't work and I get this error:

Error: /home/myuser/fpcupdeluxe_fix/cross/bin/i386-linux/i386-linux-ld: /lib64/libc.so.6: version `GLIBC_2.27' not found (required by /home/myuser/fpcupdeluxe_fix/cross/bin/i386-linux/i386-linux-ld)

Is there any way to make this work?

Thank you very much for your help in advance!

PS.: My Linux System is openSuse Leap 42.3
« Last Edit: July 28, 2021, 09:47:51 am by Snify »

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1492
Re: Fpcupdeluxe
« Reply #1883 on: July 28, 2021, 10:16:38 am »
@Snify
Please do not cross-post.
I have answered here:
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/issues/400

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1492
Re: Fpcupdeluxe
« Reply #1884 on: July 28, 2021, 10:19:10 am »
@Gustavo 'Gus' Carreno
I do not [yet] understand your question.
Quote
How can I tell fpcupdeluxe to use the next compiler up on the bootstrap list, so I can assess if it's a compiler issue or an Ubuntu issue.
Would you mind explaining this is more detail.

Gustavo 'Gus' Carreno

  • Hero Member
  • *****
  • Posts: 724
  • Professional amateur ;-P
Re: Fpcupdeluxe
« Reply #1885 on: July 28, 2021, 03:36:25 pm »
Hey Don,

@Gustavo 'Gus' Carreno
I do not [yet] understand your question.
Quote
How can I tell fpcupdeluxe to use the next compiler up on the bootstrap list, so I can assess if it's a compiler issue or an Ubuntu issue.
Would you mind explaining this is more detail.

I'm sorry for that :) I'll try and be more explanatory!!

Ok, so what I've assessed is that the default choice that fpcupdeluxe makes for the bootstrap version when compiling FPC 3.0.4 is either 3.0.0 or 3.0.2 according to the log:
Code: Text  [Select][+][-]
  1. fpcupdeluxe: info: FPCNativeInstaller (BuildModule: FPC): To compile this FPC, we need (required) a compiler with version 3.0.0 or 3.0.2

Immediately after that, it starts looking for versions online:
Code: Text  [Select][+][-]
  1. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Looking for official FPC bootstrapper with version 3.0.2
  2. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Looking for official FPC bootstrapper with version 3.0.0
  3. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Looking for official FPC bootstrapper with version 2.6.4
  4. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Looking for official FPC bootstrapper with version 2.6.2
  5. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Got a V2.6.2 bootstrap compiler from official FPC bootstrap sources.
  6. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Now looking for a better [version] bootstrap compiler from Github FPCUP(deluxe) releases.
  7. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Looking online for a FPCUP(deluxe) bootstrapper with name: fpcup-3_0_2-x86_64-linux-ppcx64
  8. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Success: found a FPCUP(deluxe) bootstrapper with version 3.0.2
  9. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Got a better [version] bootstrap compiler from FPCUP(deluxe) bootstrap binaries.
  10. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): Check if we already have a bootstrap compiler with version 3.0.2
  11. fpcupdeluxe: info: FPCNativeInstaller (CheckAndGetTools): No correct bootstrapper. Going to download bootstrapper from https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/bootstrappers_v1.0/fpcup-3_0_2-x86_64-linux-ppcx64
  12. fpcupdeluxe: info: FPCNativeInstaller (GetFile): Downloading https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/bootstrappers_v1.0/fpcup-3_0_2-x86_64-linux-ppcx64

It then settles down on version 3.0.2 and downloads it with success.

After using the 3.0.2 compiler to do the 1 of 3 bootstrap stages, when it's going to use stage one to compile stage two this happens:
Code: Text  [Select][+][-]
  1. /home/gcarreno/FreePascal_2.0.6/fpcsrc/compiler/ppc1 -Ur -Ur -Xs -O2 -n -Fi../inc -Fi../x86_64 -Fi../unix -Fix86_64 -FE. -FU/home/gcarreno/FreePascal_2.0.6/fpcsrc/rtl/units/x86_64-linux -Cg -Sg -vw-n-h-l-d-u-t-p-c- -dx86_64 -dRELEASE -Us -Sg system.pp
  2. make[7]: *** [Makefile:3489: system.ppu] Segmentation fault

So at this moment I'm trying not to bother you with the debugging and I want to see if fpcupdeluxe can be coaxed to use the 3.0.0 option for bootstrapping instead of 3.0.2 so I can assess if the issue is the compiler version or if it's something that changed in my Dyn Libs.

So my question is: How can I make fpcupdeluxe use 3.0.0 instead of 3.0.2 to help me debug?

Hope this makes it a bit more clear.

I think I mentioned it before, but here's it again, my system:
Ubuntu 21.04 64b updated in the past 2 or 3 days

Cheers,
Gus
Lazarus 2.3.0(trunk) FPC 3.3.1(trunk) Ubuntu 21.04 64b Dark Theme
Lazarus 2.0.12(stable) FPC 3.2.2(stable) Ubuntu 21.04 64b Dark Theme
http://github.com/gcarreno

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1492
Re: Fpcupdeluxe
« Reply #1886 on: July 29, 2021, 08:31:05 am »
As long as the bootstrapper has a valid version according to the Makefile, you can replace the bootstrapper.
To be more precise for your case.
Get the 3.0.0 bootstrapper from here:
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/bootstrappers_v1.0/fpcup-3_0_0-x86_64-linux-ppcx64
Replace the existing ppcx64 compiler in your bootstrap directory with this one.
Run fpcupdeluxe again. It will use the new 3.0.0 compiler.

Gustavo 'Gus' Carreno

  • Hero Member
  • *****
  • Posts: 724
  • Professional amateur ;-P
Re: Fpcupdeluxe
« Reply #1887 on: July 30, 2021, 07:56:16 pm »
Hey Don,

Probably not the right place to ask, but my browser was pointing here while trying to solve the 2.0.6 issue, but has the SVN server for FPC been shutdown?

And if so, for us that still have fpcupdeluxe installs with SVN, how do we proceed to migrate those to GIT?

And please don't say: just start over on a new folder :P

Many thanks Don!!

Cheers,
Gus
Lazarus 2.3.0(trunk) FPC 3.3.1(trunk) Ubuntu 21.04 64b Dark Theme
Lazarus 2.0.12(stable) FPC 3.2.2(stable) Ubuntu 21.04 64b Dark Theme
http://github.com/gcarreno

Gustavo 'Gus' Carreno

  • Hero Member
  • *****
  • Posts: 724
  • Professional amateur ;-P
Re: Fpcupdeluxe
« Reply #1888 on: July 30, 2021, 08:06:48 pm »
Hey Don,

Nevermind my last post!!

I've read the thread that has you announcing 2.0.0a and in there I've got the answer to "Is SVN closed?"

And I think it would be too much of a pain to have fpcupdeluxe implement a smooth transition from SVN to GIT just to ease my anxiety, so I've also answered my second question :)

I'll then do my testing of the 2.0.6 issue with a GIT repo and this will defo help me with the learning curve to apply it to may other 4 installs :)

Thanks Don!!

Cheers,
Gus
Lazarus 2.3.0(trunk) FPC 3.3.1(trunk) Ubuntu 21.04 64b Dark Theme
Lazarus 2.0.12(stable) FPC 3.2.2(stable) Ubuntu 21.04 64b Dark Theme
http://github.com/gcarreno

Gustavo 'Gus' Carreno

  • Hero Member
  • *****
  • Posts: 724
  • Professional amateur ;-P
Re: Fpcupdeluxe
« Reply #1889 on: July 30, 2021, 09:10:28 pm »
Hey all,

I officially give up on having a 2.0.6/3.0.4 install on my Ubuntu 21.04 64b.

I've tried bootstrap with 3.0.0 and 3.0.2 and I still get a Segmentation Fault error.

The suspicious part is that it's at different parts for each of the bootstrap compilers.

Oh well, we now have to get comfy with the GIT stuff.

Cheers,
Gus

PS: I'm just noting, not complaining, that the GitLab URL don't work, had to use the ZIP ones for this test.
Lazarus 2.3.0(trunk) FPC 3.3.1(trunk) Ubuntu 21.04 64b Dark Theme
Lazarus 2.0.12(stable) FPC 3.2.2(stable) Ubuntu 21.04 64b Dark Theme
http://github.com/gcarreno

 

TinyPortal © 2005-2018