Recent

Author Topic: Fpcupdeluxe  (Read 432528 times)

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1284
Re: Fpcupdeluxe
« Reply #1575 on: May 17, 2020, 12:38:13 pm »
@jiaxing2
@heejit

The latest release of fpcupdeluxe should/could solve your issues.

https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/tag/1.6.8r

dan57

  • Newbie
  • Posts: 3
Re: Fpcupdeluxe
« Reply #1576 on: May 18, 2020, 03:47:30 pm »
Hello DonAlfredo,

 About my post on page [103].
I have tested the cross compiler with the "Platform eXtended Library"
from asphyre.net.
The cross-compiler works well, no linking errors. The code produced is stable.

So here are the files www.codetwister.com/temp/cross_Arietta_G25.zip
I'll keep them online for a couple of weeks

Again, thanks for your effort in Fpcupdeluxe.



DonAlfredo

  • Hero Member
  • *****
  • Posts: 1284
Re: Fpcupdeluxe
« Reply #1577 on: May 18, 2020, 06:49:29 pm »
Thanks for the feedback.

New release.
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/tag/1.6.8s

Will cross-compile towards Windows ARM64.
And xtensa.
And aarch64 embedded if FPC trunk has this target enabled.

Edit.
@dan57: Will try to include your libs. Thanks.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1284
Re: Fpcupdeluxe
« Reply #1578 on: May 18, 2020, 10:03:55 pm »
Due to some typos, a bugfix release was needed.
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/tag/1.6.8t

heejit

  • Full Member
  • ***
  • Posts: 242
Re: Fpcupdeluxe
« Reply #1579 on: May 19, 2020, 12:23:50 am »
thanks I will try it again

Unfortunately by freebsd installation has some issue not able to test

rca

  • New Member
  • *
  • Posts: 24
Re: Fpcupdeluxe
« Reply #1580 on: May 19, 2020, 12:27:19 am »
Thanks @DonAlfredo for your effort and dedication, with fpcupdeluxe we facilitate the installation of fpc and lazarus.
And the best thing is that a large number of architectures can be cross-compiled from a single machine.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1284
Re: Fpcupdeluxe
« Reply #1581 on: May 19, 2020, 06:55:15 am »
@heejit
To install FPC on FreeBSD, you might need these patches.
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/patches_v1.0/fpcpatch_freebsd.patch
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/patches_v1.0/fpcpatch_freebsd_fixes_3_2.patch
If you allow fpcupdeluxe to use these online patches (see Setup+), auto-magical patching will be done when updating and building FPC and Lazarus.
You can also download/use patches yourself, and add them in Setup+ as FPC patches.

Sidenote.
It seems that latest FreeBSD uses ld from clang as default.
GNU ld is only available as ld.bfd.
FPC will error out on ld from clang.
That is why you need the first patch to successfully install FPC on FreeBSD.
If you can confirm this, a bugger can be opened. That allows this issue to be investigated and solved by FPC developers.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1284
Re: Fpcupdeluxe
« Reply #1582 on: May 19, 2020, 07:00:32 am »
@rca
You are welcome.
All fpcupdeluxe binaries are build on a single Windows machine with a single click.
However, this sometimes makes you (read: me) lazy. And you skip testing on some platforms. Resulting in annoying buggers.
Well ... every pro has its cons a famous philosopher would say ...

af0815

  • Hero Member
  • *****
  • Posts: 549
Re: Fpcupdeluxe
« Reply #1583 on: May 20, 2020, 08:47:11 am »
Given: clean plain debian buster with needed packages (for gtk2) installed.
Quote
# Paketliste auf neusten Stand bringen und Updaten
sudo apt-get update
sudo apt-get upgrade

# Die fehlenden Pakete installieren.
sudo apt-get install libx11-dev
sudo apt-get install libgdk-pixbuf2.0-dev
sudo apt-get install libpango1.0-dev
sudo apt-get install libgtk2.0-dev
sudo apt-get install gdb


# Für SVN
sudo apt-get install subversion

# Für GIT
sudo apt-get install git

fpcupdeluxe V1.6.8t x86_64-linux-gtk2

build of fpc fixes3.2 works
Lazarus fixes2.0 (Rev 63179) breaks with

Quote
3104) Compiling sourcefilemanager.pas
(3104) Compiling notifyprocessend.pas
(9022) Compiling resource /home/andi/fpcupdeluxe/lazarus/units/x86_64-linux/qt5/lazarus.or
(9015) Linking ../lazarus
/usr/bin/ld: cannot find -lQt5Pas
/home/andi/fpcupdeluxe/lazarus/ide/lazarus.pp(165,1) Error: (9013) Error while linking
/home/andi/fpcupdeluxe/lazarus/ide/lazarus.pp(165,1) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: /home/andi/fpcupdeluxe/fpc/bin/x86_64-linux/ppcx64 returned an error exitcode
make[2]: *** [Makefile:4574: idepkg] Error 2
make[1]: *** [Makefile:3385: idepkg] Error 2
make: *** [Makefile:3388: useride] Fehler 2
Error: (lazarus) Build IDE: stopped with exit code 2
Error: (lazarus) Building IDE: Building IDE failed.
make: Verzeichnis „/home/andi/fpcupdeluxe/lazarus“ wird verlassen
fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make returned exit status #512


ERROR: Fpcupdeluxe fatal error !
Sequencer (UserIDE): Failure running fpcupdeluxe: error executing sequence UserIDE
Sequencer (Lazarus): Failure running fpcupdeluxe: error executing sequence Lazarus
Sequencer (Only): Failure running fpcupdeluxe: error executing sequence Only

I did not expect the libQT5Pas. How can i fix this, because i want to use gtk2 not QT5. Or is this a new requirement for Lazarus ?

Edit: If i install libqt5pas, Lazarus is build BUT a x86_64-linux-qt5 version !

Quote
Lazarus 2.0.9 r63179 FPC 3.2.0 x86_64-linux-qt5
« Last Edit: May 20, 2020, 08:52:10 am by af0815 »
regards
Andreas

zamronypj

  • Jr. Member
  • **
  • Posts: 90
    • Fano Framework, Free Pascal web application framework
Re: Fpcupdeluxe
« Reply #1584 on: June 05, 2020, 06:58:30 am »
I am trying to install FPC+Lazarus (stable) using fpcupdeluxe (Release 1.6.8u), but some how it cannot complete Lazarus compilation. I restarted fpcupdeluxe several times but no luck.

Last logs before it fails
Code: Text  [Select][+][-]
  1. (3104) Compiling lazdebuggergdbmi.pas
  2. (3104) Compiling cmdlinedebugger.pp
  3. (3104) Compiling debugutils.pp
  4. (3104) Compiling gdbtypeinfo.pp
  5. (3104) Compiling gdbmimiscclasses.pp
  6. (3104) Compiling gdbmidebugger.pp
  7. (3104) Compiling gdbmidebuginstructions.pp
  8. (3104) Compiling synhighlightersql.pas
  9. (3104) Compiling synhighlightertex.pas
  10. (3104) Compiling synhighlighterunixshellscript.pas
  11. (3104) Compiling synhighlightervb.pas
  12. (3104) Compiling synhighlighterxml.pas
  13. (3104) Compiling synmacrorecorder.pas
  14. (3104) Compiling gdbmistringconstants.pas
  15. (3104) Compiling synmemo.pas
  16. (3104) Compiling synpluginsyncroedit.pp
  17. (3104) Compiling synpluginsyncronizededitbase.pp
  18. (3104) Compiling synplugintemplateedit.pp
  19. (3104) Compiling syneditmarkupguttermark.pp
  20. (3104) Compiling gdbmiserverdebugger.pas
  21. (3104) Compiling synhighlighterbat.pas
  22. (3104) Compiling synhighlighterini.pas
  23. (3104) Compiling synedittextsystemcharwidth.pas
  24. (3104) Compiling syneditmarkupifdef.pp
  25. (3104) Compiling synpluginmulticaret.pp
  26. (3104) Compiling synhighlighterpike.pas
  27. (3104) Compiling sshgdbmidebugger.pas
  28. (1008) 20675 lines compiled, 1.1 sec
  29. (1021) 12 warning(s) issued
  30. (1022) 51 hint(s) issued
  31. (1023) 1 note(s) issued
  32. (3104) Compiling syneditmarkupfoldcoloring.pas
  33. (1008) 111423 lines compiled, 4.5 sec
  34. (1021) 14 warning(s) issued
  35. (1022) 63 hint(s) issued
  36. (1002) Target OS: Linux for x86-64
  37. (3104) Compiling allsyneditdsgn.pas
  38. (3104) Compiling syndesignstringconstants.pas
  39. (3104) Compiling syneditlazdsgn.pas
  40. (3104) Compiling synpropertyeditobjectlist.pas
  41. (1008) 977 lines compiled, 0.4 sec
  42. (1022) 3 hint(s) issued
  43. An unhandled exception occurred at $00007F1D39178B60:
  44. EAccessViolation: Access violation
  45.   $00007F1D39178B60
  46.   $00000000009EDD07 line 1323 of exttools.pas
  47.   $00000000009EEF61 line 1622 of exttools.pas
  48. make: *** [useride] Error 217
  49. fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make returned exit status #512
  50.  
  51.  
  52. ERROR: Fpcupdeluxe fatal error !
  53. Sequencer (UserIDE): Failure running fpcupdeluxe: error executing sequence UserIDE
  54. Sequencer (Lazarus): Failure running fpcupdeluxe: error executing sequence Lazarus
  55. Sequencer (Default): Failure running fpcupdeluxe: error executing sequence Default

I already have FPC 3.0.4 working on Ubuntu 16.04 LTS. What did I miss?
« Last Edit: June 05, 2020, 07:21:58 am by zamronypj »
Fano Framework, Free Pascal web application framework https://fanoframework.github.io
Personal Projects https://v3.juhara.com
Github https://github.com/zamronypj

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1284
Re: Fpcupdeluxe
« Reply #1585 on: June 05, 2020, 09:29:44 am »
Confirmed.
I get the same error also on macOS Catalina now.
The issue seems to be caused by lazbuild. This problem has already been reported (bugtracker) and proves difficult to solve.
I am looking into it again. Stay tuned.

Cyrax

  • Hero Member
  • *****
  • Posts: 815
Re: Fpcupdeluxe
« Reply #1586 on: June 06, 2020, 04:28:47 am »
I am trying to install FPC+Lazarus (stable) using fpcupdeluxe (Release 1.6.8u), but some how it cannot complete Lazarus compilation. I restarted fpcupdeluxe several times but no luck.

Last logs before it fails
Code: Text  [Select][+][-]
  1. (3104) Compiling lazdebuggergdbmi.pas
  2. (3104) Compiling cmdlinedebugger.pp
  3. (3104) Compiling debugutils.pp
  4. (3104) Compiling gdbtypeinfo.pp
  5. (3104) Compiling gdbmimiscclasses.pp
  6. (3104) Compiling gdbmidebugger.pp
  7. (3104) Compiling gdbmidebuginstructions.pp
  8. (3104) Compiling synhighlightersql.pas
  9. (3104) Compiling synhighlightertex.pas
  10. (3104) Compiling synhighlighterunixshellscript.pas
  11. (3104) Compiling synhighlightervb.pas
  12. (3104) Compiling synhighlighterxml.pas
  13. (3104) Compiling synmacrorecorder.pas
  14. (3104) Compiling gdbmistringconstants.pas
  15. (3104) Compiling synmemo.pas
  16. (3104) Compiling synpluginsyncroedit.pp
  17. (3104) Compiling synpluginsyncronizededitbase.pp
  18. (3104) Compiling synplugintemplateedit.pp
  19. (3104) Compiling syneditmarkupguttermark.pp
  20. (3104) Compiling gdbmiserverdebugger.pas
  21. (3104) Compiling synhighlighterbat.pas
  22. (3104) Compiling synhighlighterini.pas
  23. (3104) Compiling synedittextsystemcharwidth.pas
  24. (3104) Compiling syneditmarkupifdef.pp
  25. (3104) Compiling synpluginmulticaret.pp
  26. (3104) Compiling synhighlighterpike.pas
  27. (3104) Compiling sshgdbmidebugger.pas
  28. (1008) 20675 lines compiled, 1.1 sec
  29. (1021) 12 warning(s) issued
  30. (1022) 51 hint(s) issued
  31. (1023) 1 note(s) issued
  32. (3104) Compiling syneditmarkupfoldcoloring.pas
  33. (1008) 111423 lines compiled, 4.5 sec
  34. (1021) 14 warning(s) issued
  35. (1022) 63 hint(s) issued
  36. (1002) Target OS: Linux for x86-64
  37. (3104) Compiling allsyneditdsgn.pas
  38. (3104) Compiling syndesignstringconstants.pas
  39. (3104) Compiling syneditlazdsgn.pas
  40. (3104) Compiling synpropertyeditobjectlist.pas
  41. (1008) 977 lines compiled, 0.4 sec
  42. (1022) 3 hint(s) issued
  43. An unhandled exception occurred at $00007F1D39178B60:
  44. EAccessViolation: Access violation
  45.   $00007F1D39178B60
  46.   $00000000009EDD07 line 1323 of exttools.pas
  47.   $00000000009EEF61 line 1622 of exttools.pas
  48. make: *** [useride] Error 217
  49. fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make returned exit status #512
  50.  
  51.  
  52. ERROR: Fpcupdeluxe fatal error !
  53. Sequencer (UserIDE): Failure running fpcupdeluxe: error executing sequence UserIDE
  54. Sequencer (Lazarus): Failure running fpcupdeluxe: error executing sequence Lazarus
  55. Sequencer (Default): Failure running fpcupdeluxe: error executing sequence Default

I already have FPC 3.0.4 working on Ubuntu 16.04 LTS. What did I miss?

Confirmed.
I get the same error also on macOS Catalina now.
The issue seems to be caused by lazbuild. This problem has already been reported (bugtracker) and proves difficult to solve.
I am looking into it again. Stay tuned.

Please see if attached patch in this bug report helps : https://bugs.freepascal.org/view.php?id=37179

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1284
Re: Fpcupdeluxe
« Reply #1587 on: June 06, 2020, 08:54:45 am »
Quote
Please see if attached patch in this bug report helps : https://bugs.freepascal.org/view.php?id=37179
Looks good. And works for me !

fabiopesaju

  • Jr. Member
  • **
  • Posts: 70
Re: Fpcupdeluxe
« Reply #1588 on: June 10, 2020, 02:46:01 am »
can you help me?

Quote
Going to install/update FPC and Lazarus with given options.
FPCUP(deluxe) is starting up.

Bootstrap dir:         /home/fabiopessoa/fpcupdeluxe/fpcbootstrap
FPCupdeluxe basedir:   /home/fabiopessoa/fpcupdeluxe
FPC URL:               https://svn.freepascal.org/svn/fpc/tags/release_3_0_4
FPC options:           
FPC source directory:  /home/fabiopessoa/fpcupdeluxe/fpcsrc
FPC install directory: /home/fabiopessoa/fpcupdeluxe/fpc
Lazarus URL:           https://svn.freepascal.org/svn/lazarus/tags/lazarus_2_0_8
Lazarus options:       
Lazarus directory:     /home/fabiopessoa/fpcupdeluxe/lazarus

Please stand back and enjoy !

9-6-20 21:15:04: fpcupdeluxe: V222 (20200909) started.
FPCUPdeluxe V1.6.8w for x86_64-linux running on Fedora
...
svn: E155004: Run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
svn: E155004: Working copy '/home/fabiopessoa/fpcupdeluxe/fpcsrc' locked.
svn: E155004: '/home/fabiopessoa/fpcupdeluxe/fpcsrc' is already locked.
fpcupdeluxe: WARNING: SVN client error return code: 256


i selected "stable" fpc and lazarus

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1284
Re: Fpcupdeluxe
« Reply #1589 on: June 10, 2020, 06:24:46 am »
@fabiopesaju

Fpcupdeluxe is not able to unlock your repo.
You can either try to do this yourself, by command line svn.
Or remove the entire fpcsrc directory and run again.
At the moment, this is all I know.

 

TinyPortal © 2005-2018