Recent

Author Topic: Fpcupdeluxe  (Read 355604 times)

macfly

  • New member
  • *
  • Posts: 9
Re: Fpcupdeluxe
« Reply #1275 on: May 21, 2019, 11:27:14 pm »
Due to timeout errors when downloading via svn, I'm testing with mirrors in Git.

embedded = fix trunk in svn? (https://svn.freepascal.org/svn/lazarus/branches/fixes_2_0)


DonAlfredo

  • Hero Member
  • *****
  • Posts: 1121
Re: Fpcupdeluxe
« Reply #1276 on: May 22, 2019, 06:52:48 am »
Embedded is a more or less recent version of both FPC and Lazarus trunk with some additions to make programming embedded targets (a.o. Microchip SAMC/D) easier.

Use trunkgit to get trunk by GIT. Its sources are:
https://github.com/graemeg/freepascal
https://github.com/graemeg/lazarus

PS:
Please not that, due to some unforeseen side-effects of changes in FPC trunk, you have to use FPC revision 42041 to build Lazarus with FPC trunk !!
https://bugs.freepascal.org/view.php?id=35576
« Last Edit: May 22, 2019, 07:05:22 am by DonAlfredo »

macfly

  • New member
  • *
  • Posts: 9
Re: Fpcupdeluxe
« Reply #1277 on: May 22, 2019, 07:57:09 pm »
Thanks for reply.

PS:
Please not that, due to some unforeseen side-effects of changes in FPC trunk, you have to use FPC revision 42041 to build Lazarus with FPC trunk !!
https://bugs.freepascal.org/view.php?id=35576

And how would I do to use this revision 42041 being that the compilation starts automatically after fpcdeluxe download the source? Or trunkgit already has it?

Edit: I see that in [Setup+] has the options to set revision.
But SVN server still giving timeout.


I'm trying now, downloading locally with an SVN client.

In this way: Checkout, timeout, cleanup, update, timeout, cleanup, update ...
« Last Edit: May 22, 2019, 09:29:54 pm by macfly »

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1121
Re: Fpcupdeluxe
« Reply #1278 on: May 23, 2019, 12:08:18 pm »
The last release of fpcupdeluxe did not handle GIT commits correct.

So, please test this pre-release.
https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/tag/1.6.2w

And, due to the FPC trunk problems as stated earlier, use commit 09e1881.
Put this number in FPC revision in Setup+.
(GIT uses commit-numbers, SVN uses revision numbers).

macfly

  • New member
  • *
  • Posts: 9
Re: Fpcupdeluxe
« Reply #1279 on: May 23, 2019, 03:46:24 pm »
Thanks DonAlfredo I'll try this.

I was able to install a specific revision downloading manually with tortoise on the basis of trial and error.
After 10 timeouts and resumes the task was completed.

So I ran the Fpcupdeluxe set up for the same revision and it managed to compile because don't have to get sources again.


One suggestion would be to put a loop to repeat the task until the checkout are completed.

I have seen that it tries to repeat, but it is necessary to increase the number of times. At least 10 resumes, or leave until complete.

Something like:

Code: [Select]
SVN.exe Chekout...

while SVNTimeOut do
begin
   SVN.exe Cleanup...
   SVN.exe Update...
end;

I do not know this happens only in some countries / networks but it has been 3 weeks since the SVN does not complete the task.

By the way, for me the address to get SSL files in Indy server is protected by captcha, as already pointed in previous posts.


Thanks for the great work!

Best regards!

« Last Edit: May 23, 2019, 03:53:59 pm by macfly »

M+AUDIO

  • New Member
  • *
  • Posts: 47
Re: Fpcupdeluxe
« Reply #1280 on: May 24, 2019, 12:26:24 pm »
Hi,

I know that the following issue is off-topic but I am trying to cross-compile on Ubuntu 16.10 64bit to 32bit but I get these errors:
Quote
Compile Project, Target: /home/petr/work/fpcx/projects/project1: Exit code 256, Errors: 1
Linking /home/petr/work/fpcx/projects/project1
/usr/bin/ld: cannot find -lgdk-x11-2.0
/usr/bin/ld: cannot find -lgdk_pixbuf-2.0
/usr/bin/ld: cannot find -lgtk-x11-2.0
/usr/bin/ld: cannot find -lgobject-2.0
/usr/bin/ld: cannot find -lglib-2.0
/usr/bin/ld: cannot find -lgthread-2.0
/usr/bin/ld: cannot find -lgmodule-2.0
/usr/bin/ld: cannot find -lpango-1.0
/usr/bin/ld: cannot find -lcairo
/usr/bin/ld: cannot find -latk-1.0
project1.lpr(20,1) Error: Error while linking
project1.lpr(20,1) Verbose: There were 1 errors compiling module, stopping

Could anybody help me and tell which packages I should install?
I tried some but without any success...

Thanks.
Hi. I also have this problem and reported it here. can you please check. pointing lazarus in project options to 32bit crosslibs did not helped me.

giahung1997

  • Full Member
  • ***
  • Posts: 113
Re: Fpcupdeluxe
« Reply #1281 on: May 25, 2019, 04:49:49 pm »
The project is frozen since latest big misunderstanding with one of main FPC developer. I want to act in rational manner. After cool-down period (there was a lot of emotions), I was asking about possibility of my participation, cooperation and future related to FPC compiler and NewPascal projects at 22 March 2019, without any clear answer until today. I didn't decide yet what to do next.
Be the next CodeTyphon. People here used to dislike it. Now they have to recognize it.
Hate me? I'm gone. You will never see me again. Fuck the people of this forum! Fuck this Lazarus! Fuck Pascal!

SymbolicFrank

  • Hero Member
  • *****
  • Posts: 635
Re: Fpcupdeluxe
« Reply #1282 on: June 03, 2019, 03:28:36 pm »
Hi DonAlfredo,

It took me multiple tries, but with the new version and revisions 42041 and 61209 it does seem to work :) Thanks!

Although Lazarus still gives: "Error: there is a problem with the Fppkg configuration. (Fppkg reports that the RTL is not installed.)", and sometimes the main IDE window doesn't close.

What did you mean with "commit 09e1881"? I don't see it anywhere, and when I put it in the box, fpcupdeluxe cannot find it.

josh

  • Hero Member
  • *****
  • Posts: 750
Re: Fpcupdeluxe
« Reply #1283 on: June 07, 2019, 10:45:12 am »
Trying a Fresh Install of Trunk for cocoa, but getting
Code: [Select]

xtedits.pas
Compiling cocoawindows.pas
cocoawindows.pas(225,15) Error: There is no method in an ancestor class to be ovextedits.pas
Compiling cocoawindows.pas

rridden: "setNeedsDisplay_(Boolean);"
cocoawindows.pas(225,15) Error: Objective-C messages require their Objective-C selector name to be specified using the "message" directive.
cocoawindows.pas(225,15) Error: Mismatch between number of declared parameters and number of colons in message string.
cocoawindows.pas(233,1) Fatal: There were 3 errors compiling module, stopping
Fatal: Compilation aborted
Error: /Users/josh/lazarus_trunk_cocoa_64/fpc/bin/x86_64-darwin/ppcx64 returned an error exitcode
make[3]: ***and number of colons in message string.
cocoawindows.pas(233,1) Fatal: There were 3 errors compiling module, stopping
Fatal: Compilation aborted
Error: /Users/josh/lazarus_trunk_cocoa_64/fpc/bin/x86_64-darwin/ppcx64 returned an error exitcode

 [../lcl.ppu] Error 1
make[2]: *** [cocoa_all] Error 2
make[1]: *** [interfaces] Error 2
make: *** [lcl] Error 2
fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make returned error code #512


ERROR: Fpcupdeluxe fatal error !

Any Ideas?
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1121
Re: Fpcupdeluxe
« Reply #1284 on: June 07, 2019, 01:00:10 pm »
Change introduced in:
https://svn.freepascal.org/cgi-bin/viewvc.cgi?view=revision&root=lazarus&revision=61319

To get working IDE, use rev 61318.

You can file a bugger ... ;-)

RAW

  • Hero Member
  • *****
  • Posts: 794
Re: Fpcupdeluxe
« Reply #1285 on: June 09, 2019, 08:52:16 pm »
Hey... nice, I've got my first running fpcUpDeluxe-LazFPCTrunkVersion ...  :D

fpcUpDeluxe needs some permissions if a security software is running:
1. fpcUpDeluxe_x64.exe and svn.exe
      - LAN send/receive TCP/IP datagram + 192.168.1.1 and 192.168.1.10
      - Outgoing connection 80, 443 // svn.exe only 443
      - direct and indirect Network access
     
2. Indirect network access:
    - fpcbootstrap\make.exe
    - fpcsrc\packages\fpmake.exe
    - fpcsrc\utils\fpmake.exe
    - fpcsrc\compiler\ppcx64.exe
    - fpcbootstrap\pwd.exe
    - fpcbootstrap\gdate.exe

3. fpcUpDeluxe_x64.exe, svn.exe: access to explorer.exe and services.exe
4. powershell.exe: access to services.exe
And after that everything went very well !!!

by the way: after the IDE is started for the first time, there can be a problem with FPPKG // fppkg.cfg
If that's the case, then insert a path (fpcUpDeluxe_INSTALL_DIR\fpc\fppkg.cfg // even if there is no such file and press the RESTORE-button!

Thanks for the program ...  :)
Windows 7 Pro (x64 Sp1) And Windows XP Pro (x86 Sp3) - LAZARUS 2.0.4 FPC 3.0.4 - TRUNK 2.1.0 FPC 3.3.1

SymbolicFrank

  • Hero Member
  • *****
  • Posts: 635
Re: Fpcupdeluxe
« Reply #1286 on: June 10, 2019, 01:26:24 pm »
DonAlfredo, do you know how I can build a simple (empty) program with arm embedded without Lazarus trying to build a dwarf/elf? Everything I can find about it seems outdated.


by the way: after the IDE is started for the first time, there can be a problem with FPPKG // fppkg.cfg
If that's the case, then insert a path (fpcUpDeluxe_INSTALL_DIR\fpc\fppkg.cfg // even if there is no such file and press the RESTORE-button!
Thanks!

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1121
Re: Fpcupdeluxe
« Reply #1287 on: June 10, 2019, 03:05:42 pm »
For my embedded ARM experiments (SAM [C/D][10/11]), I use the special embedded FPC and Lazarus versions, to be installed by fpcupdeluxe:
https://github.com/LongDirtyAnimAlf/freepascal
https://github.com/LongDirtyAnimAlf/lazarus

And this library:
https://github.com/michael-ring/mbf

Building without debug-info is as simple as disabling debugging in Project Options. But I am not sure if I have understood you correct.

SymbolicFrank

  • Hero Member
  • *****
  • Posts: 635
Re: Fpcupdeluxe
« Reply #1288 on: June 10, 2019, 03:22:16 pm »
Ah, ok, that makes it clear. I installed trunk and the cross compiler for arm / embedded. Compilation fails because it cannot find the units for building a dwarf (infodwrf.pp and others).

I'll check it out!

SymbolicFrank

  • Hero Member
  • *****
  • Posts: 635
Re: Fpcupdeluxe
« Reply #1289 on: June 10, 2019, 04:33:14 pm »
When I compile this program

Code: Pascal  [Select]
  1. program test;
  2.  
  3. begin
  4. end.

it still gives this error:

Code: Pascal  [Select]
  1. Compile Project, OS: embedded, CPU: arm, Target: test: Exit code 1, Errors: 1
  2. Fatal: Can't find unit lnfodwrf used by test

And I don't see options to simply link it to a bin or hex file, instead of trying to build a dwarf.