Recent

Author Topic: Fpcupdeluxe  (Read 344121 times)

minesadorada

  • Hero Member
  • *****
  • Posts: 582
  • Retired
Re: Fpcupdeluxe
« Reply #45 on: November 03, 2016, 06:51:50 pm »
OK Downloaded (looks fine under Win64)
Doing a clean install fpc 3.0.0 + Laz 1.7 to default c:\fpcdeluxe folder in Win64


Failed at the last hurdle.  Attached: zipped logfile
Tried 3 times with same result.
« Last Edit: November 03, 2016, 07:50:06 pm by minesadorada »
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1105
Re: Fpcupdeluxe
« Reply #46 on: November 03, 2016, 08:12:47 pm »
Please show me the command screen (better: a copy of the screen).

minesadorada

  • Hero Member
  • *****
  • Posts: 582
  • Retired
Re: Fpcupdeluxe
« Reply #47 on: November 03, 2016, 08:26:36 pm »
Please show me the command screen (better: a copy of the screen).
OK One more time...
Would you like the logfile as well?  I thought that was the command screen output logged to file.
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1105
Re: Fpcupdeluxe
« Reply #48 on: November 03, 2016, 08:35:28 pm »
Nop. The log file is generated by the basic fpcup-code ... not very informative.

But now you also see that is very easy to walk into the trap of freedom:
you can choose FPC 2.0.0 to compile Lazarus trunk, and that is not a healthy combi.

Trunk + trunk is a risky but also reasonable choice.
I personally would also always choose for fixes, because fixes = stable + bugfixes !

minesadorada

  • Hero Member
  • *****
  • Posts: 582
  • Retired
Re: Fpcupdeluxe
« Reply #49 on: November 03, 2016, 08:40:40 pm »
The latest install has worked!  (fpc 3.0.0 + Laz 1.7) Maybe it was the reboot.. or something else..  Isn't it annoying when you can't reproduce an error? :)

Next step: crosscompiling.
Watch this space
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1105
Re: Fpcupdeluxe
« Reply #50 on: November 03, 2016, 08:44:43 pm »
Yes, very annoying ... take my place ... testing fpcupdeluxe on 5 different systems ... in many FPC/Laz  combinations ... including the installation of packages ... my eyes are square today ...  :D

minesadorada

  • Hero Member
  • *****
  • Posts: 582
  • Retired
Re: Fpcupdeluxe
« Reply #51 on: November 03, 2016, 09:02:34 pm »
Crosscompiling report:
1- I am running Win64.  I asked for a crosscompile to Win64 and it allowed me - there should be a simple check to prevent this. Perhaps grey out the options that correspond to the current OS?
2. Crosscompile Win64 -> Win32 - Success!
3. Crosscompile Win64 -> Linux 32 - Fail, but message "Going to download the right cross code" and an Hourglass cursor.  App title is (Not Responding) so kill the app and restart it.
4. After kill/resatrt, try Crosscompile Win64 -> Linux 64.  Same result as Linux 32.
Message window reports "ERROR : Failed to get crossbinutils" then promises " Going to download the right cross code" and an Hourglass cursor.
5. Fire up Lazarus from new desktop icon (target=C:\fpcupdeluxe\lazarus\lazarus.exe --pcp="C:\fpcupdeluxe\config_lazarus") and try to run an empty application.
Message Window:
Compile Project, Target: C:\fpcupdeluxe\projects\project1.exe: Exit code 1, Errors: 1
Fatal: Can't find unit system used by Project1

It's not looking good...
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

minesadorada

  • Hero Member
  • *****
  • Posts: 582
  • Retired
Re: Fpcupdeluxe
« Reply #52 on: November 03, 2016, 09:05:01 pm »
Yes, very annoying ... take my place ... testing fpcupdeluxe on 5 different systems ... in many FPC/Laz  combinations ... including the installation of packages ... my eyes are square today ...  :D
You must have a hell of a fast internet connection!  I'm in the boondocks on an African island - my router is a tin can with a string connecting to the nearest town...
Take a break - it will all make sense tomorrow.. :)
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1105
Re: Fpcupdeluxe
« Reply #53 on: November 03, 2016, 09:38:23 pm »
One final one .... ;-)

NewPascal on the Mac, running the mORMot Sample !!
(see included screenshot)

Installed with fpcupdeluxe ...

minesadorada

  • Hero Member
  • *****
  • Posts: 582
  • Retired
Re: Fpcupdeluxe
« Reply #54 on: November 04, 2016, 11:34:41 am »
Win 10 x64
Removed old folder, deleted log and ini files.  Install fresh.
Screengrab attached:
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1105
Re: Fpcupdeluxe
« Reply #55 on: November 04, 2016, 09:04:40 pm »
Major update !!

All bintools, binlibs and bootstrappers have been removed from the repo (was a bad idea in the first place).
They are now available as releases.
This version of fpcupdeluxe uses these releases.

So, from now on, please use this new release (0.99) !

https://github.com/LongDirtyAnimAlf/Reiniero-fpcup/releases/tag/0.99

lainz

  • Hero Member
  • *****
  • Posts: 3137
    • Lainz
Re: Fpcupdeluxe
« Reply #56 on: November 04, 2016, 10:17:24 pm »
Quote
All bintools, binlibs and bootstrappers have been removed from the repo (was a bad idea in the first place).
They are now available as releases.

Thankyou for that, saves a lot of time for us.

You can add a progress bar for the download, or a percent in the terminal we can see?

Edit: or at least add a thread for the download, so the GUI doesn't freeze (Of course we don't need to touch nothing, but Windows keeps saying the application is 'not response' or wathever is translated 'No responde').

Edit: Done installing the cross compiler. But it doesn't works:
Plese see this:
http://forum.lazarus-ide.org/index.php/topic,34681.0.html
« Last Edit: November 04, 2016, 10:31:05 pm by lainz »

josh

  • Hero Member
  • *****
  • Posts: 745
Re: Fpcupdeluxe
« Reply #57 on: November 04, 2016, 11:06:10 pm »
Hi
Just tried Deluxe version,
Problem with Panda AV detecting virus and auto quarantining
sent to virus total failed 1/51
Qihoo-360    HEUR/QVM20.1.0000.Malware.Gen    20161104

I then allowed the download through, after loading and choosing to instal fp/laz bith trunk
Got error


Clicked the ok button, and it appears to continue.

UPDATE
Did not complete, got fmake errors timeout probably, maybe AV is still playing up with it.
« Last Edit: November 05, 2016, 12:01:24 am by josh »
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1105
Re: Fpcupdeluxe
« Reply #58 on: November 05, 2016, 11:36:53 am »
@josh
Did you have any success ?
Fpcupdeluxe downloads everything that it needs : ssl-libs for https, FPC and Lazarus sources, binutils, unzipper, GDB, crosstools ....
So, you definitely need to give it permissions !

minesadorada

  • Hero Member
  • *****
  • Posts: 582
  • Retired
Re: Fpcupdeluxe
« Reply #59 on: November 05, 2016, 12:03:34 pm »
I downloaded the x86_64-Win64 exe and it says it is version 20161102.  Is this v 0.99?

Another question: fpcupdeluxe uses svn from my already-installed TortoiseSVN.  Is this OK?
« Last Edit: November 05, 2016, 12:05:29 pm by minesadorada »
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI