Recent

Author Topic: Fpcupdeluxe  (Read 381035 times)

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #435 on: March 13, 2017, 03:19:48 pm »
Hi

Just cleared out install folder and tried again selecting 3.0.2 and laz trunk
I now do not get the previous error,but am getting other errors and again, I cannot copy screen to clipboard it out of bounds and a access error.
errors
lcl/interfaces/./carbon/carbonproc.pp(536,13) error 5000 identifier not found atsufndfontfromname
" " " " atsufindfontname
......
.....
getthemefont
getapplicatioscript


It is odd that referencing the carbonproc when i am using fpcupdeluxe for cocoa 64?

Josh
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1169
Re: Fpcupdeluxe
« Reply #436 on: March 13, 2017, 03:46:31 pm »
@josh
Please see:
http://wiki.lazarus.freepascal.org/Roadmap#Status_of_features_on_each_widgetset
As always, I would advice to install 32bit (as on Windows) and cross towards 64 bit.

edit:
The fpcupdeluxe cocoa version have been build with cocoa.
They do not build a Lazarus cocoa. They just use this widget.
I will look into this.

@xaver13
Please perform some forum-search first, before posting new issues.
This has already been reported just moments ago, in this thread.
« Last Edit: March 13, 2017, 04:01:54 pm by DonAlfredo »

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #437 on: March 13, 2017, 04:22:05 pm »
Hi

I will try the cocoa 32 and see if that will complete,
I have seen the status page; but I do not think this is upto date regarding the cocoa implementation, hense wanting to try the latest to see what is not working, what has been added and what has been fixed.

Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #438 on: March 13, 2017, 04:39:21 pm »
Tried
fpcupdeluxe cocoa 32
laz 1.7 fpc 3.0.2

This error out
.../components/sqlib/registersqldb.pas 65,6 cant't find unit mssqlconn used by registersqldb

I would say LAZ SVN has some issues on OSX in cocoa

Now checking same config but with carbon.
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1169
Re: Fpcupdeluxe
« Reply #439 on: March 13, 2017, 04:53:35 pm »
Seen this error also ... still trying to find out if this is easily solved by FPC or Lazarus.

edit:
And sorry about giving you the wrong advice earlier.
I did install FPC trunk with a patched (see bug-report about type change) Lazarus stable (1.6.4) version.
« Last Edit: March 13, 2017, 04:56:08 pm by DonAlfredo »

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #440 on: March 13, 2017, 05:28:32 pm »
Tested with carbon, laz 1.7, fpc 3.0.2.

Same problem error in registersqldb
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #441 on: March 15, 2017, 04:07:57 pm »
@DonAlfredo
Is this not MAC install, something to be reported to bugtracker; or is it currently being worked on?

Josh
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1169
Re: Fpcupdeluxe
« Reply #442 on: March 15, 2017, 04:31:24 pm »
@josh

I am waiting for this bug, before going on:
http://bugs.freepascal.org/view.php?id=31525
Need to know what FPC/Laz devs do to solve.

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #443 on: March 15, 2017, 08:16:02 pm »
Okay, will wait and monitor the bugtracker to see for any developments..
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #444 on: March 17, 2017, 10:32:42 pm »
Hi

No changes as of yet to get trunk working on OSX, so decided to go back to previous version.

I tried to go back to previous working SVN revision 54130
This also does NOT work now.

Maybe I need to also specify the FPC revision number as well now.

If so, any ideas of a working FPC revision number that will work

Cheers

Josh
« Last Edit: March 17, 2017, 10:34:44 pm by josh »
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1169
Re: Fpcupdeluxe
« Reply #445 on: March 18, 2017, 09:49:19 am »
First, I would advice always to use the official FPC/Lazarus releases for installing FPC and Lazarus !

In your case: what is your goal ?
Do you need a very new FPC, Lazarus or both ?

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #446 on: March 18, 2017, 10:04:07 am »
Hi

I have a few application that I am playing around with that were created with 1.7, and these do not open in 1.6.4.
Some of these test projects are testing the fpc 3.1.1. new features for curiosity and bug test also.

The reason I wish to get the latest SVN of the OSX version is so that I can check and test how complete the carbon and cocoa widgeset is, and report any issues bug that I find.

At the moment I have no working SVN on OSX at all. It is obviously not just me with this problem, so the amount of users that can test and report issues is reduced.
« Last Edit: March 18, 2017, 10:06:04 am by josh »
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1169
Re: Fpcupdeluxe
« Reply #447 on: March 19, 2017, 11:54:28 am »
I have added a screenshot of FPC/Lazarus trunk running on Mac.
With the changes needed to get things running !
So, you can continue your work if you want.

josh

  • Hero Member
  • *****
  • Posts: 754
Re: Fpcupdeluxe
« Reply #448 on: March 19, 2017, 12:11:26 pm »
Hi

Thanks for that that will definately help.

One further question, I previously tried modifying the utf8process with the {$IF FPC_FULLVERSION}.. as in the bugtracker, but had a problem in that when I re-ran fpcupdeluxe ; it re-downloaded and overwrote the file I had modified. probably because it had not completed the first install.

How do I tell fpcupdeluxe to not overwrite this file?
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

Bart

  • Hero Member
  • *****
  • Posts: 3546
    • Bart en Mariska's Webstek
Re: Fpcupdeluxe
« Reply #449 on: March 19, 2017, 12:29:18 pm »
I would hope that to update the source the equivalent of "svn up" is used, in which case your changes will not be overwritten, as long as there is no conflict (in which case you should be prompted for a required action).

About this issue specifically: please attach a patch file (against trunk) to the associated bugreport.
I'll ask some devel that actually has a Mac to apply it then.
(I don't like applying patches that I cannot even compile).

Bart