Forum > Third party

Fpcupdeluxe

<< < (414/420) > >>

DonAlfredo:
I have no plain common.dll in my Windows directory. Checked with a simple search for common.dll in c:\windows.

DonAlfredo:
Remark.
Many users of fpcupdeluxe, who try to install Lazarus trunk on Windows, will experience a fatal linking error that prevents a successful install of Lazarus.
Discussion can be found here.
https://gitlab.com/freepascal.org/lazarus/lazarus/-/issues/39935

KodeZwerg:
I do also having a fpcupdeluxe bug, i have not read yet your link, i do use windows, having laz 2.2.2 via fpcupd installed, downloaded newest fpcupd, set [stable] for compiler and ide, hit the setup/update button, it begin its job the normal way, installed a million lines of unreadable fast things, after it was finished... i was disappointed. It did not updated like i assumed to laz 2.2.4 it just re-installed everything like it was before.

nouzi:
fpcupdeluxe get old lazarus trunk  version on linux 

output fpcupdeluxe :
 
fpcupdeluxe: info: LazarusNativeInstaller (GetModule: Lazarus): Lazarus is at revision/hash: main-2_3-1472-ge2ad6b3d8d
fpcupdeluxe: info: Lazarus native builder: Detected source version Lazarus: 2.3.0
fpcupdeluxe: info: Lazarus native builder: Using FPC compiler with version: 3.3.1

BSaidus:
Hello,
FPC cross compiler for OpenBSD x86_64 on windows not successfully compiled.
Here is the output log:

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---fpcupdeluxe: info: FPCCrossInstaller (BuildModule: FPC): Building module FPC...fpcupdeluxe: info: FPC x86_64-openbsd cross-builder: Detected source version FPC (source): 3.2.2fpcupdeluxe: info: FPCCrossInstaller (BuildModuleCustom: FPC): Looking for crosstools and crosslibs on system. Please wait.fpcupdeluxe: TAny_openbsd-x86_64: Found correct binary utilities in directory E:\lzfpc\fpc322\cross\bin\x86_64-openbsdfpcupdeluxe: ERROR: Failed to get crosslibrary  fpcupdeluxe: ERROR: Failure due to missing cross libraries. Looking for fpcupdeluxe cross-tools on GitHub (if any).No luck in getting then cross-tools ... aborting. 
The binaries and libraries are downloaded and put into
--- Code: ---cross
--- End code ---
directory.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version