Forum > Third party

Fpcupdeluxe

<< < (413/414) > >>

Josh:
Hi

Just tried to install latest trunk of fpc/laz on mac mini, in a new folder, but am getting an error SetSetInstructionPointerRegisterValue.

ver 2.2.0k

Log below

--- Quote ---3104) Compiling fpdbgcallcontextinfo.pas
(3104) Compiling fpdbgdarwinclasses.pas
(3104) Compiling fpdbglinuxextra.pas
/Users/josh/Documents/LazTrunk/lazarus/components/fpdebug/fpdbgdarwinclasses.pas(126,15) Error: (3058) There is no method in an ancestor class to be overridden: "SetSetInstructionPointerRegisterValue(TDBGPtr);"
/Users/josh/Documents/LazTrunk/lazarus/components/fpdebug/fpdbgdarwinclasses.pas(176,1) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: /Users/josh/Documents/LazTrunk/fpc/bin/x86_64-darwin/ppcx64 returned an error exitcode
Error: (lazarus) Compile package fpdebug 1.0: stopped with exit code 1
Error: (lazarus) Compile package LCL 2.3: terminated
Error: (lazarus) [TLazPackageGraph.CompileRequiredPackages] "Exit code 1"
Error: (lazarus) Building IDE: Compile AutoInstall Packages failed.
make: *** [useride] Error 2
fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make returned exit status #512


ERROR: Fpcupdeluxe fatal error !
Sequencer (UserIDE): Failure running fpcupdeluxe: error executing sequence UserIDE
Sequencer (Lazarus): Failure running fpcupdeluxe: error executing sequence Lazarus
Sequencer (Default): Failure running fpcupdeluxe: error executing sequence Default/quote]
--- End quote ---

Josh:
just tried to instal laz/trunk fixes using wini386 version on Win11 machine, and getting..

--- Quote ---[ 41%] Compiled package pasjpeg
The installer encountered the following error:
Error inside worker thread for package oracle: Compilation of "BuildUnit_oracle.pp" failed
make[2]: *** [smart] Error 1
make[2]: Leaving directory `M:/LazarusFixes32/fpcsrc/packages'
make[1]: *** [packages_smart] Error 2
make[1]: Leaving directory `M:/LazarusFixes32/fpcsrc'
make: *** [build-stamp.i386-win32] Error 2
make: Leaving directory `M:/LazarusFixes32/fpcsrc'

fpcupdeluxe: ERROR: FPCNativeInstaller (BuildModuleCustom: FPC): Error running M:\LazarusFixes32\fpcbootstrap\make.exe for FPC failed with exit code 2
. Details:


ERROR: Fpcupdeluxe fatal error !
--- End quote ---

Josh:
Update:
To get fpc 32 bit installed on Windows 11 64bit, if getting the error above, I done the following
1. Comment out the line (19) //{$linklib common}  in the file {your laz folder}\fpcsrc\packages\oracle\src\oraoci.pp
2. Go to Set+, uncheck Get FPC/Sources, check Rebuild FPC/Laz Only.
3. Click Install FPC

Let it finish, should builf fpc ok.
Then Install Lazarus, remember to Tick Get FPC/Laz Sources and uncheck Rebuild FPC/Laz Only.

DonAlfredo:
I just did a vanilla install of fixes (3.2.3) on win11 with the 32-bit version of fpcupdeluxe without any problem !

Josh:
Hi
Do you have common.dll in Windows/System32.

Mine does not only the 64bit version in SysWow64.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version