Recent

Author Topic: Fpcupdeluxe  (Read 450856 times)

heejit

  • Full Member
  • ***
  • Posts: 245
Re: Fpcupdeluxe
« Reply #1590 on: June 10, 2020, 08:29:31 pm »
I want to install 3.2 fpc(next release version)  and Lazarus 2.0.8(current version)

Which option i suppose to select from the FPC Version List and Lazarus Version List

there is fixes, trunk, zip etc.


ASBzone

  • Sr. Member
  • ****
  • Posts: 460
  • Automation leads to relaxation...
    • Free BrainWaveCC Console Utilities
Re: Fpcupdeluxe
« Reply #1591 on: June 11, 2020, 12:42:24 am »
I want to install 3.2 fpc(next release version)  and Lazarus 2.0.8(current version)

Which option i suppose to select from the FPC Version List and Lazarus Version List

there is fixes, trunk, zip etc.

FPC Trunk + Lazarus Stable
-ASB: https://www.BrainWaveCC.com

Lazarus v2.0.11 r63516 / FPC v3.2.1-r46879 (via FpcUpDeluxe) -- Windows 64-bit install w/32-bit cross-compile
Primary System: Windows 10 Pro x64, Version 2004 (Build 19041.388)
Other Systems: Windows 10 Pro x64, Version 2004 or greater

fabiopesaju

  • Jr. Member
  • **
  • Posts: 79
Re: Fpcupdeluxe
« Reply #1592 on: June 11, 2020, 03:23:27 am »
thank you for your help. i installed and reinstalled several libraries and the error changed...

those are the last lines

Code: Pascal  [Select][+][-]
  1. /home/fabiopessoa/fpcupdeluxe/lazarus/ide/main.pp(1046,27) Warning: (4104) Implicit string type conversion from "AnsiString" to "WideString"
  2. /home/fabiopessoa/fpcupdeluxe/lazarus/ide/main.pp(1046,53) Warning: (4105) Implicit string type conversion with potential data loss from "WideString" to "AnsiString"
  3. /home/fabiopessoa/fpcupdeluxe/lazarus/ide/main.pp(1047,26) Warning: (4104) Implicit string type conversion from "AnsiString" to "WideString"
  4. /home/fabiopessoa/fpcupdeluxe/lazarus/ide/main.pp(1047,51) Warning: (4105) Implicit string type conversion with potential data loss from "WideString" to "AnsiString"
  5. /home/fabiopessoa/fpcupdeluxe/lazarus/ide/main.pp(1048,28) Warning: (4104) Implicit string type conversion from "AnsiString" to "UnicodeString"
  6. /home/fabiopessoa/fpcupdeluxe/lazarus/ide/main.pp(1048,67) Warning: (4105) Implicit string type conversion with potential data loss from "UnicodeString" to "AnsiString"
  7. (9022) Compiling resource /home/fabiopessoa/fpcupdeluxe/lazarus/units/x86_64-linux/gtk2/lazarus.or
  8. /usr/bin/ld: warning: ../link.res contains output sections; did you forget -T?
  9. (9015) Linking ../lazarus
  10. /usr/bin/ld: cannot find -lgdk-x11-2.0
  11. /usr/bin/ld: cannot find -lgdk_pixbuf-2.0
  12. /usr/bin/ld: cannot find -lgtk-x11-2.0
  13. /usr/bin/ld: cannot find -lpango-1.0
  14. /usr/bin/ld: cannot find -lcairo
  15. /usr/bin/ld: cannot find -latk-1.0
  16. make[3]: *** [Makefile:4144: lazarus] Error 1
  17. make[2]: *** [Makefile:4574: idepkg] Error 2
  18. make[1]: *** [Makefile:3385: idepkg] Error 2
  19. /home/fabiopessoa/fpcupdeluxe/lazarus/ide/lazarus.pp(165,1) Error: (9013) Error while linking
  20. /home/fabiopessoa/fpcupdeluxe/lazarus/ide/lazarus.pp(165,1) Fatal: (10026) There were 1 errors compiling module, stopping
  21. Fatal: (1018) Compilation aborted
  22. Error: /home/fabiopessoa/fpcupdeluxe/fpc/bin/x86_64-linux/ppcx64 returned an error exitcode
  23. make[3]: Leaving directory '/home/fabiopessoa/fpcupdeluxe/lazarus/ide'
  24. make: *** [Makefile:3390: useride] Error 2
  25. make[2]: Leaving directory '/home/fabiopessoa/fpcupdeluxe/lazarus/ide'
  26. make[1]: Leaving directory '/home/fabiopessoa/fpcupdeluxe/lazarus'
  27. Error: (lazarus) Build IDE: stopped with exit code 2
  28. Error: (lazarus) Building IDE: Building IDE failed.
  29. make: Leaving directory '/home/fabiopessoa/fpcupdeluxe/lazarus'
  30. fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make returned exit status #512
  31.  
  32.  
  33. ERROR: Fpcupdeluxe fatal error !
  34. Sequencer (UserIDE): Failure running fpcupdeluxe: error executing sequence UserIDE
  35. Sequencer (Lazarus): Failure running fpcupdeluxe: error executing sequence Lazarus
  36. Sequencer (Default): Failure running fpcupdeluxe: error executing sequence Default

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1327
Re: Fpcupdeluxe
« Reply #1593 on: June 11, 2020, 06:59:15 am »
@fabiopesaju

You need to install:

glib-devel
glibc-devel
libX11-devel
libXtst
libXtst-devel
gtk2-devel
gtk+extra
gtk+-devel
cairo-devel
cairo-gobject-devel
pango-devel

@heejit
If you want FPC fixes 3.2 and Lazarus 2.0.8, just choose these two from the list !

After install, you will see that fixes 3.2 has become fixes and 2.0.8 has become stable.
Versions without a number are dynamic.
If fixes 3.4 (or 4.0) will become available, your install of fixes 3.2 will again be shown as fixes 3.2

fabiopesaju

  • Jr. Member
  • **
  • Posts: 79
Re: Fpcupdeluxe
« Reply #1594 on: June 11, 2020, 02:12:57 pm »
worked perfectly. I do not know how to thank you...

these dependencies could be informed in git

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: Fpcupdeluxe
« Reply #1595 on: June 11, 2020, 06:12:38 pm »
This are the normal needed libraries of Lazarus, nothing special to fpcupdeluxe.
regards
Andreas

heejit

  • Full Member
  • ***
  • Posts: 245
Re: Fpcupdeluxe
« Reply #1596 on: June 11, 2020, 08:37:23 pm »
Trying to install:
FPC Trunk + Lazarus Stable

Following error:
Code: Pascal  [Select][+][-]
  1. custompage.inc(139,34) Error: Operator is not overloaded: "Class Of TCustomTabControl" and "Boolean"
  2. make: *** [Makefile:3395: lazbuild] Error 2
  3. comctrls.pp(4198) Fatal: There were 1 errors compiling module, stopping
  4. Fatal: Compilation aborted
  5. Error: /home/jiten/fpc-trunk/fpc/bin/x86_64-linux/ppcx64 returned an error exitcode
  6. fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: Lazbuild): make returned exit status #512
  7.  
  8.  
  9. ERROR: Fpcupdeluxe fatal error !
  10. Sequencer (UserIDE): Failure running fpcupdeluxe: error executing sequence UserIDE
  11. Sequencer (Lazarus): Failure running fpcupdeluxe: error executing sequence Lazarus
  12. Sequencer (Only): Failure running fpcupdeluxe: error executing sequence Only
  13.  

Version
OS : XUBUNTU 20.04 64 BIT
fpcupdeluxe : 1.6.8w

heejit

  • Full Member
  • ***
  • Posts: 245
Re: Fpcupdeluxe
« Reply #1597 on: June 11, 2020, 08:37:58 pm »
thanks

I want to install 3.2 fpc(next release version)  and Lazarus 2.0.8(current version)

Which option i suppose to select from the FPC Version List and Lazarus Version List

there is fixes, trunk, zip etc.

FPC Trunk + Lazarus Stable

heejit

  • Full Member
  • ***
  • Posts: 245
Re: Fpcupdeluxe
« Reply #1598 on: June 11, 2020, 08:41:38 pm »
trunk is showing = 3.3.1 i want to use 3.2

ASBzone

  • Sr. Member
  • ****
  • Posts: 460
  • Automation leads to relaxation...
    • Free BrainWaveCC Console Utilities
Re: Fpcupdeluxe
« Reply #1599 on: June 11, 2020, 08:43:21 pm »
thanks

I want to install 3.2 fpc(next release version)  and Lazarus 2.0.8(current version)

Which option i suppose to select from the FPC Version List and Lazarus Version List

there is fixes, trunk, zip etc.

FPC Trunk + Lazarus Stable

You're welcome.

BTW, was the error you showed in the previous message generated the first time you used FPCupDeluxe?  Or is it an upgrade installation?

(I only use it on Windows, so my assistance will be limited)
-ASB: https://www.BrainWaveCC.com

Lazarus v2.0.11 r63516 / FPC v3.2.1-r46879 (via FpcUpDeluxe) -- Windows 64-bit install w/32-bit cross-compile
Primary System: Windows 10 Pro x64, Version 2004 (Build 19041.388)
Other Systems: Windows 10 Pro x64, Version 2004 or greater

ASBzone

  • Sr. Member
  • ****
  • Posts: 460
  • Automation leads to relaxation...
    • Free BrainWaveCC Console Utilities
Re: Fpcupdeluxe
« Reply #1600 on: June 11, 2020, 08:44:43 pm »
trunk is showing = 3.3.1 i want to use 3.2

Then you may better off with:  FPC Fixes, Lazarus Stable.
-ASB: https://www.BrainWaveCC.com

Lazarus v2.0.11 r63516 / FPC v3.2.1-r46879 (via FpcUpDeluxe) -- Windows 64-bit install w/32-bit cross-compile
Primary System: Windows 10 Pro x64, Version 2004 (Build 19041.388)
Other Systems: Windows 10 Pro x64, Version 2004 or greater

heejit

  • Full Member
  • ***
  • Posts: 245
Re: Fpcupdeluxe
« Reply #1601 on: June 11, 2020, 10:07:37 pm »
Installed now
FPC FIXES + Lazarus Stable
Some dependency was not installed it is working now
THANKS.

Trying to install:
FPC Trunk + Lazarus Stable

Following error:
Code: Pascal  [Select][+][-]
  1. custompage.inc(139,34) Error: Operator is not overloaded: "Class Of TCustomTabControl" and "Boolean"
  2. make: *** [Makefile:3395: lazbuild] Error 2
  3. comctrls.pp(4198) Fatal: There were 1 errors compiling module, stopping
  4. Fatal: Compilation aborted
  5. Error: /home/jiten/fpc-trunk/fpc/bin/x86_64-linux/ppcx64 returned an error exitcode
  6. fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: Lazbuild): make returned exit status #512
  7.  
  8.  
  9. ERROR: Fpcupdeluxe fatal error !
  10. Sequencer (UserIDE): Failure running fpcupdeluxe: error executing sequence UserIDE
  11. Sequencer (Lazarus): Failure running fpcupdeluxe: error executing sequence Lazarus
  12. Sequencer (Only): Failure running fpcupdeluxe: error executing sequence Only
  13.  

Version
OS : XUBUNTU 20.04 64 BIT
fpcupdeluxe : 1.6.8w

Jako

  • Newbie
  • Posts: 3
Re: Fpcupdeluxe
« Reply #1602 on: June 20, 2020, 07:38:08 am »
Start fpcupdeluxe from commandline in a terminal window. You need some libs and prgs installed.

I use this
Code: Pascal  [Select][+][-]
  1. $sudo apt-get install subversion zip unzip
  2. $sudo apt-get install gdb libx11-dev libgtk2.0-dev libgdk-pixbuf2.0-dev libcairo2-dev libpango1.0-dev

It helped me today to build Lazarus v2.1.0 r63401 on Ubuntu 18.04.4 LTS (on xrdp).

Thanks!

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1327
Re: Fpcupdeluxe
« Reply #1603 on: June 20, 2020, 02:32:02 pm »
New release of fpcupdeluxe, celebrating the release of stable FPC 3.2.0  !!
This FPC supports the mORMot in all its features.
And has many more very important improvements and bugfixes.

https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/latest

heejit

  • Full Member
  • ***
  • Posts: 245
Re: Fpcupdeluxe
« Reply #1604 on: June 20, 2020, 08:54:12 pm »
New Stable version installed with all cross compiler(win32, win64, lin32, arm, wince)

Everything working fine.

Thanks to FPC Team

Thanks to Fpcupdeluxe Team.

 

TinyPortal © 2005-2018