Recent

Author Topic: Fpcupdeluxe  (Read 432920 times)

xaver13

  • Full Member
  • ***
  • Posts: 106
Re: Fpcupdeluxe
« Reply #1500 on: January 25, 2020, 05:21:52 pm »
Hello, today I tried to update Lazarus to latest stable version using Fpcupdeluxe.
But it ended with
Code: Pascal  [Select][+][-]
  1. fpcupdeluxe: ERROR: LazarusNativeInstaller (CheckModule: Lazarus): sources error (URL mismatch).
  2. fpcupdeluxe: ERROR: LazarusNativeInstaller (CheckModule: Lazarus): desired URL=https://svn.freepascal.org/svn/lazarus/tags/lazarus_2_0_6
  3. fpcupdeluxe: ERROR: LazarusNativeInstaller (CheckModule: Lazarus): source URL=https://svn.freepascal.org/svn/lazarus/tags/lazarus_2_0_4/

I can not find any error in fpcup.ini

Please, what could be wrong?

Thank you!
--
Jiri Cvrk

lainz

  • Hero Member
  • *****
  • Posts: 3593
    • Lainz
Re: Fpcupdeluxe
« Reply #1501 on: January 25, 2020, 08:25:49 pm »
The error as it shows in the log is that the version you have installed is 2.0.4, and you're trying to download 2.0.6, both are in different URL's, that's the error - URL mismatch -.

Maybe you need to delete the Lazarus folder, so it downloads it again, but don't delete your settings folder, maybe it get's upgraded from 2.0.4 to 2.0.6-
https://lainz.github.io - My Website
https://lazpaint.github.io/ - LazPaint Downloads

JdeHaan

  • Jr. Member
  • **
  • Posts: 57
Re: Fpcupdeluxe
« Reply #1502 on: February 12, 2020, 12:33:36 pm »
Tried to install trunk, but get this list of errors. (MacOs Catalina):

fpcupdeluxe: Performing a SVN/GIT/HG/FTP checkout ... please wait, could take some time.
fpcupdeluxe: info: FPCNativeInstaller (GetModule: FPC): FPC was at revision: failure
fpcupdeluxe: info: FPCNativeInstaller (GetModule: FPC): FPC is now at revision: 44154
fpcupdeluxe: WARNING: FPCNativeInstaller (GetModule: FPC): Going to patch FPC sources !!
fpcupdeluxe: info: FPC native builder: Detected source version FPC: 3.3.1
fpcupdeluxe: info: FPC native builder: Using FPC bootstrap compiler with version: 3.0.4
fpcupdeluxe: Start of compile error summary.
inplong.pas(306) Error: Error while assembling exitcode 1
fpcupdeluxe: Start of compile error summary.
inplong.pas(306) Fatal: There were 2 errors compiling module, stopping
inplong.pas(306) Error: Error while assembling exitcode 1
fpcupdeluxe: Start of compile error summary.
Fatal: Compilation aborted
inplong.pas(306) Fatal: There were 2 errors compiling module, stopping
fpcupdeluxe: Start of compile error summary.
fv/units/x86_64-darwin/inplong.s:344:14: error: invalid operand for instruction
fpcupdeluxe: Start of compile error summary.
fpcupdeluxe: Start of special error summary:
The installer encountered the following error:
Compilation of "BuildUnit_fv.pp" failed
make[1]: *** [packages_smart] Error 2
fpcupdeluxe: Start of compile error summary.
fpcupdeluxe: ERROR: FPCNativeInstaller (CleanModule: FPC): Error running make for FPC failed with exit code 512
fpcupdeluxe: Done !!

Otto

  • Full Member
  • ***
  • Posts: 224
Re: Fpcupdeluxe
« Reply #1503 on: February 21, 2020, 05:10:18 pm »
Hello everyone.

It is possible to use  Fpcupdeluxe to Creating a patch for Lazarus/FPC.

Otto.
Kind regards.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1290
Re: Fpcupdeluxe
« Reply #1504 on: February 21, 2020, 07:17:44 pm »
Fpcupdeluxe will save all changes you make as a diff-file when you update the sources through itself.
Look at the diff-files in the fpcsrc and lazarus directory.

Otto

  • Full Member
  • ***
  • Posts: 224
Re: Fpcupdeluxe
« Reply #1505 on: February 21, 2020, 07:32:16 pm »
Thank you  DonAlfredo.

Another question:
Can I use Fpcupdeluxe to send the generated patch?

Otto.
Kind regards.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1290
Re: Fpcupdeluxe
« Reply #1506 on: February 21, 2020, 08:04:08 pm »
No.
The diff-file has to be reviewed: it also contains all changes and patches by fpcupdeluxe itself.
On Windows, I use Visual Studio Code to look at and edit the diff file.

lucamar

  • Hero Member
  • *****
  • Posts: 2921
Re: Fpcupdeluxe
« Reply #1507 on: February 21, 2020, 08:37:23 pm »
It is possible to use  Fpcupdeluxe to Creating a patch for Lazarus/FPC.

AFAIK, not by itself but it shouldn't be difficult to create one using SVN on the downloaded working-copy.
Turbo Pascal 3 CP/M - Amstrad PCW 8256 (512 KB !!!) :P
Lazarus 2.0.8/FPC 3.0.4 - 32/64 bits on:
(K|L|X)Ubuntu 12..18, Windows XP, 7, 10 and various DOSes.

Otto

  • Full Member
  • ***
  • Posts: 224
Re: Fpcupdeluxe
« Reply #1508 on: February 21, 2020, 08:45:20 pm »
@DonAlfredo

Thank you  DonAlfredo.

Are you going to put this feature in future releases?

Otto.
Kind regards.

Otto

  • Full Member
  • ***
  • Posts: 224
Re: Fpcupdeluxe
« Reply #1509 on: February 21, 2020, 08:52:17 pm »
@lucamar

Thank you lucamar, you're right.

I had made this request to avoid using external programs.

Otto.
Kind regards.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1290
Re: Fpcupdeluxe
« Reply #1510 on: February 21, 2020, 09:14:56 pm »
@Otto
I understand your request and needs.
But fpcupdeluxe will remain just an installer and updater.
Many feature requests enter my mailbox.
But I have to limit myself towards the basic function(s) of fpcupdeluxe. Sorry about this. Time is limited.
(its already a lot of work to guarantee its functions across all systems out there)

Otto

  • Full Member
  • ***
  • Posts: 224
Re: Fpcupdeluxe
« Reply #1511 on: February 21, 2020, 09:31:02 pm »
@  DonAlfredo

Time is limited.
(its already a lot of work to guarantee its functions across all systems out there)

I fully understand and thank you very much for your work.

Otto.
Kind regards.

nouzi

  • Full Member
  • ***
  • Posts: 178
Re: Fpcupdeluxe
« Reply #1512 on: February 24, 2020, 10:27:50 am »
in windows install cross for arm linux not work you can fixed this thanks
my english is  bad
Lazarus 2.0.6 free pascal 3.0.4
Lazarus trunk  free pascal trunk 
System : linux mint 19.3 64bit  windows 7 64bit

lainz

  • Hero Member
  • *****
  • Posts: 3593
    • Lainz
Re: Fpcupdeluxe
« Reply #1513 on: March 07, 2020, 07:17:01 pm »
On a clean 64 bit haiku in virtual box, how I can run fpcupdeluxe, what I need to install first?
https://lainz.github.io - My Website
https://lazpaint.github.io/ - LazPaint Downloads

jma_sp

  • Full Member
  • ***
  • Posts: 138
  • El conocimiento si ocupa lugar.
Re: Fpcupdeluxe
« Reply #1514 on: March 11, 2020, 09:59:16 am »
I run fpcupdeluxe with:

- SVN (from depot)
- libQt5Pas ( I use downloaded library from fpcupdeluxe cross directory: linux to haiku), i put in same directory that fpcupdeluxe and run this in terminal.
- Qt4 / Qt5.

I have run it sometimes with some fpcupdeluxe versions under Haiku 64 but ever gets me error about OS_Target not supported and other about localized. May be next freepascal version will be able to fix this? haiku / x86_64  / x86_64-haiku

There is some url to dowload zip file directly containing libraries and binaries?

I have tried FreePascal snapshot 3.3.1 and it compiles under Haiku 64 bits (i have added path routes manually and modify fpc.cfg) i was unable to make Lazarus to compile.

Id like to have both FreePascal/Lazarus working under Lazarus 32/64 bits version.
Maybe sone day we could have a .hpkg package officially.
Would be great!!!
« Last Edit: March 11, 2020, 10:14:36 am by jma_sp »
Devuan Beowulf 3.0( JWM/ROX/iDesk) - Puppy Linux, ReactOS 0.4.xx  - FreeDos .

 

TinyPortal © 2005-2018