Recent

Author Topic: Fpcupdeluxe  (Read 466091 times)

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1361
Re: Fpcupdeluxe
« Reply #1350 on: August 15, 2019, 09:54:09 am »
@DimTim
I guess you have "sparta_dockedformeditor" installed.
This is a known bug.
See: https://forum.lazarus.freepascal.org/index.php/topic,45583.0.html

DimTim

  • New member
  • *
  • Posts: 8
Re: Fpcupdeluxe
« Reply #1351 on: August 15, 2019, 12:06:54 pm »
@DimTim
I guess you have "sparta_dockedformeditor" installed.
This is a known bug.

Actually, I do!  I'll try to remove it and try again.  Thanks!

UPD: no luck yet...
« Last Edit: August 15, 2019, 12:22:27 pm by DimTim »

DimTim

  • New member
  • *
  • Posts: 8
Re: Fpcupdeluxe
« Reply #1352 on: August 16, 2019, 08:52:17 am »
Not a bug, but some disadvantage: when long actions are performed, the GIU is frozen.  For example, when my firewall blocked internet access for a new copy of fpcupdeluxe, and it tried to download something, GUI was just frozen forever.  Maybe consider multi-threading?

Just successfully installed a fresh stable FPC+Lazarus and a fresh trunk versions, but only with option Auto-switch repo URL turned on.  Without it, downloads failed.

lainz

  • Hero Member
  • *****
  • Posts: 3800
  • Leandro Diaz
Re: Fpcupdeluxe
« Reply #1353 on: August 18, 2019, 09:11:37 pm »
Today I tried to update my macOS 64 installation of trunk trunk and it fails. Any ideas?
https://lainz.github.io/
Download LazPaint https://lazpaint.github.io/
Download BGRABitmap and BGRAControls https://github.com/bgrabitmap

DimTim

  • New member
  • *
  • Posts: 8
Re: Fpcupdeluxe
« Reply #1354 on: August 19, 2019, 05:53:22 am »
Today I tried to update my macOS 64 installation of trunk trunk and it fails. Any ideas?
At least you should tell, what error was shown. :)  But blindly guessing, try "Auto-switch repo URL" switch.  It helped me with Windows installation.

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1361
Re: Fpcupdeluxe
« Reply #1355 on: August 19, 2019, 08:25:08 am »
@lainz
I guess you are getting an error in "rtti.pp" (invalid operand) ?
« Last Edit: August 19, 2019, 08:26:50 am by DonAlfredo »

lainz

  • Hero Member
  • *****
  • Posts: 3800
  • Leandro Diaz
Re: Fpcupdeluxe
« Reply #1356 on: August 19, 2019, 04:14:29 pm »
Start compiling package utils-h2pas for target x86_64-darwin.
Executing command "/Users/leandro/fpcupdeluxe64/fpc/bin/x86_64-darwin/plex h2pas/scan.l h2pas/scan.pas"
The installer encountered the following error:
External command "/Users/leandro/fpcupdeluxe64/fpc/bin/x86_64-darwin/plex h2pas/scan.l h2pas/scan.pas" failed with exit code 256. Console output:
TP Lex Version 4.1a [April 2000], Copyright (c) 1990-2000 Albert Graef

FATAL: cannot open file /usr/lib/fpc/lexyacc/yylex.cod

make[1]: *** [utils_all] Error 2
make: *** [build-stamp.x86_64-darwin] Error 2

fpcupdeluxe: ERROR: FPCNativeInstaller (BuildModuleCustom: FPC): Error running make for FPC failed with exit code 512
. Details:


ERROR: Fpcupdeluxe fatal error !
https://lainz.github.io/
Download LazPaint https://lazpaint.github.io/
Download BGRABitmap and BGRAControls https://github.com/bgrabitmap

laguna

  • Sr. Member
  • ****
  • Posts: 287
Re: Fpcupdeluxe
« Reply #1357 on: August 19, 2019, 04:43:56 pm »
Help me, please,
fpcupdeluxe-x86_64-darwin-cocoa not start in Catalina 10.15 - Beta 5

Thanks

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1361
Re: Fpcupdeluxe
« Reply #1358 on: August 20, 2019, 12:42:01 pm »
@laguna
I am only able to run Catalina as a VM under Windows 10.
And this is sooooo slow and so full of errors that (for the moment) I have given up.
Sorry about this.

trev

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1053
  • Former Delphi 1-7, 10.2 User
Re: Fpcupdeluxe
« Reply #1359 on: August 21, 2019, 01:29:53 am »
Help me, please,
fpcupdeluxe-x86_64-darwin-cocoa not start in Catalina 10.15 - Beta 5

Try beta 6 - it resolved the issues I had with beta 5. The Catalina road is bumpy!
o Lazarus v2.1.0 r63871, FPC v3.3.1 r47164, macOS 10.14.6, Xcode 11.3.1
o Lazarus v2.1.0 r64160, FPC v3.3.1 Nov 27 21:16:31, macOS 11.0.1 (aarch64), Xcode 12.2
o Lazarus v2.1.0 r61574, FPC v3.3.1 r42318, FreeBSD 12.1 amd64 (VMware VM)
o Lazarus v2.1.0 r61574, FPC v3.0.4, Ubuntu 20.04 (PD VM)

Mi-Ki

  • New Member
  • *
  • Posts: 30
Re: Fpcupdeluxe
« Reply #1360 on: August 24, 2019, 10:16:00 am »
Hi.
I had a problem installing lazrus on raspberry.
https://forum.lazarus.freepascal.org/index.php?topic=46244.0

Fpcupdeluxe ok.
Everything works. :)
Thank you very much.

Mi-Ki

  • New Member
  • *
  • Posts: 30
Re: Fpcupdeluxe
« Reply #1361 on: August 25, 2019, 08:28:45 am »
I have installed lazarus 2.0.2
Not there - Package - Online package manager  %)

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1361
Re: Fpcupdeluxe
« Reply #1362 on: August 25, 2019, 08:43:58 am »
Please provide more details.
OPM should (must) be included with Lazarus 2.0.2

https://svn.freepascal.org/cgi-bin/viewvc.cgi/tags/lazarus_2_0_2/components/onlinepackagemanager/?root=lazarus

totya

  • Hero Member
  • *****
  • Posts: 643
Re: Fpcupdeluxe
« Reply #1363 on: August 25, 2019, 08:51:59 am »
OPM should (must) be included with Lazarus 2.0.2

This is the reason for my unanswered question.

af0815

  • Hero Member
  • *****
  • Posts: 586
Re: Fpcupdeluxe
« Reply #1364 on: August 25, 2019, 09:23:55 am »
OPM is a Package, delivered with Lazarus and can be installed like a normal Package. This depends not with fpcupdeluxe, but is IMHO more a not understandung how Lazarus and Package are working.

regards
Andreas

 

TinyPortal © 2005-2018