Forum > Third party

Fpcupdeluxe

(1/397) > >>

DonAlfredo:
Introducing fpcupdeluxe. A GUI tool that is based on fpcup by the late Renier.

https://github.com/newpascal/fpcupdeluxe/releases/latest

Still pre-mature, but ready to use in most cases.

It will ease the install of FPC and Lazarus.
And, as with fpcup, it is fully self-contained, meaning that you can install it on your system without worries about other installs of FPC and Lazarus.
BUT USE THE LINK THAT WILL BE CREATED BY FPCUPDELUXE TO START LAZARUS !

Use the quick-start buttons to install a standard flavor of FPC and Lazarus.
After install, you can add packages from the module list.

And also, you can install cross-compilers for various system.
For Windows, libraries and bintools will be downloaded automagically (when available).

When crossing for Android, it will first search the standard locations for the NDK and SDK.
In case of failure, it will download  the right tools.

Pre-release. Have fun and give feedback !

lainz:
Hi, I've downloaded the version for x86_64. I've selected trunk both for fpc and lazarus and installed it. Lazarus 1.7 64 bits.

When I want to install a cross compiler for i386 it gives me some errors:

--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---fpcdefs.inc(248,2) Error: User defined: Cross-compiling from systems without support for an 80 bit extended floating point type to i386 is not yet supported at this time fpcdefs.inc(248,2) Error: User defined: Cross-compiling from systems without support for an 80 bit extended floating point type to i386 is not yet supported at this time fpcdefs.inc(248,2) Error: User defined: Cross-compiling from systems without support for an 80 bit extended floating point type to i386 is not yet supported at this time fpcdefs.inc(248,2) Error: User defined: Cross-compiling from systems without support for an 80 bit extended floating point type to i386 is not yet supported at this time constexp.pas(87,1) Fatal: There were 4 errors compiling module, stoppingFatal: Compilation aborted
If I want to install cross compiler how I can do? I need to compile first for fpc i386 and then cross compile for x86_64? How?

DonAlfredo:
@lainz
Windows ? Linux ?
On Windows:
Recommended: install 32bit, cross towards 64bit.
The cross-compiler will already be installed by fpcupdeluxe.
GDB versions for 32bit and 64bit will also be available and will switch over automagically.

lainz:
Windows.

--- Quote ---Recommended: install 32bit, cross towards 64bit.
--- End quote ---
Ok as supposed, I will try again.

Edit: Done. Better that installing all by hand.

MementoMojito:
Hi DonAlfredo,

Thanks for this great tool : )
I have never used fpcup before but I thought I would it give it a go. I am on Debian Jessie x86-64 and I am trying to install FPC stable and Laz stable for x86_64.
However I have the error:


--- Code: Pascal  [+][-]window.onload = function(){var x1 = document.getElementById("main_content_section"); if (x1) { var x = document.getElementsByClassName("geshi");for (var i = 0; i < x.length; i++) { x[i].style.maxHeight='none'; x[i].style.height = Math.min(x[i].clientHeight+15,306)+'px'; x[i].style.resize = "vertical";}};} ---fpclazup: ERROR: Could not find SVN executable. Please make sure it is installed.fpclazup: info: Error running fpcup. Technical details: error executing sequence fpc; line: 2, param: FPCfpclazup: info: Error running fpcup. Technical details: error executing sequence Default; line: 3, param: fpc 
So quite obviously I need SVN; I have installed kdesvn but still no joy. What package is missing if you ever know?

Thanks!

Navigation

[0] Message Index

[#] Next page

Go to full version