Recent

Author Topic: Problem with fpc.cfg  (Read 3892 times)

brody

  • Newbie
  • Posts: 4
Problem with fpc.cfg
« on: October 23, 2016, 04:03:27 pm »
Hi:

Win 7 - svc pack 1   64 bit

Lazarus - 1.6    FPC 3.0.0.  SVN revision 51630

FPC - Version 1.0.12  2015/11/16  Compiler version 3.0.0

I have an issue when I try to compile *some* old code.

I have two different projects in different directories that are somewhat old.  I've been using them for quite some time.

Project #1 I compiled a month ago, all was well.  It still compiles today.
Project #2 is a little over a year old.  When I open the project, I get the "The current FPC has no config file.  It will probably miss some units.  Check your installation of FPC."

I have uninstalled FPC and Lazarus, and reinstalled both using the following files:
fpc-3.0.0.i386-win32.exe
lazarus-1.6.0-fpc-3.0.0-win64.exe


I changed no options during the install, which means I have a C:\FPC\etc directory structure and a C:\lazarus\fpc\3.0.0 directory structure.

BOTH directories have a fpc.cfg in what appears to be the correct location.

Any clues as to how to resolve?

Thanks.

Bart

  • Hero Member
  • *****
  • Posts: 3588
    • Bart en Mariska's Webstek
Re: Problem with fpc.cfg
« Reply #1 on: October 23, 2016, 05:57:49 pm »
Set verbosity to All (-va) and check the output of the compiler to see what and where it is looking for anything.

Also in Project Options->Compiler Options click on "Show Options" to see the options that are given to the compiler. There may be an @path/to/fpc.cfg parameter thee that points to an obsolete path?

Bart

brody

  • Newbie
  • Posts: 4
Re: Problem with fpc.cfg
« Reply #2 on: October 23, 2016, 07:31:36 pm »
Alright, I'll do that. 

Thanks for the tip.

brody

  • Newbie
  • Posts: 4
Re: Problem with fpc.cfg
« Reply #3 on: October 24, 2016, 04:24:50 pm »
This can be closed as fixed.


Went into PROJECT OPTIONS -> CONFIG AND TARGET

And for whatever reason, the TARGET OS (-T) field was set to WIN32.   Changed it to (DEFAULT) and all is well in the world.

Thanks for the help.