Recent

Author Topic: Online Package Manager  (Read 392243 times)

avra

  • Hero Member
  • *****
  • Posts: 1477
    • Additional info
Re: Online Package Manager
« Reply #1545 on: February 12, 2019, 04:05:32 pm »
I have reported the issue to the author: https://github.com/dgaspary/fpOdf/issues/2.
I have fixed HelloWorld ODF example for Windows, and reported it as another issue. Now everything compiles and HelloWorld demo ODF file is created and tested with LibreOffice. Author has just informed me that all patches have been applied.
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

GetMem

  • Hero Member
  • *****
  • Posts: 3431
Re: Online Package Manager
« Reply #1546 on: February 12, 2019, 08:39:25 pm »
I have fixed HelloWorld ODF example for Windows, and reported it as another issue. Now everything compiles and HelloWorld demo ODF file is created and tested with LibreOffice. Author has just informed me that all patches have been applied.
Thanks avra. I updated the central repository. Both the package and the demo project works fine.

avra

  • Hero Member
  • *****
  • Posts: 1477
    • Additional info
Re: Online Package Manager
« Reply #1547 on: February 13, 2019, 08:16:50 am »
I updated the central repository. Both the package and the demo project works fine.
Great, thanks!  ;)
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

wp

  • Hero Member
  • *****
  • Posts: 5541
Re: Online Package Manager
« Reply #1548 on: February 19, 2019, 06:09:53 pm »
GetMem, could you add the new version 1.0.4 of LazBarCodes to the repo? Now the barcodes have a method for saving to graphic file:
- download: https://sourceforge.net/projects/lazarus-ccr/files/LazBarcodes/lazbarcodes-1.0.4.zip/download
- json file: https://sourceforge.net/projects/lazarus-ccr/files/LazBarcodes/OPM/update_lazbarcodes.json/download
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

GetMem

  • Hero Member
  • *****
  • Posts: 3431
Re: Online Package Manager
« Reply #1549 on: February 19, 2019, 06:40:07 pm »
GetMem, could you add the new version 1.0.4 of LazBarCodes to the repo? Now the barcodes have a method for saving to graphic file:
- download: https://sourceforge.net/projects/lazarus-ccr/files/LazBarcodes/lazbarcodes-1.0.4.zip/download
- json file: https://sourceforge.net/projects/lazarus-ccr/files/LazBarcodes/OPM/update_lazbarcodes.json/download
Done. Thanks for the new version.

RDL

  • New member
  • *
  • Posts: 41
Re: Online Package Manager
« Reply #1550 on: February 26, 2019, 07:04:06 am »
GetMem
Could not install FPSpreadsheet via OPM.
I get the error "error reading data from socket"
Sorry for my english, google translation!

GetMem

  • Hero Member
  • *****
  • Posts: 3431
Re: Online Package Manager
« Reply #1551 on: February 26, 2019, 07:08:36 am »
Hi RDL,

Quote
Could not install FPSpreadsheet via OPM.
I get the error "error reading data from socket"
Just tested, works fine here. Firewall, AV? Maybe slow connection. You can try increase the connection timeout(OPM-->Options-->General).

avra

  • Hero Member
  • *****
  • Posts: 1477
    • Additional info
Re: Online Package Manager
« Reply #1552 on: February 27, 2019, 07:14:37 pm »
These OPM packages fail to compile with 32bit Lazarus 2.0 fixes and FPC 3.0 fixes on Win10x64:

CodeSigningHelperGitLab trunk version compiles, OPM version doesn't. OPM version should be updated.
KaajControlsNeeds fpgui_toolkit package which is not in OPM. Strange.
LazAutoUpdateAfter adding LCLPlatformDef to uses section of VersionSupport.pas compilation is fine. Fix reported to the author.
LazProfilerProblem with Generics. Reported to the author.
OpenWeatherMapCompilation fixed and reported to author. Demos still return response code 401 which seams to be an authentication issue.
PoweredByCompilation fails on Lazarus 2.0+. Fixed and reported https://bugs.freepascal.org/view.php?id=35160
« Last Edit: February 27, 2019, 07:24:21 pm by avra »
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

RDL

  • New member
  • *
  • Posts: 41
Re: Online Package Manager
« Reply #1553 on: February 28, 2019, 05:18:22 am »
[GetMem]
av not installed. Other components succefull installers.

error gif
https://s2.gifyu.com/images/65465.gif
Sorry for my english, google translation!

GetMem

  • Hero Member
  • *****
  • Posts: 3431
Re: Online Package Manager
« Reply #1554 on: February 28, 2019, 07:55:11 am »
@avra
First of all, thanks for checking the packages regularly. It helps me a lot.

CodeSigningHelperFixed.
KaajControlsUnfortunately fpgui has two package with the same, one for windows one for linux. Since each package name must be unique in OPM, fpgui_tools cannot be installed automatically. This is the reason why I removed in the past,  I also removed KaajControls now, if somebody finds a workaround I can add it back.
LazAutoUpdateFixed.
LazProfilerAlthough it would be nice if the package compiles with Lazarus 2.0, the author explicitly stated that the package only works with FPC/Lazarus trunk(see attached screenshot). I see no problem here.
OpenWeatherMapFixed.
PoweredByFixed.


If would be nice if somebody could check the packages on Linux too(much more issues there).




[GetMem]
av not installed. Other components succefull installers.

error gif
https://s2.gifyu.com/images/65465.gif
Unfortunately I'm out of ideas. Can somebody else test if the package can be installed or not?

avra

  • Hero Member
  • *****
  • Posts: 1477
    • Additional info
Re: Online Package Manager
« Reply #1555 on: February 28, 2019, 11:13:14 am »
thanks for checking the packages regularly. It helps me a lot.
You're most welcome and thank you for OPM. OPM and FpcUpD have really made some things much easier then they used to be. With them, docking IDE and embedded form designer, Lazarus can finally fully shine and fight for the place it deserves.
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

wp

  • Hero Member
  • *****
  • Posts: 5541
Re: Online Package Manager
« Reply #1556 on: February 28, 2019, 12:18:09 pm »
Could not install FPSpreadsheet via OPM.
I get the error "error reading data from socket"
This does not seem to be an error message from fpspreadsheet. Which Lazarus version are you having? From your video I see that the error is occuring in the download phase at the end of the laz_fpspreadsheet package - there are more packages to follow. There seems to be a problem with the connection to the repository. Install again, or download separately or download from the primary site https://sourceforge.net/projects/lazarus-ccr/files/FPSpreadsheet/fpspreadsheet-1.10.1.zip/download (which is the same version), then install manually.
« Last Edit: February 28, 2019, 12:24:28 pm by wp »
Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

RDL

  • New member
  • *
  • Posts: 41
Re: Online Package Manager
« Reply #1557 on: March 05, 2019, 05:17:54 am »
GetMem, wp
Sorry. This was my Kerio firewall.
see attachment
« Last Edit: March 05, 2019, 05:20:42 am by RDL »
Sorry for my english, google translation!

Windsurfer

  • Sr. Member
  • ****
  • Posts: 362
    • Windsurfer
Re: Online Package Manager
« Reply #1558 on: March 10, 2019, 04:30:42 pm »
I nstalling with Fpcupdeluxe to Windows 10, I had the following error messages.
If I commented out the references to llProgress it compiled.

(3104) Compiling fppkg_optionsfrm.pas
C:\Lazarus\lazarus\components\fppkg\src\fppkg_optionsfrm.pas(287,43) Error: (5000) Identifier not found "llProgress"
C:\Lazarus\lazarus\components\fppkg\src\fppkg_optionsfrm.pas(310,61) Error: (5000) Identifier not found "llProgress"
fppkg_optionsfrm.pas(403) Fatal: (10026) There were 2 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: C:\Lazarus\fpc\bin\x86_64-win64\ppcx64.exe returned an error exitcode
Error: (lazarus) Compile package fppkgpackagemanager 0.1: stopped with exit code 1
Error: (lazarus) Compile package RunTimeTypeInfoControls 0.1: terminated
Error: (lazarus) Compile package OnlinePackageManager 1.0.1.2: terminated
Error: (lazarus) Compile package lazprojectgroups 0.7: terminated
Error: (lazarus) [TLazPackageGraph.CompileRequiredPackages] "Exit code 1"
Error: (lazarus) Building IDE: Compile AutoInstall Packages failed.
C:\Lazarus\fpcbootstrap\make.exe: *** [useride] Error 2
fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make.exe returned error code #2

[Edit]
In fppkg_mainform.pas I just found this:
{$ifndef ver3}
{$error This packagemanager only works with fpc 3.1.1 or higher.}
{$endif}

I guesss that I need to change from fpc 3.0 fixes.
« Last Edit: March 10, 2019, 05:02:19 pm by Windsurfer »

GetMem

  • Hero Member
  • *****
  • Posts: 3431
Re: Online Package Manager
« Reply #1559 on: March 10, 2019, 05:48:10 pm »
@Windsurfer

OPM and fppkg ar two separate packages. I only maintain OPM. If you find a bug related to fpkg, please report it on the bug tracker or mailing list.