Recent

Author Topic: Online Package Manager  (Read 627047 times)

wp

  • Hero Member
  • *****
  • Posts: 8549
Re: Online Package Manager
« Reply #1965 on: January 30, 2021, 07:49:02 pm »
af0815 is right, do not remove dExif. fpExif is not a direct replacement (otherwise I would not have taken the time to rewrite it). It works with Delphi, though.
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

Remy Lebeau

  • Hero Member
  • *****
  • Posts: 952
    • Lebeau Software
Re: Online Package Manager
« Reply #1966 on: January 30, 2021, 09:08:12 pm »
Seems OPM is not up-to-date with the latest version of Indy's code on GitHub (https://github.com/IndySockets/Indy/).
Remy Lebeau
Lebeau Software - Owner, Developer
Internet Direct (Indy) - Admin, Developer (Support forum)

GetMem

  • Hero Member
  • *****
  • Posts: 3376
Re: Online Package Manager
« Reply #1967 on: January 30, 2021, 09:52:20 pm »
Seems OPM is not up-to-date with the latest version of Indy's code on GitHub (https://github.com/IndySockets/Indy/).

I'm not sure what you mean, I updated indy a few weeks ago. Just to double-check, I did a SVN update(screenshot1). The version in OPM is the same, namely r. 3662(screenshot2). Am I missing something? 

Remy Lebeau

  • Hero Member
  • *****
  • Posts: 952
    • Lebeau Software
Re: Online Package Manager
« Reply #1968 on: January 31, 2021, 08:47:34 pm »
I'm not sure what you mean, I updated indy a few weeks ago. Just to double-check, I did a SVN update(screenshot1). The version in OPM is the same, namely r. 3662(screenshot2). Am I missing something?

You are right, my bad.  OPM is up to date.  A user was submitting some changes to Indy the other day, and claimed to be using the latest version from OPM, but their copy of IdGlobal.pas was not the latest.
Remy Lebeau
Lebeau Software - Owner, Developer
Internet Direct (Indy) - Admin, Developer (Support forum)

zgabrovski

  • New Member
  • *
  • Posts: 33
Re: Online Package Manager
« Reply #1969 on: February 07, 2021, 07:26:52 am »
Hmm...

Nice to see progress in the packages. But, on the other hand OPM is not a development platform and is supposed to distribute "stable" packages only (whatever that means).

To reduce the workload for GetMem who has to apply the changes manually I'd urge you to use your own version control system (GitHub, Gitlab, Sourceforge) and send GetMem only new versions after some degree of stability is achieved or after severe fixes.

To give your users access to your recent version you can use the "update-json" mechanism: Store the zips on your site and create an update.json with the link to this zip. Send the update-json to GetMem, and your recent version will be available to the OPM users by selecting "install from third-party repository": https://wiki.freepascal.org/Online_Package_Manager#Create_JSON_for_updates

Sorry for the late reply.
The latest version was stable (I mean that there is no major issues) and I want kindly ask you to update in OPM. Curren vesion in OPM is buggy.
I will attach file again here.
Regards,
Zdravko



GetMem

  • Hero Member
  • *****
  • Posts: 3376
Re: Online Package Manager
« Reply #1970 on: February 07, 2021, 08:30:43 am »
@zgabrovski

I updated DBTreeViewAndDBCntrlGrid. Thanks for the new version!

lainz

  • Hero Member
  • *****
  • Posts: 3827
Re: Online Package Manager
« Reply #1971 on: February 16, 2021, 06:42:42 pm »
Hi GetMem, can you update BGRAControls? There is a fix for compilation issues

https://github.com/bgrabitmap/bgracontrols/releases/tag/v7.2
Just Why?

GetMem

  • Hero Member
  • *****
  • Posts: 3376
Re: Online Package Manager
« Reply #1972 on: February 16, 2021, 07:08:14 pm »
Hi Lainz,

Compiling with FPC 3.2.0/Lazarus Trunk, BGRAControls gives the error in the screenshot. I checked BGRABitmap from OPM, is the latest version(v.11.3.1.0), at least according to the external json(https://raw.githubusercontent.com/bgrabitmap/bgrabitmap/master/update_BGRABitmap.json). Do I need BGRABitmap trunk? Or am I missing something obvious?

lainz

  • Hero Member
  • *****
  • Posts: 3827
Re: Online Package Manager
« Reply #1973 on: February 17, 2021, 12:01:39 am »
Hi Lainz,

Compiling with FPC 3.2.0/Lazarus Trunk, BGRAControls gives the error in the screenshot. I checked BGRABitmap from OPM, is the latest version(v.11.3.1.0), at least according to the external json(https://raw.githubusercontent.com/bgrabitmap/bgrabitmap/master/update_BGRABitmap.json). Do I need BGRABitmap trunk? Or am I missing something obvious?

Hi, thanks for reporting, I will fix it.

Edit: Done, please download it again, it should work now with current release of BGRABitmap.
« Last Edit: February 17, 2021, 12:22:04 am by lainz »
Just Why?

GetMem

  • Hero Member
  • *****
  • Posts: 3376
Re: Online Package Manager
« Reply #1974 on: February 17, 2021, 06:34:04 am »
Quote
Hi, thanks for reporting, I will fix it.

Edit: Done, please download it again, it should work now with current release of BGRABitmap.
I updated BGRAControls. Thanks for the new version.

kkuba

  • Newbie
  • Posts: 0
Re: Online Package Manager
« Reply #1975 on: February 20, 2021, 10:34:24 am »
Would there be a chance to upgrade ZeosLib in the repository? The current version is a bit out of date, there have been two new releases since its publication. The current release is 7.2.10

GetMem

  • Hero Member
  • *****
  • Posts: 3376
Re: Online Package Manager
« Reply #1976 on: February 20, 2021, 11:19:50 am »
@kkuba

Thanks for the feedback. I updated ZeosLib from https://sourceforge.net/projects/zeoslib/. According to site and the downloaded zip, the current version is 7.2.10.0, however the version inside the lpk is still 10.2.8.0. It's OK for my part, but it might be confusing for users.

Fred vS

  • Hero Member
  • *****
  • Posts: 2283
    • StrumPract is the musicians best friend
Re: Online Package Manager
« Reply #1977 on: February 21, 2021, 01:06:03 am »
Hello GetMem.

Could you update uos?
https://github.com/fredvs/uos

Many thanks.

Fre;D
I use Lazarus 2.0.6 32/64 and FPC 3.2.0 32/64 on Debian 10.2 64 bit, Windows 10, Windows 7 32/64, Windows XP 32,  FreeBSD 64 and Mac OS X Snow Leopard 32.
Widgetset: fpGUI, MSEgui, Win32, GTK2, Qt, Carbon.

https://github.com/fredvs
https://gitlab.com/fredvs

GetMem

  • Hero Member
  • *****
  • Posts: 3376
Re: Online Package Manager
« Reply #1978 on: February 22, 2021, 06:30:23 am »
Hi Fre;D,

Quote
Could you update uos?
https://github.com/fredvs/uos

Many thanks.
I updated UOS. Thanks for the new version.

regards,
Getmem

indigo80

  • New Member
  • *
  • Posts: 41

 

TinyPortal © 2005-2018