Recent

Author Topic: Online Package Manager  (Read 515862 times)

franciscoluiz

  • New Member
  • *
  • Posts: 25
Re: Online Package Manager
« Reply #1710 on: December 10, 2019, 01:09:35 pm »
@Alextp
Quote
Can we include JPPack?
https://github.com/jackdp/JPPack

The package does not compile with Lazarus Trunk/FPC 3.0.4.

@GetMem, in the Online Package Manager configuration JSON file, there are a few properties that do just that, such as: LazCompatibility, FPCCompatibility, SupportedWidgetSet...


GetMem

  • Hero Member
  • *****
  • Posts: 3757
Re: Online Package Manager
« Reply #1711 on: December 10, 2019, 02:21:57 pm »
@franciscoluiz
Quote
in the Online Package Manager configuration JSON file, there are a few properties that do just that, such as: LazCompatibility, FPCCompatibility, SupportedWidgetSet...
I'm aware of that, however in order to add it to OPM, I need at least one Lazarus/FPC version where the package is functional. It does not seems to work with the following combinations: Lazarus 2.0.x, Lazarus Trunk/FPC 3.0.4, FPC 3.2.0, FPC trunk. Do you have more information?

wp

  • Hero Member
  • *****
  • Posts: 7620
Re: Online Package Manager
« Reply #1712 on: December 10, 2019, 03:04:13 pm »
I cloned the JPPack, and can confirm that it does not compile with Laz trunk / FPC 3.0.4. OK - the author requires FPC 3.3.1 (it is a bad idea to tie a package of general interest to the latest FPC version).

The main problem, however, is that the package depends also on "JPLib", another library of routines of the same author. It can be found on the author's github site but there is no Lazarus package. Since these libraries are actively maintained by their author it does not make sense that somebody of the Lazarus team takes responsibility to make them available in OPM.

Alextp, if you are interested in having these components available get in touch with their author and ask him to follow the Lazarus standards (i.e., provide a package, no pollution of search path as in Delphi). I am sure the FPC version issue can be handled by a few "IF FPC_FullVersion" checks I would say: minimum requirement is the current FPC release version.
Mainly Lazarus trunk / fpc 3.2.0 / all 32-bit on Win-10, but many more...

af0815

  • Hero Member
  • *****
  • Posts: 584
Re: Online Package Manager
« Reply #1713 on: December 17, 2019, 09:08:01 am »
laz_synapeV40.1 is actual not useable on a RasPi (3B+) for me

*) in jedi.inc {$ASMMODE Intel} is used. It should be souronded with a {$IFDEF MSWINDOWS}

*) in synases a lot of Identfiers are not found -> this is an very very old issue (eg. https://sourceforge.net/p/synalist/bugs/43/ and here in the forum).

it looks like Synaser is not maintained for a longer time.
regards
Andreas

guest64953

  • Guest
Re: Online Package Manager
« Reply #1714 on: December 17, 2019, 11:22:16 am »
Castle Game Engine failed to install via OPM. I installed OPM from onlinepackagemanager.lpk shipped with Lazarus. I'm running on OpenIndiana. Castle failed to compile. Both Lazarus and FPC are trunk, using Fpcupdeluxe.

GetMem

  • Hero Member
  • *****
  • Posts: 3757
Re: Online Package Manager
« Reply #1715 on: December 17, 2019, 11:54:52 am »
@af0815
Quote
laz_synapeV40.1 is actual not useable on a RasPi (3B+) for me
Did you try to report the bug here: http://www.ararat.cz/synapse/doku.php/support ? AFAIK this is the official page. If the bug is fixed, I can update OPM with the latest version.

@hunghung
Quote
Castle Game Engine failed to install via OPM. I installed OPM from onlinepackagemanager.lpk shipped with Lazarus. I'm running on OpenIndiana. Castle failed to compile. Both Lazarus and FPC are trunk, using Fpcupdeluxe.
OPM usually targets stable version of Lazarus/FPC, currently Lazarus 2.0.x and FPC 3.0.4. I don't mind adding packages with trunk support, however you have to contact the package maintainer for this. Please try the following link: https://castle-engine.io/talk.php

guest64953

  • Guest
Re: Online Package Manager
« Reply #1716 on: December 17, 2019, 11:59:14 am »
@hunghung
Quote
Castle Game Engine failed to install via OPM. I installed OPM from onlinepackagemanager.lpk shipped with Lazarus. I'm running on OpenIndiana. Castle failed to compile. Both Lazarus and FPC are trunk, using Fpcupdeluxe.
OPM usually targets stable version of Lazarus/FPC, currently Lazarus 2.0.x and FPC 3.0.4. I don't mind adding packages with trunk support, however you have to contact the package maintainer for this. Please try the following link: https://castle-engine.io/talk.php

Thanks for clarify this  :)

af0815

  • Hero Member
  • *****
  • Posts: 584
Re: Online Package Manager
« Reply #1717 on: December 17, 2019, 12:45:14 pm »
@af0815
Quote
laz_synapeV40.1 is actual not useable on a RasPi (3B+) for me
Did you try to report the bug here: http://www.ararat.cz/synapse/doku.php/support ? AFAIK this is the official page. If the bug is fixed, I can update OPM with the latest version.
It is (first) reported (on the official synalist, descibed on the supportpage) since 20.2.2013 !!! https://sourceforge.net/p/synalist/mailman/message/30510767/

I think it will never maintained.

« Last Edit: December 17, 2019, 12:48:30 pm by af0815 »
regards
Andreas

Alextp

  • Hero Member
  • *****
  • Posts: 1145
    • UVviewsoft
Re: Online Package Manager
« Reply #1718 on: December 26, 2019, 10:43:04 pm »

jacekpazera

  • New Member
  • *
  • Posts: 10
    • Pazera-Software
Re: Online Package Manager
« Reply #1719 on: January 17, 2020, 04:48:18 am »
The last news from JPPack:
Created JPLib package for Lazarus and CodeTyphon.
Compatibility with FPC 3.0.2 and newer.

Works OK on Lazarus 1.6.4 + FPC 3.0.2, Lazarus 2.0.6 + FPC 3.0.4, Lazarus 2.0.7 + FPC 3.3.1, CodeTyphon 7.00

GetMem

  • Hero Member
  • *****
  • Posts: 3757
Re: Online Package Manager
« Reply #1720 on: January 17, 2020, 05:21:49 am »
@jacekpazera
Quote
The last news from JPPack:
Created JPLib package for Lazarus and CodeTyphon.
Compatibility with FPC 3.0.2 and newer.

From where I can download the source? A quick google search did not reveal anything.

GAN

  • Sr. Member
  • ****
  • Posts: 301
Lazarus 2.0.8 FPC 3.0.4 Linux Mint Mate 19.3
Zeos 7.2.6 - Sqlite 3.32.3

https://gitlab.com/users/GAN__/projects


GetMem

  • Hero Member
  • *****
  • Posts: 3757
Re: Online Package Manager
« Reply #1723 on: January 17, 2020, 06:54:15 am »
Thanks. I added the packages to OPM. Two more questions:
1. In the JPPack documentation is mentioned that JPPack depends on PNGComponents(https://bitbucket.org/uweraabe/pngcomponents), however I cannot find a lazarus package for pngcomponents. I'm I missing something? After a quick try JPPack works fine without pngcomponents.
2. JPPack is windows only or it works under Linux too?

jacekpazera

  • New Member
  • *
  • Posts: 10
    • Pazera-Software
Re: Online Package Manager
« Reply #1724 on: January 17, 2020, 08:20:21 am »
PngComponents package is required only for Delphi.

I've made some corrections and now everything works fine on Linux (Xubuntu 18.04 + Lazarus 2.0.2 / FPC 3.3.1).

 

TinyPortal © 2005-2018