Recent

Author Topic: [SOLVED] LAMW : unable to build AppGridViewDemo1  (Read 3631 times)

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
[SOLVED] LAMW : unable to build AppGridViewDemo1
« on: September 29, 2016, 11:19:32 am »
Hi

After update and reinstall, I get these messages during java compilation :

Code: Pascal  [Select][+][-]
  1. Messages, Hints: 2
  2. Note: Duplicate unit "controls" in "controls", orphaned ppu "C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\obj\controls\controls.o"
  3. Note: Duplicate unit "controls" in "LCLBase 1.5", ppu="C:\lamw\laz4android\lcl\units\arm-android\controls.ppu", source="C:\lamw\laz4android\lcl\controls.pp"
  4. Compile Project, OS: android, CPU: arm, Target: C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\libs\armeabi\libcontrols.so: Success
  5. Building APK... : Exit code 1, Errors: 101
  6. Panic:      [echo] ----------
  7. Panic:      [echo] Resolving Dependencies for AppGridViewDemo1...
  8. Panic: [dependency] Ordered libraries:
  9. Panic: [dependency]
  10. Panic: [dependency] ------------------
  11. Panic:      [echo] ----------
  12. Panic:      [echo] Building Libraries with 'debug'...
  13. Panic:    [subant] No sub-builds to iterate on
  14. Panic:
  15. Panic: -code-gen:
  16. Panic: [mergemanifest] Merging AndroidManifest files into one.
  17. Panic: [mergemanifest] Manifest merger disabled. Using project manifest only.
  18. Panic:      [echo] Handling aidl files...
  19. Panic:      [aidl] No AIDL files to compile.
  20. Panic:      [echo] ----------
  21. Panic:      [echo] Handling RenderScript files...
  22. Panic:      [echo] ----------
  23. Panic:      [echo] Handling Resources...
  24. Panic:      [aapt] Generating resource IDs...
  25. Panic:      [echo] ----------
  26. Panic:      [echo] Handling BuildConfig class...
  27. Panic: [buildconfig] Generating BuildConfig class.
  28. Panic:
  29. Panic: -pre-compile:
  30. Panic:
  31. Panic: -compile:
  32. Panic:     [javac] Compiling 9 source files to C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\bin\classes
  33. Panic:     [javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
  34. Panic:     [javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
  35. Panic:     [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
  36. Panic:     [javac] C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\src\com\example\appgridviewdemo1\jGridView.java:108: error: cannot find symbol
  37. Panic:     [javac]         listLayout.setLayoutParams(new GridView.LayoutParams(LayoutParams.WRAP_CONTENT, LayoutParams.WRAP_CONTENT));
  38. Panic:     [javac]                                                              ^
  39. Panic:     [javac]   symbol:   variable LayoutParams
  40. Panic:     [javac]   location: class jGridViewCustomAdapter
  41. Panic:     [javac] C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\src\com\example\appgridviewdemo1\jGridView.java:108: error: cannot find symbol
  42. Panic:     [javac]         listLayout.setLayoutParams(new GridView.LayoutParams(LayoutParams.WRAP_CONTENT, LayoutParams.WRAP_CONTENT));
  43. Panic:     [javac]                                                                                         ^
  44. Panic:     [javac]   symbol:   variable LayoutParams
  45. Panic:     [javac]   location: class jGridViewCustomAdapter
  46. Panic:     [javac] C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\src\com\example\appgridviewdemo1\jGridView.java:111: error: cannot find symbol
  47. Panic:     [javac]         itemLayout.setLayoutParams(new RelativeLayout.LayoutParams(LayoutParams.WRAP_CONTENT, LayoutParams.WRAP_CONTENT));
  48. Panic:     [javac]                                                                    ^
  49. Panic:     [javac]   symbol:   variable LayoutParams
  50. Panic:     [javac]   location: class jGridViewCustomAdapter
  51. Panic:     [javac] C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\src\com\example\appgridviewdemo1\jGridView.java:111: error: cannot find symbol
  52. Panic:     [javac]         itemLayout.setLayoutParams(new RelativeLayout.LayoutParams(LayoutParams.WRAP_CONTENT, LayoutParams.WRAP_CONTENT));
  53. Panic:     [javac]                                                                                               ^
  54. Panic:     [javac]   symbol:   variable LayoutParams
  55. Panic:     [javac]   location: class jGridViewCustomAdapter
  56. Panic:     [javac] C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\src\com\example\appgridviewdemo1\jGridView.java:118: error:
  57.  
  58. [repeated several time]
  59.  
  60. cannot find symbol
  61. Panic:     [javac]         LayoutParams txtParam = new LayoutParams(LayoutParams.WRAP_CONTENT, LayoutParams.WRAP_CONTENT); //w,h        
  62. Panic:     [javac]                                                                             ^
  63. Panic:     [javac]   symbol:   variable LayoutParams
  64. Panic:     [javac]   location: class jGridViewCustomAdapter
  65. Panic:     [javac] Note: C:\lamw\lazandroidmodulewizard\demos\Eclipse\AppGridViewDemo1\src\com\example\appgridviewdemo1\jGridView.java uses unchecked or unsafe operations.
  66. Panic:     [javac] Note: Recompile with -Xlint:unchecked for details.
  67. Panic:     [javac] 12 errors
  68. Panic:     [javac] 3 warnings
  69. Panic:
  70. Panic: BUILD FAILED
  71. Panic: C:\lamw\android-sdk-windows\tools\ant\build.xml:716: The following error occurred while executing this line:
  72. Panic: C:\lamw\android-sdk-windows\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.
  73. Panic:
  74. Panic: Total time: 6 seconds
  75. Panic: tool stopped with exit code 1. Use context menu to get more information.
  76. Exception, Errors: 1
  77. Fatal: [Exception] Failed: Cannot build APK!
  78.  

What can I do ?

Regards 
« Last Edit: September 30, 2016, 10:46:39 am by tintinux »
Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

Handoko

  • Hero Member
  • *****
  • Posts: 3851
  • My goal: build my own game engine using Lazarus
Re: LAMW : unable to build AppGridViewDemo1
« Reply #1 on: September 29, 2016, 11:46:03 am »
Hello tintinux. I've just svn updated to revision 499 and compile my old projects, I did not experience any issue so far.

edited:

I tested to compile/build AppGridViewDemo1, no problem too. How do you compile the project? I opened the project file, change the library path and click menu > Run > Project > Compile. I just got 2 hints but no error.
« Last Edit: September 29, 2016, 12:26:18 pm by Handoko »

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
Re: LAMW : unable to build AppGridViewDemo1
« Reply #2 on: September 29, 2016, 06:02:22 pm »
Hi

The good new is that you can use svn. What is your command line or URL ? Can you commit ?
GIT is a mess, specialy with LAMW and I loose a lot of time and quality with it.

My issue is not during Pascal compilation, but afterwards when I build the APK with [LAMW] build APK and run.
Paths are OK.
I suppose there is another problem with java stuff not updated.

Best regards
Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

Handoko

  • Hero Member
  • *****
  • Posts: 3851
  • My goal: build my own game engine using Lazarus
Re: LAMW : unable to build AppGridViewDemo1
« Reply #3 on: September 29, 2016, 06:19:25 pm »
These are the commands I use to update LAMW from the web:
Code: [Select]
cd ~/Android
svn up lazandroidmodulewizard.git

I use Linux internal svn command. You can easily find free svn client from Sourceforge.

My LAMW folder is:
home/Android/lazandroidmodulewizard.git

I'm using Lazarus 1.6 x86-64-linux-gtk2 FPC 3.0.0 + java-7-openjdk-amd64 + NDK R11C Android 7 (API 24).

A.S.

  • Jr. Member
  • **
  • Posts: 76
Re: LAMW : unable to build AppGridViewDemo1
« Reply #4 on: September 29, 2016, 08:27:39 pm »

jmpessoa

  • Hero Member
  • *****
  • Posts: 1623
Re: LAMW : unable to build AppGridViewDemo1
« Reply #5 on: September 29, 2016, 08:50:15 pm »

Hello tintinux!

I updated  "jGridView.java"  and "AppGridViewDemo1"

Thank you!
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

tintinux

  • Sr. Member
  • ****
  • Posts: 311
    • Gestinux
Re: LAMW : unable to build AppGridViewDemo1
« Reply #6 on: September 30, 2016, 09:19:56 am »
Hi

After a new update of LAMW sources and rebuild of lazarus, it works fine : thanks !

Thanks also to have restored the svn-git bridge, SVN clients are much simpler and quicker to use than GIT clients. Probably because of the many files generated or updated automatically with LAMW. If we make changes in some source on our side, it looks impossible to "update" (git pull) other LAMW sources until we commit that changes.  Or there is something I don't know how. May be, it would be better to locate all generated files in some directory distinct from sources and not managed by git, but I realize it would be a huge and difficult task !

Best regards
Tintinux

Initiator of gestinux, open-source, multi-database and multilingual accounting and billing software made with LAZARUS.

You can help to develop, to make and improve translations, and to provide examples of legal charts and reports from more countries.

 

TinyPortal © 2005-2018