Recent

Author Topic: fpcupdeluxe not correct fpc version  (Read 1504 times)

xinyiman

  • Hero Member
  • *****
  • Posts: 2092
    • Lazarus and Free Pascal italian community
fpcupdeluxe not correct fpc version
« on: August 28, 2018, 07:47:23 pm »
Hi guys, on my mac I'm trying to install lazarus (cocoa) via fpcupdeluxe. And although I told him to install the trunk version of lazarus and the trunk version of fpc gives me these messages at the beginning of the install

Code: Pascal  [Select][+][-]
  1. Performing a SVN/GIT checkout ... please wait, could take some time.
  2. fpcupdeluxe: info: FPC builder: Detected source version FPC: 3.3.1
  3. fpcupdeluxe: info: FPC builder: Detected source version FPC: 3.3.1
  4. fpcupdeluxe: info: FPC builder: Using FPC bootstrap compiler with version: 3.0.4
  5. fpcupdeluxe: info: FPC builder: Using FPC bootstrap compiler with version: 3.0.4
  6.  

Why?
Win10, Ubuntu and Mac
Lazarus: 2.1.0
FPC: 3.3.1

sstvmaster

  • Full Member
  • ***
  • Posts: 167
Re: fpcupdeluxe not correct fpc version
« Reply #1 on: August 28, 2018, 08:21:30 pm »
I think its correct. fpcupdeluxe uses bootstrap complier 3.0.4 to compile 3.3.1 . That's how I understood it.
« Last Edit: August 28, 2018, 08:23:53 pm by sstvmaster »
Windows 10 (64 bit)
Lazarus: 2.0.10 / Trunk x32

af0815

  • Hero Member
  • *****
  • Posts: 582
Re: fpcupdeluxe not correct fpc version
« Reply #2 on: August 28, 2018, 09:53:51 pm »
FPC 3.2 is not released (yet), this is the reason why 3.0.4 is the last stable (nothing else).
regards
Andreas

 

TinyPortal © 2005-2018