Recent

Author Topic: 1.7 SVN: Can't run with "Run without Debugging" button (please confirm)  (Read 1455 times)

Hansaplast

  • Hero Member
  • *****
  • Posts: 545
  • Tweaking4All.com
    • Tweaking4All
 In the SVN version of Lazarus 1.7 (build 52835, MacOS X 10.11), the newly added "Run without debugging" button does not work for Mac users.
(previous 1.7 builds seem to have the same issue, as far as recall)


It produces this error message:


Code: [Select]
Launching application Invalid
The launching application "/<path>/<to>/Project1.app" does not exist or is not executable.
See Run -> Run Paramaters -> local


I've reported this as a bug as well bug 30490, and it was suggested I post this in the forum as well for others to see/investigate/comment on.


Steps to Reproduce:


Start a new project (File -> New -> Application),
Save all (if the IDE will let you!) in a project folder.
In Project Options, create an Application bundle.
Run this application (click "Run without debugging").


Additional Information:


- All settings in "Run -> Run Paramaters -> local" are default (blank).
- The project1.app application bundle exists.
- The file "project1.app/Content/MacOS/project1" links to the executable.
- Running Project1.app straight from Finder works just fine.
- Running the linked file from Finder works just fine.
- Running the binary from Finder works as well.


Just to clarify ...


Using the "Run" button:
Debugger set to GDB: it works correctly.
Debugger set to None: it works correctly (Tools -> options -> Debugger -> Debugger Type = none).


Using the "Run without debugging" button:
Debugger set to GDB: it FAILS....
Debugger set to None: it works correctly (Tools -> options -> Debugger -> Debugger Type = none).


Maybe I looked at it too simple that "Run without debugging" would simply (temporary) set the debugger to "none"?
« Last Edit: August 20, 2016, 07:44:33 pm by Hansaplast »