Author Topic: [SOLVED] Resource file missing - but not really...  (Read 5280 times)


  • Guest
[SOLVED] Resource file missing - but not really...
« on: February 26, 2016, 02:49:55 pm »
I just installed  Lazarus v1.6 w/ PFC 3.0 x64 on Windows 10 64-bit Pro this morning - still using all default settings.

When I create a new console app by selecting "Program" from the "New Project" dialog, Lazarus creates a few base files for my project.  One of those files is a resource file with the extension *.res.  However, each time I compile my little program an error raises informing me that Lazarus cannot find the resource file named MyFilename.rc.  The compiler is looking for a resource file with the extension *.rc instead of the *.res extension created by the template or app wizard.  I simply change the extension on the resource file from *.res to *.rc then everything compiles perfectly, but I should not have to perform this step.  I have tried several small "Hello World!" type example programs, and each time the same issue occurs - I get a *.res resource file when the compiler is looking for a *.rc resource file.  Is this a small bug in Lazarus, or is there a setting that I have neglected to change somewhere which will point the compiler to the correct resource file extension?

Thanx in advance!
« Last Edit: June 20, 2018, 01:48:53 am by GypsyPrince »


  • Hero Member
  • *****
  • Posts: 10445
Re: Resurce file missing - but not really...
« Reply #1 on: February 26, 2016, 03:37:27 pm »
The *.res files are compiled resource files. They are compiled from the *.rc files which are plain text files.
If a default new lazarus project won't compile with your new install it may be that there are leftovers somewhere from a previous install.

1. res <> rc, but you need an rc file to create a res file.
2. Plz report back if a new project1 gives the same error.
When you ask a question that is actually answered in the documentation, you are either lazy or a moron.


  • Guest
Re: Resurce file missing - but not really...
« Reply #2 on: February 26, 2016, 04:07:24 pm »
Okay... I watched my project folder as I did each step.

Neither a *.rc file nor a *.res file were created when using the wizard.

Upon compiling my sample program for the first time, I get the error that the file "project1.rc" can't be found, but this process creates a file named "project1.res".

So, this along with your explanation creates a new question for me:
    Is the application wizard supposed to create the file named "project1.rc" for me, or am I supposed to manually create this file myself?  Is this file created during some process that I inadvertently skipped?

Bear in mind that I am new to both Lazarus and Pascal.  The tutorial ebook that I'm reading to learn Lazarus hasn't yet mentioned anything about resource files.


TinyPortal © 2005-2018