Recent

Author Topic: Win 8.1 Forms suddenly gone !  (Read 2775 times)

docwat

  • New Member
  • *
  • Posts: 40
Win 8.1 Forms suddenly gone !
« on: March 17, 2016, 01:40:05 am »
Hi,

For some unknown reason my Lazarus forms suddenly  fail to show Win 8.1 32.    This happens on both installed progs and within the IDE.

Progs appear as normal in the IDE and complle successfully but on RUN the forms appear white and TEdit texts do not appear until the box is clicked. (the components appear).

I do not understand why the problem also occurs in previously  installed Lazarus progs using a setup exe utility.    Seems that Win 8.1 has lost the ability to display Lazarus forms whilst appearing to display other progs normally.

Where do I start to diagnose this frustrating collapse ?  Brought my projects to a stand still.

I would welcome some advice.

Many thanks  Docwat

docwat

  • New Member
  • *
  • Posts: 40
Re: Win 8.1 Forms suddenly gone !
« Reply #1 on: March 17, 2016, 07:52:40 am »
Hi,

The problem cleared on next day switch on of Win 8.1.   It seemed to relate to screen resolution with the impression that lowering resolution seemed to occasionally put things right but it may simply have reflected the random nature of the problem.

Whatever it puts in some doubt the reliability of Lazarus under Win 8.1 within my own computer which is worrying if for no other reason that I do not know what went wrong !  This is the first problem that I have encountered in some 2 years and seems to relate to a single project but affecting finished and installed version outside of the IDE is not very good.

The suspicion is that it may be hardware related may be justified.

But today all seems to have returned to normal.

Docwat

docwat

  • New Member
  • *
  • Posts: 40
Re: Win 8.1 Forms suddenly gone !
« Reply #2 on: March 17, 2016, 11:24:33 am »
That did not last long !

Screen view attatched.

Docwat

GetMem

  • Hero Member
  • *****
  • Posts: 3501
Re: Win 8.1 Forms suddenly gone !
« Reply #3 on: March 17, 2016, 11:35:32 am »
What's happening if you run your program with compatibility mode on?

docwat

  • New Member
  • *
  • Posts: 40
Re: Win 8.1 Forms suddenly gone !
« Reply #4 on: March 17, 2016, 03:39:27 pm »
PROBLEM SOLVED

It appears that some setting of the VDU a Pavilion 23xi had changed, no doubt at my hand.  Resetting to factory defaults has restored proper display of Lazarus screens.   The question still remains - why was the current Lazarus Project only affected ?

Will take a few days to 100% confirm this solution but for now everything looks O.K.

Docwat