Recent

Author Topic: Cannot install lazvlc package on Rpi  (Read 4236 times)

Tibb

  • New Member
  • *
  • Posts: 26
Cannot install lazvlc package on Rpi
« on: March 03, 2016, 07:07:03 pm »
Lazarus 1.6RC2
fpc 3.0.0
raspberry Pi 2 / Raspbian v8 (Jessie)

Trying to install package lazvlc 1.0 //Save and rebuild IDE

Compile  package lazvlc 1.0: Exit code 256, Errors: 1
lclvlc.pp(90,47) Error: Identifier not found 'GetXHandle'

Thank You.
« Last Edit: March 04, 2016, 09:10:39 pm by tibb78 »

Jurassic Pork

  • Hero Member
  • *****
  • Posts: 824
Re: Cannot install lazvlc package
« Reply #1 on: March 03, 2016, 11:31:43 pm »
hello,
getXHandle Function is in the include files vlcgtk2.inc or vlcqt.inc .
In the file lclvlc.pp you have
Code: Pascal  [Select][+][-]
  1. {$ifdef HasX}
  2. {$ifdef lclgtk2}
  3. {$I vlcgtk2.inc}
  4. {$endif}
  5. {$ifdef lclqt}
  6. {$I vlcqt.inc}
  7. {$endif}
  8. {$endif}

check why one of the two files isn't include when you compile (check your LCL_PLATFORM).

Quote
LCL_PLATFORM=%platform
%platform is the target widgetset. It can be win32,wince,gtk,gtk2,qt,carbon,cocoa,customdrawn.

Friendly, J.P
Jurassic computer : Sinclair ZX81 - Zilog Z80A à 3,25 MHz - RAM 1 Ko - ROM 8 Ko

Tibb

  • New Member
  • *
  • Posts: 26
Re: Cannot install lazvlc package
« Reply #2 on: March 04, 2016, 08:41:11 pm »
Hello,

at 'Configure build Lazarus' i set LCL widget type to gtk2, target OS Linux and Target CPU to arm yet i cannot rebuild the IDE with lazvlc.

These are greyed out:

Code: Pascal  [Select][+][-]
  1. {$ifdef lclgtk2}
  2. {$I vlcgtk2.inc}
  3. {$endif}
  4. {$ifdef lclqt}
  5. {$I vlcqt.inc}
  6. {$endif}
  7.  

Thank You anyway.

t.
« Last Edit: March 04, 2016, 09:09:48 pm by tibb78 »

taazz

  • Hero Member
  • *****
  • Posts: 5365
Re: Cannot install lazvlc package
« Reply #3 on: March 04, 2016, 10:30:04 pm »
Hello,

at 'Configure build Lazarus' i set LCL widget type to gtk2, target OS Linux and Target CPU to arm yet i cannot rebuild the IDE with lazvlc.

These are greyed out:

Code: Pascal  [Select][+][-]
  1. {$ifdef lclgtk2}
  2. {$I vlcgtk2.inc}
  3. {$endif}
  4. {$ifdef lclqt}
  5. {$I vlcqt.inc}
  6. {$endif}
  7.  

Thank You anyway.

t.
does jessie support X Windows? Try to find why the HasX is not defined and if required install the x Windows library in jessie.
Good judgement is the result of experience … Experience is the result of bad judgement.

OS : Windows 7 64 bit
Laz: Lazarus 1.4.4 FPC 2.6.4 i386-win32-win32/win64

Tibb

  • New Member
  • *
  • Posts: 26
Re: Cannot install lazvlc package on Rpi
« Reply #4 on: March 05, 2016, 09:44:22 am »
I can start X Windows with startx on the Pi, i can run GUI apps on it. Im running Lazarus itself on the Pi 2 and trying to build lazvlc from there.
« Last Edit: March 05, 2016, 09:45:57 am by tibb78 »

Jurassic Pork

  • Hero Member
  • *****
  • Posts: 824
Re: Cannot install lazvlc package on Rpi
« Reply #5 on: March 05, 2016, 10:58:58 am »
hello,
try to remove the HasX condition :
Code: Pascal  [Select][+][-]
  1. //{$ifdef HasX}
  2. {$ifdef lclgtk2}
  3. {$I vlcgtk2.inc}
  4. {$endif}
  5. {$ifdef lclqt}
  6. {$I vlcqt.inc}
  7. {$endif}
  8. //{$endif}
  9.  
Jurassic computer : Sinclair ZX81 - Zilog Z80A à 3,25 MHz - RAM 1 Ko - ROM 8 Ko

Tibb

  • New Member
  • *
  • Posts: 26
Re: Cannot install lazvlc package on Rpi
« Reply #6 on: March 07, 2016, 09:06:31 pm »
hello,
try to remove the HasX condition :
Code: Pascal  [Select][+][-]
  1. //{$ifdef HasX}
  2. {$ifdef lclgtk2}
  3. {$I vlcgtk2.inc}
  4. {$endif}
  5. {$ifdef lclqt}
  6. {$I vlcqt.inc}
  7. {$endif}
  8. //{$endif}
  9.  

Thank You, first im trying to get it work on windows.

 

TinyPortal © 2005-2018