Forum > General

Console is getting cleared after compilation in FPC 3+

(1/1)

Artlav:
Greetings.
It feels like i'm just missing a switch somewhere, but i can't find a way to stop the compiler from clearing the console after it's done compiling.

Before around FPC 3 it would compile, give out the compile done message, and leave everything as is.
With FPC 3 it compiles, if there are no errors it clears screen, then gives out the compile done line.

How can i stop it from clearing the screen?
It's quite annoying.

Jonas Maebe:
On which platform are you, and how are you compiling? I've never heard of this kind of behaviour before (with FPC 3.0 or any other version).

Laksen:
I'm seeing it in Ubuntu 15 as well, but not in ubuntu 14.

It's about 52 newlines on my project generated by the call to ld. It does the same if linked from the command line. Not an fpc bug, just binutils again.

Using binutils x86_64 2.25.1 on the buggy system

Jonas Maebe:
Ah, yes. That bug has been fixed binutils already (http://bugs.freepascal.org/view.php?id=27988 ), so when Ubuntu updates to 2.26 it should be ok.

Artlav:
Arch Linux, binutils 2.25.1
Just tried to compile with -sh, and it compiles without problems, but running the linker script produces the newlines.
Scrolling up, it does look like there is just a bunch of new lines rather than a clear screen.
So, binutils it is, apparently.

Thanks for clearing it up.
I thought it was a new FPC "feature" since i encountered it in the past on Windows while trying to compile for Android, which had version 3.*, while all the 2.* worked as usual. Didn't matter to me back then, but i noticed.

Navigation

[0] Message Index

Go to full version