Forum > Windows

Can't change anything on a form

<< < (2/3) > >>

taazz:
Open lazarus, change the form contents to create the problem save and then upload here both the old and new lfm file or search them for differences your self pay close attention to numeric values and your settings of decimal separator and thousand grouping digits.

bylaardt:
i had a similar issue on linux.
was fixed saving the lfm file in utf8 format.

adriane:
I did try on Ubuntu, FP3 installed easily, but Lazarus was a bummer to install.

Program compiled and no problems at and everything works as expected on Linux.

Got plenty of suggestions to work with so I'll give them all a go and get back with a happy conclusion, I hope.

Cheers for now.

adriane:
Tracked down the culprit but still not solved on Windows 10.

Project raised exception class 'External: SIGPE'
In file Lplproc.pas at Line 902
which is :   if (length(Msg) div (length(Msg) div 10000))=0 then ;

That isn't the error but the divide by zero exception (that isn't see below code copied from unit) gets triggered in my program running Windows 10 whereas Linux does not.

{------------------------------------------------------------------------------
  procedure RaiseGDBException(const Msg: string);

  Raises an exception.
  Normally gdb does not catch fpc Exception objects, therefore this procedure
  raises a standard "division by zero" exception which is catched by gdb.
  This allows one to stop a program, without extra gdb configuration.
 ------------------------------------------------------------------------------}

procedure RaiseGDBException(const Msg: string);
begin
  debugln(rsERRORInLCL, Msg);
  // creates an exception, that gdb catches:
  debugln(rsCreatingGdbCatchableError);
  DumpStack;
  if (length(Msg) div (length(Msg) div 10000))=0 then ;
end;

User137:
You need to trace further what calls the RaiseGDBException().

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version