Forum > Windows

Can't change anything on a form

(1/3) > >>

Got a project and if I alter an element on the form in any way I get a division by 0 in the .lfm
All I tried doing was changing the design time position of a memo box. Compiled no problem. Tried to run from Windows (not in the IDE) and got divide by zero in .lfm
Put everything back as it was (by restoring the backed up lfm form) and it compiles and runs.
Altered again and this time run from within the IDE. Got a divide by zero!
Restored the backup and all fine again.
Next I tried to alter the font in a drop down. Compiled. Come out of Lazarus. Went back in and got a divide by zero error on the form.
Restored the backup again. Compiled and it runs within and out of the IDE and everything is good.
Version 1.4.4 Free Pascal 2.6.4 Windows 10
I suspect it is something amiss with Windows 10 but I can't work out what the issue is.
I'm at the point where trying the same things and expecting different outcomes is a sign of madness!

Can you try with 1.6RC1 ?


Can you try to simplify the project, i.e. remove non-standard controls, dependence on other forms etc., while keeping the bug and then upload the project here? (only lfm, pas, lpi and lpr files packed into a single zip)

Are there any non-standard components compiled into your lazarus? Sometimes strange behavior originates in third-party components. Uninstall them one by one and see whether the bug goes away after removing one particular component.

Moreover, turn off you anti-virus program for a test. We've seen here a lot of strange issues caused by the antivirus going crazy by self-made programs.

1. Will try 1.6 first. I'm pretty much convinced this is a Windows 10 issue.
2. I'm going to see if it still happens on Linux as well.
3. I'm also going to put the changes in the code so they occur at run-time. It does seem to be a form error.

1.6rc1 didn't sort it out.
As an experiment I changed the size/posn of the Memo component that I wanted to move by editing the .lfm using Notepad.
Went back in to Lazarus. Compiled and run. So that worked.


[0] Message Index

[#] Next page

Go to full version