Forum > Operating Systems

Compiling lazarus applications for OpenSolaris

<< < (2/2)

marcov:
Check the filetype with 'file'  and also check a file that comes with the distribution that way.

motaz:
for 32 bit:
ELF 32-bit LSB executable 80386 Version 1, dynamically linked, stripped


for 64 bit:
fpc:            ELF 64-bit LSB executable AMD64 Version 1, dynamically linked, stripped


btw, ppc386 and ppx64 are not there, should I compile the project? to get that files?
I found them in lib directory, should I copy them into bin directory?

motaz:
ppc386 and ppcx64 are working from lib directory, but when I tried to compile project I get this error:

Fatal: Can't find unit system used by Engine
Fatal: Compilation aborted

motaz:
I found install.sh script and I run it for 64 bit version, when I tried to compile a hello world .pas project I get this:

motaz@openindiana:~/asnparser$ fpc first.pas
Free Pascal Compiler version 2.6.4 [2014/03/06] for x86_64
Copyright (c) 1993-2014 by Florian Klaempfl and others
Target OS: Solaris for x86-64
Compiling first.pas
Assembling first
first.pas(3,24) Error: Assembler gas not found, switching to external assembling
first.pas(3,24) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)

Navigation

[0] Message Index

[*] Previous page

Go to full version