Recent

Author Topic: IDE (RC1) not doing BUILD on itself  (Read 1282 times)

userx-bw

  • Full Member
  • ***
  • Posts: 178
IDE (RC1) not doing BUILD on itself
« on: December 29, 2015, 02:51:36 pm »
when I went into Tools-> Configure "Build Lazarus"
set it up to build in profile - any of them I picked,
Quote
standard, Optimize, clean up build all,
gtk2 - Linux - x86_64
then told it where to put it
Quote
.lazarus
I get this no matter what and it fails to build
Code: [Select]
....
Compile package LazControls 1.0.1: Success
Compile package IDEIntf 1.0: Exit code 256, Errors: 1
componenttreeview.pas(774,3) Error: Can't open resource file "/home/userx/.lazarus/components/ideintf/../../images/componenttreeview.res"

the full path to the actual file is:

Code: [Select]
/home/userx/.lazarus/components/ideintf/units/x86_64-linux/nogui/componenttreeview.res

the permissions on that and all of the other files are,

Code: [Select]
-rw-r--r-- 1 userx userx 3470 Dec 29 06:28 /home/userx/.lazarus/components/ideintf/units/x86_64-linux/nogui/componenttreeview.res



More  JIC (Just In Case) Information,

what I did with this Lazarus was put it into the Download directory,
Code: [Select]
$ make clean bigide then I had to create a .lazarus dir, then copy the startlazarus, lazarus into there, then just kept copying whatever other directories it told me where missing into that same dir, the directories and all of what is in them over into .lazarus, this is everything within that base dir.

Quote
/home/userx/.lazarus/components
/home/userx/.lazarus/ide
/home/userx/.lazarus/lcl
/home/userx/.lazarus/packager
/home/userx/.lazarus/projectsessions
/home/userx/.lazarus/units

/home/userx/.lazarus/editormacroscript.xml
/home/userx/.lazarus/editoroptions.xml
/home/userx/.lazarus/environmentoptions.xml
/home/userx/.lazarus/fpcdefines.xml
/home/userx/.lazarus/idemake.cfg
/home/userx/.lazarus/includelinks.xml
/home/userx/.lazarus/inputhistory.xml
/home/userx/.lazarus/jcfsettings.cfg
/home/userx/.lazarus/laz_indentation.pas
/home/userx/.lazarus/lazarus
/home/userx/.lazarus/lazarus.dci
/home/userx/.lazarus/miscellaneousoptions.xml
/home/userx/.lazarus/packagefiles.xml
/home/userx/.lazarus/startlazarus
/home/userx/.lazarus/staticpackages.inc

I fire up Lazarus by going into .lazarus then typing ./lazarus - it opens up, then I went to do a build on it then got them errors,

It concerns me because if I add any 3rd party packages to it, I have to rebuild Lazars and this error I am getting may effect its ability to do so ... as well.

sooo...

how would I fix that, or is this a buggy to be reported seeings how I am using the RC1?
My Finished Projects
https://sourceforge.net/projects/mhsetroot/
https://sourceforge.net/projects/gmhsetrootfreepascalfrontend/

HP Elitetbook 6930p Dual Core Intel vPro 2.66 gHz
VOID (Linux) 64bit

 

TinyPortal © 2005-2018