Recent

Author Topic: tried update, some examples don't run, I'm all messed up now, please help  (Read 3109 times)

skyrider

  • Newbie
  • Posts: 3
A year or so ago I loaded lazarus-1.2.6-fpc-2.6.4-win32 and it seemed to work fine. I'm not a coding guru but I do enjoy designing and writing non-commercial apps. So I wrote a program to automate much of my home. It worked fine but it stayed unchanged for about a year. Last week I needed to make a slight change. I had some question so went to the Lazarus web site, saw that 1.4.4 was recommended. I downloaded it; had to uninstall my 1.2.6 first; but then did the install of 1.4.4. My app wouldn't compile due to missing BRABitmap, controls and such (as I expected). So I closed that; opened an example project (i just picked 'LoadPicture' from the list given for opening example projects). I clicked the green "Run" arrow. It said it compiled ok. but there was no screen activity, no app window. I started Task Manager and found 3 instances of LoadPicture.exe *32 on the process list. I tried 'File'+'Close-All'+'Quit' but Lazarus would not close. I tried 'Run'+'Stop' then 'Run'+'Reset Debugger' and Lazarus closed at that instant but popped up "loadpicture.exe Application Error" a red circle with white "X" and: "The application was unable to start correctly (0xc0000142). Click OK to close the application". I did. Then I checked the process list in Task Manager and still found 2 lines of loadpicture.exe. 'End Process' there had no effect.

I spent a couple hours searching this and other forums looking for answers. I saw where other people were trying to completely eliminate Lazarus (as if it had never been there) but to little avail. At that point I got really worried. I uninstalled 1.4.4 and tried again with similar results. I uninstalled again, I deleted all the Lazarus remnants, I removed the 4 Lazarus entries in the registry. I deleted the AppData config file, I purged the PATH, and deleted the unused (at that point) file extensions. I then tried 1.6.1RC thinking that, with FPC 3 that it would be all new stuff from an install point of view. I'm using Win7/64 with AMD64 CPU. This time i did NOT get the initial dialog saying that a prior version had been found (making me think i DID revert to 'never there' state) and did I want to update or not... But the results of trying to complete one of the example programs (untouched by me) was the same except this time it was a CheckBox project. The 'End Process' in Task Manager would never get rid of any of those triple-line checkbox.exe processes for any version of Lazarus.

BTW I have the latest MS service packs/updates, I run Autodesk Inventor, AutoCad, Photoshop, all the Open Office apps, the Arduino IDE, a few games, Firefox, some CNC simulators and lots more and have no anomalies with anything other than Lazarus.

So, as before I uninstalled Lazarus (this time the 1.6RC1) and purged the remnants as before. I tried 1.2.6, thinking I might revert to what had been working. NOT! Same behavior. So, as before I uninstalled Lazarus (this time the 1.2.6) and purged the remnants also as before. Then I reinstalled 1.4.4.

This time I started opening several example projects. I did 'Projects'+'Close Projects' then the Project Wizard pops up. I selected 'View Example Projects' (as I had done before) and then BitButton.lpi and then I clicked the green 'Run' button. There were NO messages, but after a few seconds the app appeared (no form had previously displayed in the IDE). The title was TBitBtn Verify, its app showed on the task bar, and the app worked correctly. I closed it. It still had no form in the IDE. I looked under all windows - not there! I looked at the 'View' menu and the top item 'Toggle Form/Unit view F12' was grayed out.

I experimented for about a day (I'm [supposed] retired). I could only clear the task list of anomalous processes by rebooting my PC. It took awhile. But I determined that a few other example projects were like BitButton, they appeared to compile, link to exe's and run. But many (most) of the examples would not and left those 3 processes hanging in task manager. Some showed design-time forms but gave compile errors then failed.

I was frustrated by the statement on the Lazarus website stating that everything needed was in the Windows installer. I was encouraged by my success a year or so ago with 1.2.6. and the success of 5000+ lines of code in my house automation app. I was expecting to need to load and update my optional controls like the BGRAxxx and TAChart and Synapse stuff, but I never expected that the canned and untouched example projects wouldn't run properly.

So...  I am at a total loss of what to do next, what to change, inspect, fix, whatever. I'm sure that most PC's just load the latest Lazarus and go. I suspect I'm doing something wrong. I know I'm no guru, but now I feel like an idiot. Please help. Thanks much !

marcov

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9029
  • FPC developer.
Re: tried update, some examples don't run, I'm all messed up now, please help
« Reply #1 on: December 19, 2015, 06:30:57 pm »
Try to exclude Lazarus + application development directories from the antivirus.

Both Lazarus (recompile when installing components) and the generated apps are not in antiviruses known files database, increase the case of trouble with avirii.

skyrider

  • Newbie
  • Posts: 3
Re: tried update, some examples don't run, I'm all messed up now, please help
« Reply #2 on: December 19, 2015, 07:40:58 pm »
Hhmm.. ok, at this point I'll try anything. I use Avast (free version) antivirus. It has been updated several times in 2015. I can (actually, I have) gone into it, to 'Settings'+'Exclusions' and added "C:\lazarus\*" to that list there. But I haven't done anything else. I'm [figuratively] walking on eggs here, as your suggestion sounds very promising!

But I don't want to mess up any more, so please bear with me just a little more.

Should I now uninstall all the 1.4.4 and purge my system; and then, now that the exclusion list has "C:\lazarus\*" in it, reinstall from the lazarus-1.4.4-fpc-2.6.4-win32.exe download ? Should I first: re-download it ? What is the surest/safest method ? I don't mind taking the time for trying your best advice!

Could I turn off Avast altogether (it allows that for a period of time) and try that ? In which case should I uninstall, purge, reinstall and would that be with a fresh lazarus-1.4.4-fpc-2.6.4-win32.exe download ? Or what ?

I sure hope this works. If I can get the examples to all work then I think I can get my other stuff going too.

Thanks so much for your reply!

skyrider

  • Newbie
  • Posts: 3
Re: tried update, some examples don't run, I'm all messed up now, please help
« Reply #3 on: December 20, 2015, 06:46:23 pm »
Got it. Thanks much Marcov ! You're a big help ! I'm up and running again.  :D

 

TinyPortal © 2005-2018