Recent

Author Topic: fpGUI - IDE build cannot find InfoBuild  (Read 4173 times)

Windsurfer

  • Sr. Member
  • ****
  • Posts: 362
    • Windsurfer
fpGUI - IDE build cannot find InfoBuild
« on: November 08, 2015, 09:20:42 pm »
I am using Lazarus 1.4.2 with Linux Mint 17.2 Cinnamon.

I have built fpGUI 1.4.1, and am now installing the latest fpGUI uidesigner-ext. I have placed the new main.pp as instructed but receive the following error message:

main.pp(93,44) Fatal: Cannot find unit InfoBuild used by Main.

I have search the drive for any file with infobuild contained in the name, but cannot locate it.

Has anyone any suggestions?

Graeme

  • Hero Member
  • *****
  • Posts: 1430
    • Graeme on the web
Re: fpGUI - IDE build cannot find InfoBuild
« Reply #1 on: November 09, 2015, 01:48:00 am »
The official fpGUI definitely doesn't contain any unit with the name InfoBuild.

I can't speak for UIDesigner-ext - as I don't maintain that project.
--
fpGUI Toolkit - a cross-platform GUI toolkit using Free Pascal
http://fpgui.sourceforge.net/

Windsurfer

  • Sr. Member
  • ****
  • Posts: 362
    • Windsurfer
Re: fpGUI - IDE build cannot find InfoBuild
« Reply #2 on: November 09, 2015, 08:48:47 am »
Thanks Graeme, I'll unload and reload again, starting with fpGUI only.

Graeme

  • Hero Member
  • *****
  • Posts: 1430
    • Graeme on the web
Re: fpGUI - IDE build cannot find InfoBuild
« Reply #3 on: November 09, 2015, 10:57:51 am »
I had a quick look an my system. Lazarus has an InfoBuild unit located in the "<lazarus>/ide/" directory. So it seems somewhere something got its knickers in a twist. ;-)
--
fpGUI Toolkit - a cross-platform GUI toolkit using Free Pascal
http://fpgui.sourceforge.net/