Recent

Author Topic: Can't active ZQuery into Lazarus object inspector and ZEOS connecion to SQLite  (Read 1690 times)

gelinp

  • Full Member
  • ***
  • Posts: 114
Hello,

I've got a simple zeos connection to SQLite databse. Here are parameters into object inspector for TZconnection and TZquery of main form:

ZConnection1 : TZconnection
Connected : true
Database : /home/gelinp/04_PROGRAMATION/projets/typodoc/data.sqlite
LibraryLocation : /usr/lib/libsqlite3.so
Protocol : sqlite-3

ZQuery1 : TZQuery
Active : false
Connection : ZConnection1
Datasource : DataSourceLesSequences
SQL : select * from PEDAGOLesSequences

If I try to activate ZQuery1, Lazarus freeze and I must reboot it.

I understand I have to use /usr/lib/libsqlite3.so as LibraryLocation because I can't use two libraries from differents paths, and Lazarus doesn't accept I use it from my project directory (Access violation when I run my application). And if I let  LibraryLocation empty I can't connect ZConnection1. So It looks like my parameter is OK.

If I try to open Zquery1 into the code formcreate event, then my application never display main form and I have to kill the process.

I can't understand what is wrong. Do you have an idea ?

Thanks for your help.

« Last Edit: November 04, 2015, 03:06:27 pm by gelinp »
My configuration is : Lazarus 1.6+dfsg-1 / FPC 3.0.0 / Debian Mint / x86_64-linux-gtk2

gelinp

  • Full Member
  • ***
  • Posts: 114
I respond to myself : There was a bug into my lazarus project, may be a conflict with libraires path, a new one resolve the problem. I notice it's running with libraryLocation empty ! I understand lazarus is looking for libsql3.so.0 into an other library path, specified somewhere else ...
My configuration is : Lazarus 1.6+dfsg-1 / FPC 3.0.0 / Debian Mint / x86_64-linux-gtk2

 

TinyPortal © 2005-2018