Recent

Author Topic: Weird GUI  (Read 2753 times)

ceh2624

  • New member
  • *
  • Posts: 6
Weird GUI
« on: September 22, 2015, 04:12:06 am »

I have some weird things happening on the Lazarus GUI. (1.4.2) 
This is installed on a Kubunbu 14.04 laptop. Once I get something written correctly, it compiles and builds with no problems.  The problem is at design time.  Firstly, in the code editor, the key for a lower case 'm' causes a 'CRLF'.  Shift-M works fine.  I even tried it with CapsLock on and the shift-m again acts like the return key.  It doesn't do that in any other application.
More weirdness
In the editor when I type Button. the suggestions come up ok but when I type the first letter of the property I want (eg. Caption) the auto fill goes away and I have to finish typing.
Yup, there's more...
In the Object Inspector, when I try to edit a property (name or caption) typing always repeats keystrokes.  For example to set a button caption to OK it ends up OOKK.  The backspace key deletes two chars at a time!  %)

Everything is fine on my dual boot Win7/Kubuntu14.04 Desktop.  Lazarus 1.4.2 works perfectly in both environments.

The laptop had Kubuntu14.04 then two weeks ago I upgraded to 15.05.  I got tired of swatting bugs  and switched the laptop back to 14.04 today.  This is where the weird stuff started.  Lazarus 1.4.2 worked perfectly in both previous OSs.  The OSs were all clean, new installs.


Any Ideas?
« Last Edit: September 22, 2015, 04:26:32 am by ceh2624 »

Leledumbo

  • Hero Member
  • *****
  • Posts: 8112
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Weird GUI
« Reply #1 on: September 22, 2015, 06:24:30 am »
Consider cleaning (or just rename) your Lazarus config folder. Something wrong with the keymapping or something else, I don't know. Moreover, what widgetset do your Lazarus use? Although it shouldn't matter as both gtk2 and qt works fine on my KDE on top of Manjaro.

M+AUDIO

  • New Member
  • *
  • Posts: 47
Re: Weird GUI
« Reply #2 on: September 22, 2015, 12:52:21 pm »
Hello

I remember same thing happened to me a month ago when I decided to try cross compiling,
"m" key in source editor acts like "return" key. and double characters in object inspector for every keypress.
the keypess issue was present in my compiled app too, for example in TEditBox and TMemo components.
However, I'm talking about lubuntu 14.0.4 LTS, lubuntu 15.0.4, GTK2 widgetset and lazarus 1.4.2 release.

I've searched at that time and then found some bug reports about this.
http://bugs.freepascal.org/view.php?id=23140
also some threads here in forum
http://forum.lazarus.freepascal.org/index.php?topic=26142.0
http://forum.lazarus.freepascal.org/index.php?topic=6231.0
http://forum.lazarus.freepascal.org/index.php?topic=16585.0

My problem got (temporarily) fixed by calling "ibus exit" in terminal. and after that I've changed "keyboard input method system:" in "language support" from "iBus" to "none". but it doesn't sounds like a real solution I think.

ceh2624

  • New member
  • *
  • Posts: 6
Re: Weird GUI
« Reply #3 on: September 23, 2015, 01:53:50 pm »

Fascinating...
Thanks for the suggestions.  I looked at the links you provided, M+AUDIO.  Many of them pointed to a bug in Lazarus.  It seem that Lazarus doesn't play nice with ibus which goofs up the key mapping. ibus exit does the trick (all weird behaviour stops) but instead of a fix it's only a workaround. The weird thing is it only happens on this installation on my laptop.  Even previous installations on the same version of Kubuntu didn't have any problems.
« Last Edit: September 23, 2015, 02:43:13 pm by ceh2624 »