Recent

Author Topic: [Solved] One or more packages needed not found  (Read 1020 times)

clauer

  • Newbie
  • Posts: 1
[Solved] One or more packages needed not found
« on: August 20, 2015, 09:52:33 am »
Hi,

Solved due a posting in Third Party, FastReport 5.

coming from Delphi I'm new to Lazarus / Freepascal. First testing was succesful, the IDE worked as it should and I was able to run a short test program.

As I need a good report generator I tried to install the FastReports 5 version for Lazarus (not the Lazarus report generator which I installed first and shortly later uninstalled before installing FastReport 5). Now when I recompile Lazarus to get the component working I get the error message "One or more packages needed not found" and it shows me the Package Graph where nearly all of the components have a red sign.

On another machine I get the same error but in the Package Graph there are only two components marked with a red sign: lhelpcontrolpgk  0.2 (in the right window) and fs_lazarus contained in fr_lazarus 5.2. 

Looking under Package-Links I see that all packages are valid, the correct folder is displayed.

What might be wrong? And, how can I fix it?

Thanks for any help and regards
Christian
« Last Edit: August 20, 2015, 11:38:58 pm by clauer »