Recent

Author Topic: Loss Of Networked Storage Crashes Lazarus  (Read 1974 times)

Signal

  • New member
  • *
  • Posts: 41
Loss Of Networked Storage Crashes Lazarus
« on: April 16, 2015, 04:44:13 pm »
I find this completely weird. Here is what happened. Everything in the house is on an UPS, except the Internet connection (nothing I can do about that).

I was working with Laz when the power went out. Everything kept working normally for about 15 minutes on UPS power, then a compile simply hung. No error messages, just greyed out controls. Closing the IDE resulted in a message something like The IDE is Still Rebuilding. However, I was only doing a simple compile, not rebuilding the IDE.

I went to another machine. Laz did the same thing. I tried different projects and an empty project and got the same results.  I figured it had to have something to do with the power failure, so I ran connectivity checks and found my NAS in another part of the house was offline. Its UPS had failed.

Once I restored power to the UPS, both Laz installations resumed working normally.

This can't be proper behavior. The project I was working on lives on the local hard drive. The only thing I do with the NAS is publish to it once in awhile for backup purposes. I wasn't doing anything like that on either machine when Laz went South.

I double checked project and installed package paths to make sure that none of them were pointing to the NAS. I found nothing.

One machine was running production 1.2.6, the other 1.4RC2, both on Linux.

Thoughts anyone?