Recent

Author Topic: Can't install package  (Read 2042 times)

hy

  • Full Member
  • ***
  • Posts: 214
Can't install package
« on: March 26, 2015, 12:35:37 pm »
I am not using packages heavily but there are some visual components that I need.
Now I had a fresh install on a new computer

My package compiles well and all compiled units reside in $PackageDIr/lib/x86_64-linux
When trying to install the package I am getting:

lazarus.pp(1,1) Fatal: Cannot find oycomponents used by Lazarus, incompatible ppu=/media/work/src/ylib/oy/package/lib/x86_64-linux/oycomponents.ppu, package oycomponents
oycomponents is my package and

Well, the file exists - but why the heck am I getting a mismatch/incompatible ppu?
OS Debian; Lazarus 1.5 SVN 48502
_____
***hy
OS: debian sid(64bit)  [fpc 3.0.4] Lazarus SVN

hy

  • Full Member
  • ***
  • Posts: 214
Re: Can't install package
« Reply #1 on: March 26, 2015, 09:17:13 pm »
Ok, I had a strange error:
The package file  oycomponents.lpk contained an entry that was utterly wrong:
Instead of
Code: [Select]
    <UsageOptions>
      <UnitPath Value="$(PkgOutDir)"/>
    </UsageOptions>
there was something added to the UnitPath - sorry I can't remember but after comparing to another package I use I've wondered why there are two entries in Usage options.
After removing it everything worked fine.
_____
***hy
OS: debian sid(64bit)  [fpc 3.0.4] Lazarus SVN

 

TinyPortal © 2005-2018