Recent

Author Topic: Test on [FPC 2.7.1 , OS X 10.10 , iOS 8.1 , XCode 6.1]  (Read 4793 times)

simonsayz

  • New Member
  • *
  • Posts: 27
Test on [FPC 2.7.1 , OS X 10.10 , iOS 8.1 , XCode 6.1]
« on: October 25, 2014, 07:48:28 pm »

It works on device & simulator

- FPC 2.7.1, OSX 10.10, iOS 8.1, XCode 6.1

Ref. http://blog.naver.com/simonsayz/220161343864

Best Regards
Simon,Choi

MISV

  • Hero Member
  • *****
  • Posts: 650
Re: Test on [FPC 2.7.1 , OS X 10.10 , iOS 8.1 , XCode 6.1]
« Reply #1 on: November 17, 2014, 02:35:00 pm »
Thanks. I am currently looking into if one can do iOS development with Lazarus. Your post gives some optimism :)

CCRDude

  • Hero Member
  • *****
  • Posts: 502
Re: Test on [FPC 2.7.1 , OS X 10.10 , iOS 8.1 , XCode 6.1]
« Reply #2 on: December 01, 2014, 04:25:47 pm »
Thanks for yet another great set of instructions!

Currently setting up another machine, this time with Yosemite, and noticed one thing.

What's listed as a tip near the bottom needs to be a prerequisite at the top really. XCode 6/6.1 doesn't bring the iPhoneSimulator6.1.sdk any more, ane web researches indicate that XCode never supports more than current plus one previous versions.

Meaning it's essential for this to work to get the SDK from a previous XCode version!

In my case, I had another Mac with 10.8 and XCode 5 from which I took the SDKs. In other cases, they may simply exist from older versions (?), but fro fresh installs, this is a key prerequisite.

It should be possible to download old XCode versions from the Developer Center. Not sure how to extract SDKs there, I'm currently testing with the copy from the other machine.

CCRDude

  • Hero Member
  • *****
  • Posts: 502
Re: Test on [FPC 2.7.1 , OS X 10.10 , iOS 8.1 , XCode 6.1]
« Reply #3 on: March 05, 2015, 08:10:49 am »
I was just browsing this again since I need an iOS 8.1 feature (local notifications won't work on 8.1 unless you register them first, and this registration is part of the 8.x SDK only), and noticed the link to iPhoneall8.1.zip is actually pointing to parser_ios8.1.zip. I would have assumed this is due to the parser not working, but since there's a different file size behind the link, I hope there's actually a zip I can download... could you please fix you otherwise great tutorial to include the proper link?

CCRDude

  • Hero Member
  • *****
  • Posts: 502
Re: Test on [FPC 2.7.1 , OS X 10.10 , iOS 8.1 , XCode 6.1]
« Reply #4 on: March 06, 2015, 09:52:55 am »
Another update regarding my first comment: simonsayz' pager says to take the 6.1 SDK from XCode 4.5.2. But 4.5.2 only includes the 6.0 SDK, you'll need XCode 4.6.3.
Just downloaded them both and verified that :)

Update: you can find a working link to that file in one of the older posts :)
« Last Edit: March 06, 2015, 10:42:44 am by CCRDude »