Recent

Author Topic: Android Module Wizard and Typhon  (Read 4943 times)

developing

  • New Member
  • *
  • Posts: 26
Android Module Wizard and Typhon
« on: February 23, 2015, 10:23:40 am »
Hi all
I'm new in Android Module Wizard, but word with Typhon 1 year.(I was Delphi programmer for 4 years)

For install and use Android Module Wizard I read this post, but don't complete to install and run it.

Because I encountered Below error:

Error to install and use Android Module Wizard.


Anybody have a solution, Help or Tutorial for me?Please.


http://www.pilotlogic.com/sitejoom/index.php/forum/android/3026-new-components-for-android#6800

jmpessoa

  • Hero Member
  • *****
  • Posts: 1481
Re: Android Module Wizard and Typhon
« Reply #1 on: February 23, 2015, 02:55:20 pm »
Hi Developing... you missing configure NDK path? This error is about path to libs missing [-Fl] ..

Go to IDE->Project->Project Options->Path .... In my [windows] system I can see [-Fl]:


C:\adt32\ndk10\platforms\android-13\arch-arm\usr\lib\;
C:\adt32\ndk10\toolchains\arm-linux-androideabi-4.6\prebuilt\windows\lib\gcc\arm-linux-androideabi\4.6\

[When all configs paths are corrects this is automatically make by Wizard ...]

Edit 1: If you want run some demo App... please change some paths in "*.lpi" according with your system ...

Edit 2:  About "Upgrade Code Templates", again you missing configure "java templates" path... In my sytem : "C:\laz4android1346592\components\LazAndroidWizard\java"

Edit 3: About "and when I copy and replace App.java..." or "Controls.java", yes you can do it, but then you
need change/configure the first line .... your package name.
« Last Edit: February 23, 2015, 03:36:37 pm by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

developing

  • New Member
  • *
  • Posts: 26
Re: Android Module Wizard and Typhon
« Reply #2 on: February 24, 2015, 09:05:23 am »
Hi and thanks for soon answer.

When I open C:\lazandroidmodulewizard-master\demos\Eclipse\AppActionBarTabDemo1\jni\controls.lpi following Error was shown.

I have Android NDK r7-crystax-5.beta3-windows
JDK 1.6.0_25 and 1.8.0_31
Apache Ant 1.9.2
and Typhon32 Ver.5.1

Do you have any solution?
« Last Edit: February 24, 2015, 09:09:27 am by developing »

developing

  • New Member
  • *
  • Posts: 26
Re: Android Module Wizard and Typhon
« Reply #3 on: February 24, 2015, 09:17:11 am »
Another question: How can I create new jniAnroidModule project.

In other words, how to fill the below window?

And other settings must do?

jmpessoa

  • Hero Member
  • *****
  • Posts: 1481
Re: Android Module Wizard and Typhon
« Reply #4 on: February 24, 2015, 04:58:19 pm »
Hi @Developing,

Question 1.

Code: [Select]
... When I open C:\lazandroidmodulewizard-master\demos\Eclipse\AppActionBarTabDemo1\jni\controls.lpi following Error was shown...
Solution: Just click "continue loading..."  Now, simule some change in component property [ex. Tag=2] and save....

Why? jListView LOST this property in some revision....

Question 2:
Code: [Select]
...how to fill the below window...
Action 1: [First]: Go to IDE --> Tools --> Android Module Wizard ---> Setting Paths [jdk, sdk, ndk...]

Action 2:

a) Path to Workspace: Just path to your Projects folder
     ex: C:\adt32\eclipse\workspace
or   C:\adt32\ant\workspace   
or  C:\android\myprojects

That is: some folder to centralize your projects!!!

b) You Project name! [if you created your project using eclipse just select it! or
if you will make using "ant" just enter the prject name: ex "MyProject1"

c) Accept as is...

d) [plataform = iceCream 4.0x] [minSdk=14] [Taget = 17]

e) [Instruction = Armv6] [Arm fpu = soft] [Project = Ant ou Eclipse? see item "b']

Please: read the "readme.txt", "install_tutorial_ant_users.txt",  install_tutorial_eclipse_users.txt

Thank You!

Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

developing

  • New Member
  • *
  • Posts: 26
Re: Android Module Wizard and Typhon
« Reply #5 on: March 01, 2015, 05:19:54 am »
Hi
I start agin on new windows XP.

I followed tutorial in install_tutorial_eclipse_users.txt

Download laz4android1.3-46592-FPC2.7.1 from sourceforge and install it,
install android NDK r7, SDK and JDK 8.0_31.
download apache-ant-1.9.2 and set the pathes.

Mentioned orders well done.

Even tfpandroidbridge_pack.lpk package install on laz4android and lazandroidwizardpack.lpk package compile well done, but when select "Use>Install" for this package shown below message. And repeat these behavior when I want install amw_ide_tools.lpk.

Can you help me to install and run these packages?

Thanks.

« Last Edit: March 01, 2015, 05:45:55 am by developing »

jmpessoa

  • Hero Member
  • *****
  • Posts: 1481
Re: Android Module Wizard and Typhon
« Reply #6 on: March 01, 2015, 06:49:01 am »
Hi Developing!

Sorry, I never found this error! Let's see if someone can help here ....

One thing I always recommend  is to open a simple/trivial windows project [like TForm1 ... etc.] before install the "Lamw" packages....
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

Leledumbo

  • Hero Member
  • *****
  • Posts: 8138
  • Programming + Glam Metal + Tae Kwon Do = Me
Re: Android Module Wizard and Typhon
« Reply #7 on: March 01, 2015, 07:30:00 am »
C:\Program Files? I think that's the problem...

developing

  • New Member
  • *
  • Posts: 26
Re: Android Module Wizard and Typhon
« Reply #8 on: March 01, 2015, 08:35:46 am »
Thanks Leledumbo.

I uninstall laz4android from "C:\Program Files\laz4android" path, reinstall in "C:\laz4android" and all problems solved.