Recent

Author Topic: fpcup 3.1.1 Update  (Read 120262 times)

Thaddy

  • Hero Member
  • *****
  • Posts: 10795
Re: fpcup 3.1.1 Update
« Reply #135 on: July 13, 2016, 11:40:35 am »
Nope.
Let's discuss. < you have my email? >

zbyna

  • Jr. Member
  • **
  • Posts: 52
Re: fpcup 3.1.1 Update
« Reply #136 on: July 13, 2016, 12:54:33 pm »
As for FRET_UNKNOWN_REVISION.:
win7 64bit.
problem disappeared with --getfullrepo too
Code: [Select]
fpclazup.exe --fpcURL="trunk" --lazURL="trunk" --installdir="E:\Development\" --getfullrepo
...
Version: based on commit fpcup001 (20150210)
Build date: 2016/07/02 08:19:01
Compiled for CPU: i386 on win32
...
fpclazup: info: INFO: directory E:\Development\fpc is not an SVN repository (or a repository with the wrong remote URL).
fpclazup: info: INFO: creating directory E:\Development\fpc for SVN checkout.
fpclazup: info: Running SVN checkout or update.
fpclazup: info: FPC was at: failure
fpclazup: info: FPC is now at: revision 34101
...

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1464
Re: fpcup 3.1.1 Update
« Reply #137 on: July 13, 2016, 01:02:26 pm »
Updated fpc(laz)up !
Should now return correct revision in all cases.
I hope ...  :)

Thaddy

  • Hero Member
  • *****
  • Posts: 10795
Re: fpcup 3.1.1 Update
« Reply #138 on: July 13, 2016, 01:28:02 pm »
I hope the dependencies are also covered again? I hope? Otherwise I will spoil your dinner again!
Going to run some tests... 8) %)

zbyna

  • Jr. Member
  • **
  • Posts: 52
Re: fpcup 3.1.1 Update
« Reply #139 on: July 13, 2016, 02:50:09 pm »
Updated fpc(laz)up !
Should now return correct revision in all cases.
I hope ...  :)

Thanks !

rvk

  • Hero Member
  • *****
  • Posts: 4479
Re: fpcup 3.1.1 Update
« Reply #140 on: July 14, 2016, 03:09:58 pm »
How do you install Lazarus 1.6 with fixes and FPC 3.0.0 with fixes?

(B.T.W. FPCUrl=3.0.2 doesn't exist yet. 3.0.2rc1 does. Luckily "fixes" from branche contains the same fixes)

I tried
fpclazup64.exe --fpcURL=fixes --lazURL=fixes

but got errors.
Is this again due to the wrong bootstrap compiler?
(If so... isn't that going to be a problem with 1.6.2 later on?)

Code: [Select]
C:/development/fpcbootstrap/ppcx64.exe -Ur -Xs -O2 -n -Fi../inc -Fi../x86_64 -FE. -FUC:/development/fpc/rtl/units/x86_64-win64 -vi-n-h- -dx86_64 -dRELEASE ../inc/uuchar.pp
C:/development/fpcbootstrap/ppcx64.exe -Ur -Xs -O2 -n -Fi../inc -Fi../x86_64 -FE. -FUC:/development/fpc/rtl/units/x86_64-win64 -vi-n-h- -dx86_64 -dRELEASE -I../objpas ../objpas/objpas.pp
C:/development/fpcbootstrap/ppcx64.exe -Ur -Xs -O2 -n -Fi../inc -Fi../x86_64 -FE. -FUC:/development/fpc/rtl/units/x86_64-win64 -vi-n-h- -dx86_64 -dRELEASE -Fi../objpas/sysutils -Fi../objpas/classes -Fu../x86_64 -I../win -I../objpas -I../win/wininc -Fu../win/wininc -Fu../win -I../inc -Fu../inc -Fu../objpas buildrtl
typshrdh.inc(54,23) Error: It is not possible to overload this operator. Related overloadable operators (if any) are:
typshrdh.inc(54,24) Error: It is not possible to overload this operator. Related overloadable operators (if any) are:
typshrdh.inc(54,24) Fatal: Syntax error, ":" expected but ">" found
Fatal: Compilation aborted
make.exe[7]: *** [buildrtl.ppu] Error 1
make.exe[7]: Leaving directory `C:/development/fpc/rtl/win64'
make.exe[6]: *** [win64_all] Error 2
make.exe[6]: Leaving directory `C:/development/fpc/rtl'
make.exe[5]: *** [rtl] Error 2
make.exe[5]: Leaving directory `C:/development/fpc/compiler'
make.exe[4]: *** [next] Error 2
make.exe[4]: Leaving directory `C:/development/fpc/compiler'
make.exe[3]: *** [ppc1.exe] Error 2
make.exe[3]: Leaving directory `C:/development/fpc/compiler'
make.exe[2]: *** [cycle] Error 2
make.exe[2]: Leaving directory `C:/development/fpc/compiler'
make.exe[1]: *** [compiler_cycle] Error 2
make.exe[1]: Leaving directory `C:/development/fpc'
C:\development\fpcbootstrap\make.exe: *** [build-stamp.x86_64-win64] Error 2
C:\development\fpcbootstrap\make.exe: Leaving directory `C:/development/fpc'

WTDdallas

  • Full Member
  • ***
  • Posts: 100
Re: fpcup 3.1.1 Update
« Reply #141 on: July 14, 2016, 03:21:50 pm »
Updated fpc(laz)up !
Should now return correct revision in all cases.
I hope ...  :)

Thanks !

Where do we get fpclazup.exe?

rvk

  • Hero Member
  • *****
  • Posts: 4479
Re: fpcup 3.1.1 Update
« Reply #142 on: July 14, 2016, 03:24:57 pm »
Where do we get fpclazup.exe?
(I sent you the link in a PM.)

Wiki page: http://wiki.freepascal.org/fpcup
Github page: https://github.com/LongDirtyAnimAlf/Reiniero-fpcup
Bin-directory for fpclazup64.exe: https://github.com/LongDirtyAnimAlf/Reiniero-fpcup/tree/master/bin/x86_64-win64
(assuming you have 64bit OS and want 64bit Lazarus)

fpclazup64.exe --fpcURL=trunk --lazURL=trunk --getfullrepo


As said in an earlier post I wanted to only do the fixes for Laz1.6 and FPC but that doesn't seem to work. The trunk install works correctly.
fpclazup64.exe --fpcURL=fixes --lazURL=fixes (this doesn't work)
« Last Edit: July 14, 2016, 03:28:05 pm by rvk »

zbyna

  • Jr. Member
  • **
  • Posts: 52
Re: fpcup 3.1.1 Update
« Reply #143 on: July 14, 2016, 03:44:36 pm »
Updated fpc(laz)up !
Should now return correct revision in all cases.
I hope ...  :)

Thanks !

Where do we get fpclazup.exe?

I am using  files from bin folder, located on project github,  according  cpu & os  I need:
https://github.com/LongDirtyAnimAlf/Reiniero-fpcup/tree/master/bin

rvk

  • Hero Member
  • *****
  • Posts: 4479
Re: fpcup 3.1.1 Update
« Reply #144 on: July 14, 2016, 05:15:53 pm »

That's also the reason why there are no bootstrap compilers hosted on fpcup GitHub.
Valid... but isn't there any chance to just get proper bootstrap compilers for all platforms in
ftp://ftp.freepascal.org/pub/fpc/dist/3.0.0/bootstrap

This has already been discussed on the FPC mailing list !
http://lists.freepascal.org/pipermail/fpc-devel/2016-June/037172.html
Ok, maybe a really daft question of me but where can I find the official FPC 3.0.0 64bit release ?

(the one with only 64bit and a clean ppcx64.exe)

I can find a 3.0.0 package for Linux (which I use to extract FPC3.0.0 compiler). But I can't find it for Windows 64bit. It is included in Lazarus 1.6 64bit but that's a much larger install(-file).

Edit:
Ok, I guess I need to use the cross-compiler then (as was the same with FPC 2.6.4 for x86_64).
http://forum.lazarus.freepascal.org/index.php/topic,29452.msg186131.html#msg186131
(and so should fpclazup because it needs fpc3.0.0 for the fixes/fixes target. Pfffff, it doesn't get easier with that :()
« Last Edit: July 14, 2016, 05:25:31 pm by rvk »

WTDdallas

  • Full Member
  • ***
  • Posts: 100
Re: fpcup 3.1.1 Update
« Reply #145 on: July 14, 2016, 06:56:38 pm »
Download fpclazup64.exe, Ran,  works

Tried to add sparta_dockedformeditor and crashes.  :o

Deleted lazarus.exe and renamed lazarus.old.exe, So I am fine  :D (Didn't know you could do that before).

Any Updates for that package?

Also UTF8 not working?
« Last Edit: July 14, 2016, 07:06:31 pm by WTDdallas »

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3935
  • I like bugs.
Re: fpcup 3.1.1 Update
« Reply #146 on: July 14, 2016, 08:13:23 pm »
Tried to add sparta_dockedformeditor and crashes.  :o
...
Also UTF8 not working?

Both sparta_dockedformeditor and UTF-8 work well here. What is wrong with UTF-8 in your system?

Yes, renaming lazarus.old.exe is fine but you should also copy a working Lazarus executable and give it a distinctive name.
Then you can always start it when things go wrong.
Mostly Lazarus trunk and FPC 3.2 on Manjaro Linux 64-bit.

rvk

  • Hero Member
  • *****
  • Posts: 4479
Re: fpcup 3.1.1 Update
« Reply #147 on: July 14, 2016, 08:14:09 pm »
Tried to add sparta_dockedformeditor and crashes.  :o
I had that too this morning (uninstalled anchor and sparta packages).
It's already reported:
http://bugs.freepascal.org/view.php?id=30377

WTDdallas

  • Full Member
  • ***
  • Posts: 100
Re: fpcup 3.1.1 Update
« Reply #148 on: July 14, 2016, 11:54:37 pm »
Both sparta_dockedformeditor and UTF-8 work well here. What is wrong with UTF-8 in your system?

It was not finding it, may be a compiler switch I don't have set, or a package I have not loaded yet?

Trying to add a package that required it and it said not found :
rxpopupunit.pas(915,3) Error: Identifier not found "UTF8Delete"
rxpopupunit.pas(915,25) Error: Identifier not found "UTF8Length"

rvk

  • Hero Member
  • *****
  • Posts: 4479
Re: fpcup 3.1.1 Update
« Reply #149 on: July 15, 2016, 07:58:53 am »
Both sparta_dockedformeditor and UTF-8 work well here. What is wrong with UTF-8 in your system?
It was not finding it, may be a compiler switch I don't have set, or a package I have not loaded yet?
Trying to add a package that required it and it said not found :
rxpopupunit.pas(915,3) Error: Identifier not found "UTF8Delete"
rxpopupunit.pas(915,25) Error: Identifier not found "UTF8Length"
Where did you get the rcpopupunit ? It's not in the normal rx package.

Anyway... did that file include LazUtf8 in the uses? Because the functions are there.

 

TinyPortal © 2005-2018