Forum > General

Run a project... compiled but not executed! Why?


Giuseppe RidinĂ²:
As the subject says, I run a project, (for example "Hallo World!"), but the .exe file is produced  but is not launched. So I have to go to the project folder and run it manually.
The strange thing is that previously it worked, but with the last version (lazarus- installed it doesn't anymore.
Maybe I need to set something but I couldn't find it nowhere.  :cry:
Thanks in advance for any suggestion.

P.S. I use WinXP.

Vincent Snijders:
This has probably something to to with output to the console.
If you run your program in a dos-box, does it write anything to the dos-box? This situation is not handled correctly by lazarus yet.

Giuseppe RidinĂ²:
To be more exact only projects created using Lazarus previous version are compiled but not launched from the IDE, while projects created using the same version are launched properly.
BTW, when I run the *.exe (created with the new version) from a dos box, this is the output:

--- Code: ---TBitmap.SetMaskHandle A FImage.FHandle=A90510AD FImage.FMaskHandle=00000000
TBitmap.SetMaskHandle END FImage.FHandle=A90510AD FImage.FMaskHandle=C4051569
--- End code ---
It looks not very useful  :?

Vincent Snijders:
It was usefull to the person who implemented - debugged masked bitmaps.  We are working on a solution for these (sometimes usefull, but most of the time not) debug output, so that is doesn't hinder normal apps.


[0] Message Index

Go to full version