Author Topic: problem with Lazreport  (Read 5507 times)


  • Newbie
  • Posts: 1
problem with Lazreport
« on: July 04, 2006, 03:10:12 pm »
I have last (04.07.2006) Lazarus from CVS and I installed Lazreport from CVS - no problem - but when I tried to save and after to load an report it give me some errors - as "unsupported FRF format" - or "unsupported UTF8 character" - or "Duplicate attribute" - and finaly "Access violation" - it seem that it don't save correct the report to file (in *.lrf) - I am using Lazarus under Win32 - WinXP Sp2. What can I do - it is a solution or not ?


  • Sr. Member
  • ****
  • Posts: 470
RE: problem with Lazreport
« Reply #1 on: July 05, 2006, 02:00:11 am »
This is one of the reasons why FPC 2.0.2 is the recommended compiler for working with LazReport, you don't specify if you tried to load and save the sample report salida.lrf, anyway the kind of problem is probably something like this: salida.lrf was using a string like this "Page Nº 1/32" on each page of output report, the problem is that simbol "º" is not a valid UTF8 character and in recent FPC versions TXMLConfig was made more strictier and it complains in things like this. Check that your report use only ascii characters under FPC 2.1.1 or FPC 2.0.3. Under 2.0.2, TXMLConfig is more forgiven on this things.

In LazReport currently only *.lrf format is supported.

Also, a new release in LazReport sourceforge project page (not LazReport web page) has been made, in that release salida.lrf report was modified to not include the symbol "º" so it should work ok even in FPC2.1.1 but it's untested.

Once FPC 2.0.4 is out a solution have to be found (or maybe it have one solution already....)


TinyPortal © 2005-2018