Recent

Author Topic: [solved] Connector for MariaDB 10.x  (Read 4448 times)

Ocye

  • Hero Member
  • *****
  • Posts: 518
    • Scrabble3D
[solved] Connector for MariaDB 10.x
« on: October 25, 2014, 02:27:05 pm »
I updated my server recently and get the error message:

Quote
Fatal error: TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (10.0.14-MariaDB).
(The same with TMySQL55Connection).

How can I solve this issue? (Except downgrading to 5.5 which I've done for now.)
« Last Edit: October 26, 2014, 12:51:48 pm by Ocye »
Lazarus 1.7 (SVN) FPC 3.0.0

BigChimp

  • Hero Member
  • *****
  • Posts: 5740
  • Add to the wiki - it's free ;)
    • FPCUp, PaperTiger scanning and other open source projects
Re: Connector for MariaDB 10.x
« Reply #1 on: October 25, 2014, 02:31:07 pm »
Have you searched the forum? AFAIR there's a fix in FPC trunk but not in FPC 2.6.x (nor is one expected (edit) as there are no further planned 2.6.x releases).

Edit: mmm, don't know about the forum, but this is the relevant bug report:
http://bugs.freepascal.org/view.php?id=26620
« Last Edit: October 25, 2014, 09:28:19 pm by BigChimp »
Want quicker answers to your questions? Read http://wiki.lazarus.freepascal.org/Lazarus_Faq#What_is_the_correct_way_to_ask_questions_in_the_forum.3F

Open source including papertiger OCR/PDF scanning:
https://bitbucket.org/reiniero

Lazarus trunk+FPC trunk x86, Windows x64 unless otherwise specified

Ocye

  • Hero Member
  • *****
  • Posts: 518
    • Scrabble3D
Re: Connector for MariaDB 10.x
« Reply #2 on: October 26, 2014, 12:51:38 pm »
Many thanks. TMySQL56Connection works with MariaDB 10.x when I compile with fpc 2.7.1.
Lazarus 1.7 (SVN) FPC 3.0.0