Recent

Author Topic: Lazarus on Raspbian  (Read 2150 times)

Carsten315

  • Newbie
  • Posts: 2
Lazarus on Raspbian
« on: September 13, 2014, 08:08:28 pm »
Hello!

I tried to install Lazarus on Raspbian Pi (Version 09.09.) with the following commands:
Code: [Select]
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fpc
sudo apt-get install lazarus
The problem starts at the line "sudo apt-get install fpc". Here I get the error that the dependency to fcp-2.6.0 is missing.

I did not install other software!

What did I make wrong...? Please can anyone help me...?

Regards
Carsten

dogriz

  • Full Member
  • ***
  • Posts: 105
    • Tech blog - Delphi, Lazarus, Firebird, Windows, Linux, Android...
Re: Lazarus on Raspbian
« Reply #1 on: September 13, 2014, 09:57:58 pm »
Code: [Select]
sudo aptitudeUse aptitude to resolve problems with fpc installation (wrong version of binutils package).
Or dist-upgrade to raspbian jessie (I'm doing it while typing this, actually it is updating for a few hours now...veeery slow). In jessie repo you have fpc 2.6.2 and lazarus 1.2.4.
FPC 3.0.4
Lazarus 2.0.2
Debian x86_64, arm