Recent

Author Topic: [SOLVED] Problems with LazReport, Spanish version.  (Read 2744 times)

RickDeCastro

  • Newbie
  • Posts: 2
[SOLVED] Problems with LazReport, Spanish version.
« on: September 04, 2014, 04:31:19 pm »
Hi guys.
English is not my first language, so I hope you can understand me.

I'm a newbie at the Lazarus environment and I am evaluating as a development tool in Spanish.
Now I'm testing the LazReport and everything seems to run smoothly.
During my research, I noticed some inconsistencies related to the Preview Tool:
1. I have installed the spanish version of LazReport and the Preview Tool also appears in spanish at design time. Perfect. However, some buttons are not appropriate icons (Zoom -, Zoom +, and Text Search) is even work perfectly.

2. On the other hand, compiles the application with the English version. That is, if we run the EXE created, all in the preview comes out in English. However, there other icons of all buttons shown.

3. The button [Search text] opens a dialog to enter a search string but ... does not work. Most of the time says that "not found" a text that is displayed and others do not do anything.

Questions:
a) Does anyone know if you can to "locate" the compiled version? (changing the languaje of the preview compilated)

b) To some it worked Text Search?

TIA
« Last Edit: September 05, 2014, 12:04:50 am by RickDeCastro »

otorres

  • Jr. Member
  • **
  • Posts: 94
Re: Problems with LazReport, Spanish version.
« Reply #1 on: September 04, 2014, 05:30:27 pm »
Code: [Select]
uses gettext,translations;

procedure TranslateResStrings;
var
  Lang, FallbackLang: String;
begin
  GetLanguageIDs(Lang,FallbackLang); // in unit gettext
  TranslateUnitResourceStrings('LCLStrConsts','C:/lazarus/lcl/languages/lclstrconsts.%s.po', Lang,FallbackLang);
  TranslateUnitResourceStrings('Lr_const','C:/lazarus/components/lazreport/source/languages/lr_const.%s.po', Lang,FallbackLang);
end;

Initialization
  TranslateResStrings; 



The case of search text i dont know how to fix.

RickDeCastro

  • Newbie
  • Posts: 2
Re: Problems with LazReport, Spanish version.
« Reply #2 on: September 05, 2014, 12:01:02 am »
Thanks otorres.

That's it.
Works fine the translation now.


jesusr

  • Sr. Member
  • ****
  • Posts: 470
Re: [SOLVED] Problems with LazReport, Spanish version.
« Reply #3 on: November 14, 2014, 12:40:10 am »
Searching the text in preview window seems to work here (most of the times :)), the problem was that the found text was not highlighted but that was fixed in r46761

 

TinyPortal © 2005-2018