Forum > Linux PDAs

Problem installing Lazarus


I try to install Lazarus following official instruction.

--- Code: ---sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fpc
--- End code ---

After runing last line I get next massage:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies: fpc : Depends: fpc-2.6.0 (= 2.6.0-9+rpi1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
I boot RPI to shell, I increase swap file to 600M, I install

--- Code: ---sudo apt-get install binutils-dev
--- End code ---
but no success.

Any idea?
Regards, Matija

No ideas.

However: What operating system are you running? On a Raspberry Pi?
See first link in my signature.


Sorry for lack of information.

I run preinstalled OS - Debian on 8G SD card. RPI is B+.
Before Lazarus I install MySql server and connector. Nothing else.

Regards, Matija

I find the solution.
I use fresh image and write

--- Code: ---sudo apt-get update
--- End code ---
after that if i use upgrade I get an error when installing fpc.
So I first Install

--- Code: ---sudo apt-get install fpc
sudo apt-get install lazarus

--- End code ---
and after that

--- Code: ---sudo apt-get upgrade
--- End code ---
RPI give me an error that I have some dependencies isues with lazarus and lcl but after I run

--- Code: ---sudo apt-get -f install
--- End code ---

I can succesfully finish the upgrade and Lazarus was working fine.

Regards, Matija

Glad you got it working & thanks for posting your solution!


[0] Message Index

Go to full version