Recent

Author Topic: fpc-1.9.3-040306 uses unix,linux,basunix,oldlinux again...  (Read 6080 times)

grogh

  • Guest
fpc-1.9.3-040306 uses unix,linux,basunix,oldlinux again...
« on: April 30, 2004, 09:46:05 am »
I am using fpc-1.9.3-040306 becouse I use lazarus. So, my old sources doesn't compile anymore...

Troubles... 1. in old source, that works perfectly with 10.0.10 when uses linux

Error: Identifier not found "geteuid" Error: Identifier not found "shell"

so, I have changed uses linux to uses unix
 errors:
khachabash17.pas(72,10) Error: Identifier not found "Tsysinfo" khachabash17.pas(72,18) Error: Error in type definition khachabash17.pas(75,8) Error: Identifier not found "Sysinfo" khachabash17.pas(76,15) Error: Expression type must be class or record type khachabash17.pas(78,8) Error: Identifier not found "Uptime" khachabash17.pas(79,5) Error: Identifier not found "Uptime" khachabash17.pas(79,13) Error: Identifier not found "UpTime" khachabash17.pas(80,8) Error: Identifier not found "Uptime" khachabash17.pas(81,5) Error: Identifier not found "Uptime" khachabash17.pas(81,13) Error: Identifier not found "Uptime" khachabash17.pas(82,8) Error: Identifier not found "Uptime" khachabash17.pas(83,11) Error: Identifier not found "uptime" khachabash17.pas(86,25) Error: Identifier not found "Loads" khachabash17.pas(86,38) Error: Identifier not found "Loads" khachabash17.pas(86,51) Error: Identifier not found "Loads" khachabash17.pas(86,60) Error: Illegal expression khachabash17.pas(87,32) Error: Identifier not found "totalram" khachabash17.pas(87,48) Error: Illegal expression khachabash17.pas(88,32) Error: Identifier not found "freeram" khachabash17.pas(88,47) Error: Illegal expression khachabash17.pas(89,32) Error: Identifier not found "bufferram" khachabash17.pas(89,49) Error: Illegal expression khachabash17.pas(90,32) Error: Identifier not found "sharedram" khachabash17.pas(90,49) Error: Illegal expression khachabash17.pas(91,32) Error: Identifier not found "totalswap" khachabash17.pas(91,49) Error: Illegal expression khachabash17.pas(92,32) Error: Identifier not found "freeswap" khachabash17.pas(92,48) Error: Illegal expression khachabash17.pas(234,27) Error: Identifier not found "geteuid"

Same problem appear when using baseunix unit.

But when I use all units, for example uses linux, unix, baseunix, oldlinux then project compiles fine, but... anpther problem is ncrt. I useing ncrt unit... And program doesn't work as it works when compiled with 1.0.6 or 1.0.10 So, I replaced uses ncrt to uses crt, and it works now. What does it all men? Where can I find documentation about new freepascal units?

Thanks all

Marc

  • Administrator
  • Hero Member
  • *
  • Posts: 2557
fpc-1.9.3-040306 uses unix,linux,basunix,oldlinux again...
« Reply #1 on: May 03, 2004, 11:57:43 am »
Avoid using linux and oldlinux.

linux is obsolete and oldlinux is a temp replacement.
Use baseunix and unix instead.
//--
{$I stdsig.inc}
//-I still can't read someones mind
//-Bugs reported here will be forgotten. Use the bug tracker

 

TinyPortal © 2005-2018