Recent

Author Topic: Laz AutoUpdate component - beta  (Read 48728 times)

lainz

  • Hero Member
  • *****
  • Posts: 3651
    • Lainz
Re: Laz AutoUpdate component - beta
« Reply #30 on: December 18, 2016, 05:50:55 pm »
Has this been fixed yet so that it is usable?  I really want to include the ability to look for an update in my project and I don't want to reinvent the wheel.

I like this tool, but I maybe will use other way for my application, and I already tested it, is Windows only, since most of my applications are for Windows only.

1) Create an installer for your application, better with Inno Setup
2) Upload it somewhere
3) Create a JSON with the version information and the download url
4) Load the JSON with your application, if there's a new version, prompt the user to download it. If yes download and install the application, maybe with /silent or /verysilent mode. Of course you need to close your application first to ensure the exe is replaced correctly.

This always works. This is something like Notepad++ does.
https://lainz.github.io - My Website
https://lazpaint.github.io/ - LazPaint Downloads

Rayvenhaus

  • Jr. Member
  • **
  • Posts: 80
Re: Laz AutoUpdate component - beta
« Reply #31 on: December 18, 2016, 08:47:05 pm »
However, I need a cross-platform solution as my project it targeted at Unix/Win32 platforms so that wouldn't work for me.

lainz

  • Hero Member
  • *****
  • Posts: 3651
    • Lainz
Re: Laz AutoUpdate component - beta
« Reply #32 on: December 18, 2016, 09:50:46 pm »
I see.

In your case will be the same steps for windows, and for unix instead of making a setup making a deb, and running the command line to install it or open with the default application.

If your program is portable, don't have a deb, then you must wait for this component, or modify it to download from other places instead of sourceforge.
https://lainz.github.io - My Website
https://lazpaint.github.io/ - LazPaint Downloads

Rayvenhaus

  • Jr. Member
  • **
  • Posts: 80
Re: Laz AutoUpdate component - beta
« Reply #33 on: December 18, 2016, 09:54:15 pm »
I appreciate your input on this and I will wait for the author to update the component.

minesadorada

  • Hero Member
  • *****
  • Posts: 605
  • Retired
Re: Laz AutoUpdate component - beta
« Reply #34 on: December 19, 2016, 11:05:34 am »
I've made a tentative start. HTTPClient will replace synapse, and it will need SSL support with SourceForge & GitHub.  Looks very do-able but might take awhile depending on available coding time.  I need LazAutoUpdate to work again for some of my own apps, so there's an incentive.
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

Rayvenhaus

  • Jr. Member
  • **
  • Posts: 80
Re: Laz AutoUpdate component - beta
« Reply #35 on: December 19, 2016, 03:35:45 pm »
That's wonderful news!!

Rayvenhaus

  • Jr. Member
  • **
  • Posts: 80
Re: Laz AutoUpdate component - beta
« Reply #36 on: January 08, 2017, 01:15:17 pm »
Just curious, how are we looking on getting LazAutoUpdate working again?

minesadorada

  • Hero Member
  • *****
  • Posts: 605
  • Retired
Re: Laz AutoUpdate component - beta
« Reply #37 on: January 08, 2017, 02:07:50 pm »
I've been distracted writing a Foobot interface.  LazAutoUpdate is next on my list.
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

minesadorada

  • Hero Member
  • *****
  • Posts: 605
  • Retired
Re: Laz AutoUpdate component - beta
« Reply #38 on: January 13, 2017, 04:41:17 pm »
Just curious, how are we looking on getting LazAutoUpdate working again?
I've started this and so far results are encouraging.  Sourceforge downloads are working fine, and the code is a lot cleaner.
Lazautoupdate isn't just the component however, and there is lots of refactoring to do with the other parts yet.
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

Rayvenhaus

  • Jr. Member
  • **
  • Posts: 80
Re: Laz AutoUpdate component - beta
« Reply #39 on: January 13, 2017, 05:22:29 pm »
Looking forward to the release.   :)

minesadorada

  • Hero Member
  • *****
  • Posts: 605
  • Retired
Re: Laz AutoUpdate component - beta
« Reply #40 on: January 13, 2017, 06:12:34 pm »
It works fine in Linux, but Windows 10 permissions are defeating it unless the app is run 'as administrator' (when it works fine)

The stumbling block is AsyncProcess starting an external console app (updatehm) in Windows 10.  After a little web research, I can't see a way round this yet.

==Edit== Sorted. I have to use ShellExecuteEx with the 'runas' verb in the Windows 10 case.

Onwards and upwards!
« Last Edit: January 13, 2017, 07:22:51 pm by minesadorada »
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

minesadorada

  • Hero Member
  • *****
  • Posts: 605
  • Retired
Re: Laz AutoUpdate component - beta
« Reply #41 on: January 14, 2017, 09:18:10 am »
LazAutoUpdate component update to V0.2.0.0

* Rewrite of core updating code
* Available via OnlinePackageManager
  * Be sure to click 'Update' so that you get V0.2.0.0.
  * V0.1.27 is now deprecated.
* Read the 'readme_developer.txt' in /testapp before using
* Win32/64 and Linux32/64 only.

This is a work-in-progress, and needs testing thoroughly before deploying in a production environment.
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

GetMem

  • Hero Member
  • *****
  • Posts: 3753
Re: Laz AutoUpdate component - beta
« Reply #42 on: January 14, 2017, 09:50:08 am »
Hi minesadorada,

I attempted to add v0.2.0.0 as default to the main repository, but with Lazarus Trunk/FPC 3.0.0 it won't compile. It's the same issue we discussed before:
Basically you have to move(unit versionsuport.pas) LCLVersion to the interface uses, then add {$IF (lcl_major > 0) and (lcl_minor > 6)} LCLPlatformDef {$ENDIF}; to the implementation uses. You can also test with other combination Laz 1.6/1.6.2 but it should work.

minesadorada

  • Hero Member
  • *****
  • Posts: 605
  • Retired
Re: Laz AutoUpdate component - beta
« Reply #43 on: January 14, 2017, 10:00:14 am »
Hi minesadorada,

I attempted to add v0.2.0.0 as default to the main repository, but with Lazarus Trunk/FPC 3.0.0 it won't compile. It's the same issue we discussed before:
Basically you have to move(unit versionsuport.pas) LCLVersion to the interface uses, then add {$IF (lcl_major > 0) and (lcl_minor > 6)} LCLPlatformDef {$ENDIF}; to the implementation uses. You can also test with other combination Laz 1.6/1.6.2 but it should work.
OK Will do.  I'd assumed that OPM would only been used/seen by Laz 1.8/fpc3.11+ users.
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

minesadorada

  • Hero Member
  • *****
  • Posts: 605
  • Retired
Re: Laz AutoUpdate component - beta
« Reply #44 on: January 14, 2017, 10:24:30 am »
Hi minesadorada,

I attempted to add v0.2.0.0 as default to the main repository, but with Lazarus Trunk/FPC 3.0.0 it won't compile. It's the same issue we discussed before:
Basically you have to move(unit versionsuport.pas) LCLVersion to the interface uses, then add {$IF (lcl_major > 0) and (lcl_minor > 6)} LCLPlatformDef {$ENDIF}; to the implementation uses. You can also test with other combination Laz 1.6/1.6.2 but it should work.
Recompiled to V0.2.1.0.
Compiles in Trunk/trunk and Laz1.6.2/fpc3.0.0

Please test
GPL Apps: Health MonitorRetro Ski Run
OnlinePackageManager Components: LazAutoUpdate, LongTimer, PoweredBy, ScrollText, PlaySound, CryptINI

 

TinyPortal © 2005-2018