Forum > Embedded - ARM

Lazarus on DE1-SoC board ?

(1/2) > >>

pik33:
I have a DE1-SoC board. It is Altera FPGA with 2 core ARM processor. The board is running Linaro linux with LXDE.
IS it possible to get Lazarus working on this board?
I tried to use apt-get fpc, which returned whole bunch of 404 errors.
I use a Pi and I have installed a Lazarus on it - maybe there is possibility to transfer it from Pi?

hinst:
the command is

--- Code: ---apt-get install fpc
--- End code ---
>install<
consider running apt-get update before trying to install it btw

Suggestion №2: try installing it using fpcup

pik33:
Apt-get update failed because it tried to download from a directory which doesn't exist.

fpcup found not installed packages. libx11, libgdk_pixbuf, libpango, libgdk-x11-2.

hinst:
apparently you have your repository URLs not configured correctly. they should point to your linux distro's official package repository. if you don't fix this, you won't be able to install any packages. I suggest you find out your linux distro repository URLs and enter them in your apt config files. Also check that you have Internet access. ping google.com for example

after you fix this, install listed packages, then run fpcup, it installs lazarus to /home/you/development/lazarus

pik33:
The board is new and it seems the distro for this board was writtten in hurry and is in very alpha stage. Too many things are simply broken. I have 4 different sd images with different sizes; there is even an Ubuntu with gnome desktop.. but with broken ethernet driver. :(
LXDE version has an Ethernet working, but configuration is broken.
Lightweight framebuffer version has installed QT libraries, but no gcc.

So, at now I lost any hope to install Lazarus on it and I will be happy if I manage to install text mode fpc compliler.

Navigation

[0] Message Index

[#] Next page

Go to full version