Forum > WinCE

[SOLVED] Problems with settings for WinCE ( PSION'S Workabout Pro 3 )

(1/2) > >>

this is my first post here so be gentle ;)

First of all, i'm not pro in programming, well, to be honest i'm just a casual programmer.

I haven't used Lazarus for a long time. Last version was something from 0.9.x. That time i was able to correctly setup all needed options for wince and in result i got simple application for Windows CE 5.0

But now with 1.2.4 (and 1.2.2, haven't tested rest of them) I have a problem with setting up Lazarus for WinCE application. Well at least i think that is the problem.

I did everything from link below:

I've downloaded Lazarus, then cross-arm-wce-win32.exe
I've installed Lazarus (clean install, no old configs) then cross arm (just like in link above)
And next i've setup all (i think) options for wince application generation (pictures attached, polish localization of Lazarus).

Next i'm creating very simple app with only one form and a button on it with Close binded to it.
Ctrl+F9 -> ok, no errors (file size 1.98mb, after UPX ~624kb)

But when i'm trying to run this on emulator or on device itself nothing happens. (On PC i got 'Access denied')
Well, on emulator i got "project1' is not a valid Windows CE application." message.
On device i got nothing, no form nor any kind of message.

What did i wrong?
Or maybe there is someghing i'm missing to check in project options?
Or maybe i'm just to old for it ...

Help me out guys, please.


when I tried to build simple WinCE application (One form, one button), set LCLWidgetType, configured WinCE+arm CPU in compilation part of Options dialog - everything went fine.

Currently I`m developing one project for WinCE and I`m happy user of Lazarus  and Typhon.

Maybe you`ve device locked - check ggl how to unlock device.


Ok, let's assume that device is blocked.
But why i cannot run anything on virtual emulator?! :/

Only those 3 options should be marked for wince/arm?
LCL Widget Type: wince
Target OS: wince
Target CPU Family: arm

Edited ===================== :)
Day after.
I've uninstalled Lazarus and removed all files from its directory. Did totally clean instal (again). Also, i removed all MS emu for WinCE i got on my computer (it was a bit messy with them, too many unsuccessfull attempts).
Did clean download as described in Lazarus help.
Proper emu, proper images (but to run it i had to search ggl some time, Lazarus' help wasn't good with explanation at that point ;) ) anyway, after successful installation i've compiled sample app (one form, one button with Close;)
Works fine on emulator (finally)
but on device still no success.

I'ts 'PSION Workabout Pro3' (Windows 5.0). I've checked ggl and didn't find any info about locked device, instead I found that any app should work fine.

Well, maybe I wasn't to precise with info that on device it doesn't want to run. When i'm clicking it, outline shows for a (about) half a second from that icon and it's grows to whole screen but screen is empty.
It's just like it wanted to say "I WANT TO RUN THIS APPLICATION" but nothing happens...

PS: sorry for my english if messed up with tenses :)

Ok, i think I've discovered what is 'wrong' with that device.
This info could be helpfull for some of you in future.

Non of the Lazarus settings made that simple app to run on device (only on emulator).
I did more digging and found that Microsoft has released (some long time ago) Embedded Visual C++ (it's free for use) so I've downloaded it and also I've downloaded SDK for that device (i'ts only for C++/.NET/Java).
Firstly I've created new 'Hello World' application using SDK delivered with Embedded compiler (it's available in the File->New->Project->WCE Application, and then 'Sample Hello World application') and it didn't want to run either. Then after installing SDK for that particular device and a little change in Embedded Visual C++ (from drop down list) to select 'PsionTeklogixCE500' SDK, I've recompiled that source again and voila. Everything is working fine now. Device is able to run this simple app.

So i think that using Lazarus for creating apps for that piece of hardware is (for now) impossible because we must use devices SDK (and they aren't pascal sources).

But I can always be mistaken...

Have you tried to search forum for wince5 keyword, or google for wince5 lazarus problem?

I immediatelly had some hits and these are just some:,11942.msg60441.html#msg60441,12581.msg64885.html#msg64885,12726.msg65769.html#msg65769,7161.msg33685.html#msg33685


[0] Message Index

[#] Next page

Go to full version