Recent

Author Topic: [SOLVED] Application entering zombie state  (Read 1578 times)

tk

  • Sr. Member
  • ****
  • Posts: 367
[SOLVED] Application entering zombie state
« on: June 29, 2014, 12:23:52 pm »
Hi all,
I have an application which enters zombie state in Kubuntu/GTK2 after termination and I don't know the cause.
It happens always, with or without debugging.
After closing the main form the application goes to the final end  in the lpr file (it stops there on breakpoint) and then the app enters zombie state as can be seen in task manager.
When debugging it still can be paused, see attachments, snapshots of call stack and threads.

Interesting is that I have another applications which terminate correctly but this one not.
And I don't know where is the problem.

I'll try to cut off parts of source code to get the cause but if anybody knew the reason of this behavior it would spare me the lasting work :)

Thank you

« Last Edit: June 29, 2014, 03:03:44 pm by tk »

tk

  • Sr. Member
  • ****
  • Posts: 367
[SOLVED] Re: Application entering zombie state
« Reply #1 on: June 29, 2014, 03:01:28 pm »
I reply myself, finally it was not so difficult to find.
In this application I used a shared library which had IsMultiThread  set to True.
It seems that this variable has other meaning in Lazarus than in Delphi.
Safe way without IFDEFs is to set IsMultiThread to False in the library before it gets unloaded, e.g. in a finalization section.

 

TinyPortal © 2005-2018