Recent

Author Topic: [SOLVED] Fpcupdeluxe v1.62m (and 1.62o) generate error on new deployment  (Read 681 times)

ASBzone

  • Full Member
  • ***
  • Posts: 225
  • Automation leads to relaxation...
    • BrainWaveCC Utilities

A few weeks ago, I successfully deployed FPC 3.2 fixes / Lazarus 2.0 fixes using Fpcupdeluxe v1.62m x64 on Windows 10 Version 1809


Today, I decided to upgrade my build of FPC/Lazarus, and was told that v1.62o was available.  So, I used that version successfully to upgrade.


Then I went to my laptop running Windows 10 Version 1803, and uninstalled my older standalone instance of Lazarus 2.0R3, and used v1.62o x64 to install 3.2 fixes / 2.0 fixes. Successfully.


Flush with all this success, I went over to my another system running Windows 10 Version 1803 and tried the above.  v1.62m failed with one "make" error, and v1.62o failed with a different "make" error.  I've captured the latest error experienced.


This is the most prominent error:   

fpcupdeluxe: ERROR: FPCNativeInstaller (GetFile): Found make executable, but it is not GNU Make.



There's nothing in my path that should create this issue.

I went to yet a different machine to raise my spirits somewhat, but alas, I met with failure here as well.

Windows 10 x64 Version 1803

In between runs, I deleted the folders and tried again.  I ran Fpcupdeluxe with and without (mostly with) elevated permissions.


Summary:
1 -- Windows 10 x64 Version 1809 -- originally installed with v1.62m; successfully upgraded with v1.62o
2 -- Windows 10 x64 Version 1803 -- successfully installed with v1.62o

3 -- Windows 10 x64 Version 1803 -- unable to install with v1.62m or v1.62o
4 -- Windows 10 x64 Version 1803 -- unable to install with v1.62m or v1.62o
All versions of Fpcupdeluxe were x64, and were initially attempted with Windows-i386 cross compile enabled.
Unsuccessful attempts were subsequently tried without the cross-compile option.
« Last Edit: February 24, 2019, 02:47:44 pm by ASBzone »
-ASB: https://www.BrainWaveCC.com

Lazarus v2.0.3 r61159 / FPC v3.2.0-beta-r42011 (via FpcUpDeluxe) -- Windows 64-bit install w/32-bit cross-compile
Primary System: Windows 10 Pro x64, Version 1809 (Build 17763.379)
Other Systems: Windows 10 Pro x64, Version 1803 or greater

Cyrax

  • Hero Member
  • *****
  • Posts: 724
Re: Fpcupdeluxe v1.62m (and 1.62o) generate error on new deployment
« Reply #1 on: February 23, 2019, 12:04:27 am »

A few weeks ago, I successfully deployed FPC 3.2 fixes / Lazarus 2.0 fixes using Fpcupdeluxe v1.62m x64 on Windows 10 Version 1809


Today, I decided to upgrade my build of FPC/Lazarus, and was told that v1.62o was available.  So, I used that version successfully to upgrade.


Then I went to my laptop running Windows 10 Version 1803, and uninstalled my older standalone instance of Lazarus 2.0R3, and used v1.62o x64 to install 3.2 fixes / 2.0 fixes. Successfully.


Flush with all this success, I went over to my another system running Windows 10 Version 1803 and tried the above.  v1.62m failed with one "make" error, and v1.62o failed with a different "make" error.  I've captured the latest error experienced.


This is the most prominent error:   

fpcupdeluxe: ERROR: FPCNativeInstaller (GetFile): Found make executable, but it is not GNU Make.



There's nothing in my path that should create this issue.

I went to yet a different machine to raise my spirits somewhat, but alas, I met with failure here as well.

Windows 10 x64 Version 1803

In between runs, I deleted the folders and tried again.  I ran Fpcupdeluxe with and without (mostly with) elevated permissions.


Summary:
1 -- Windows 10 x64 Version 1809 -- originally installed with v1.62m; successfully upgraded with v1.62o
2 -- Windows 10 x64 Version 1803 -- successfully installed with v1.62o
3 -- Windows 10 x64 Version 1803 -- unable to install with v1.62m or v1.62o
4 -- Windows 10 x64 Version 1803 -- unable to install with v1.62m or v1.62o
All versions of Fpcupdeluxe were x64, and were initially attempted with Windows-i386 cross compile enabled.
Unsuccessful attempts were subsequently tried without the cross-compile option.

Somehow the forum software messed the error message up.

Quote
This is the most prominent error:   

fpcupdeluxe: ERROR: FPCNativeInstaller (GetFile): Found make executable, but it is not GNU Make.


Did you install the linux subsystem at some point?

EDIT : Ignore my question. Please check out that make.exe is indeed a binary file. And make sure that your antivirus software isn't interfering  execution of make.exe or other binaries. Also check if you need to unblock your downloaded files : https://www.tenforums.com/tutorials/5357-unblock-file-windows-10-a.html
« Last Edit: February 23, 2019, 12:13:24 am by Cyrax »

ASBzone

  • Full Member
  • ***
  • Posts: 225
  • Automation leads to relaxation...
    • BrainWaveCC Utilities
Re: Fpcupdeluxe v1.62m (and 1.62o) generate error on new deployment
« Reply #2 on: February 24, 2019, 03:01:14 am »
And make sure that your antivirus software isn't interfering  execution of make.exe or other binaries.

Also check if you need to unblock your downloaded files : https://www.tenforums.com/tutorials/5357-unblock-file-windows-10-a.html


The latter issue wasn't a problem, but the former was.


Machines #1, 3 and 4 are using the same AV software.
The AV on machine #1 is using a profile that already excludes certain folders, including the FPCupDeluxe folders
Machine 2 is using a different AV with a less aggressive setting.
The AV on machines 3 and 4, were set with *almost* the same config as machine 1, but for some reason, they only had the stand-alone Lazarus folders exempted.  On that profile (which I thought was the same as my primary machine), they weren't setup for the FPCupDeluxe folder.   


So, after some undetermined time, make.exe (and one or two others) would get nabbed.


That kind of issue gets logged, but does not raise an alert.   I never even thought to check the central AV console...    :-X


But all is working properly now.    Sorry for the false alarm.
-ASB: https://www.BrainWaveCC.com

Lazarus v2.0.3 r61159 / FPC v3.2.0-beta-r42011 (via FpcUpDeluxe) -- Windows 64-bit install w/32-bit cross-compile
Primary System: Windows 10 Pro x64, Version 1809 (Build 17763.379)
Other Systems: Windows 10 Pro x64, Version 1803 or greater