Recent

Author Topic: After installing 1.2  (Read 1909 times)

MoellerCLaus

  • Jr. Member
  • **
  • Posts: 67
    • Vig Foreningsprogram
After installing 1.2
« on: April 06, 2014, 03:14:03 pm »
I try to install my own components under 1.2 which worked before the update but the following message prevents me from getting any further.

clmcombobox.pas(46,7) Fatal: Can not find Controls used by clmCombobox, ppu=C:\lazarus\lcl\units\i386-win32\controls.ppu, package LCLBase

Seems to me that some how not all basic LCL(Base) were compiled? Any ideas

karaba

  • New Member
  • *
  • Posts: 49
Re: After installing 1.2
« Reply #1 on: April 06, 2014, 04:15:39 pm »
seems to me that lclbase is not in the required packages in your application/package. if it is try to remove and add it again.

Martin_fr

  • Administrator
  • Hero Member
  • *
  • Posts: 5801
    • wiki
Re: After installing 1.2
« Reply #2 on: April 06, 2014, 04:31:40 pm »
The quick fix:

- Chech fpc, (below),
then
- Menu "Tools" > Configure build Lazarus >
  there is a radio "Clean all, select it
  then build
- Also to be save. Menu "Tools" > Rescan fpc sources

-------------------------------
To know more about the error: on the messages window, right click, "copy all and hidden"
There are additional hints usually.

But it may be a problem with the upgrading.

A possible guess: You still use an old FPC, if you used an old fpc before, and did not "uninstall" during the new install, then you have 2 fpc installed.

The installer does not touch your config, so it still points to the old.

-----Check fpc:
Menu Tools > options

All entries (fpc, fpc sources, make) should contain 2.6.2

C:\lazarus\fpc\2.6.2\ .....

MoellerCLaus

  • Jr. Member
  • **
  • Posts: 67
    • Vig Foreningsprogram
Re: After installing 1.2
« Reply #3 on: April 06, 2014, 07:53:37 pm »
 :) Thanks you both for your help. Tried did not help.

I have now tried to uninstall Lazarus 1.2.0; deleted manually
* the directory c:\lazarus
* user appdata for lazarus

Installed again from scratch - no problems.
Added standard package Lazreport - compile and install went well.
Then tried to add package LazReportPDFExport - I get a dialog box with
One or more packages were not found. See package graph for result.

Seems to me that something in the setup of the packages in general or at least on my PC hangs or points to wrong packages.
I will try to investigate further.

karaba

  • New Member
  • *
  • Posts: 49
Re: After installing 1.2
« Reply #4 on: April 06, 2014, 08:18:57 pm »
lazReportPDFExport requires the Package PowerPDF which handles the pdf creation. You need to download it from the lazarus CCR (Code and Components Repository) manually. This is the reason why it is not installed by default.