Forum > Linux

Suse 9.1

<< < (2/2)

cybermonkey342:

--- Quote from: "Vincent" ---
--- End quote ---
How did you change the fpc.cfg? Did you make the changes in a fpc.cfg, that was used?


If you mean, if the fpc.cfg was in use, no. I just changed the fpc.cfg which ist after the installation in the /etc/ path and then started Lazarus. Then tried to compile, but it seems the compiler didn't notify the change... (Maybe you should delete the old path within the fpc.cfg??)
(I know it's not very smart just to copy the files into the new path, but it works..)

Vincent Snijders:
Sorry for my English, I didn't mean in use, but (how should I say it) whether is was actually used by lazarus when compiling.

It seems somehow your changes weren't picked up by the compiler.

Would you like to try the following:
Open in lazarus the compiler options dialog (depending on which version you are using in the project or the run menu) and press the Test button.

Scan the output for a line containing:
Reading options from file ....
What file is mentioned there?
If it is /etc/fpc.cfg, check if there are line like
Handling option -Fl/opt/....
Interpreting option -Fl/opt/....
and further down
Using library path: /opt/....

TIA
Vincent.

cybermonkey342:
Hum, I would say the FAQs are okay... I think it could be my fault... because you have to put a symbolic link into the opt/gnome... lazarus find it.
So now I should start PROGRAMMING  :D

Navigation

[0] Message Index

[*] Previous page

Go to full version